Logon data for CIFS mount

Hi@all,

I have integrated Ubuntu 19.10 into the UCS domain (ubuntu-domain-join).

Now I want to include the Windows shares of the master on the Ubuntu client. When I mount the share I have to enter the password every time:

root@pc001:/data# mount -t cifs //tux.gehr.lan/Downloads /data/Downloads/
Password for s.gehr@//tux.gehr.lan/Downloads

then it works . Sure, I could store the credentials (credentials=~/.smbcredentials) but that’s not the purpose of ADS. How do I get the client to take the login data of the logged in user?

with best
sven

Maybe this 2 posts helps:

HTH, Robert


That’s how I did it. Many thanks

1 Like

I have included the shares as follows:

<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Downloads" mountpoint="~/Downloads"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Texte" mountpoint="~/Texte"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Sicherheit" mountpoint="~/Sicherheit"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Projekte" mountpoint="~/Projekte"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Multimedia" mountpoint="~/Multimedia"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Bilder" mountpoint="~/Bilder"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Buchhaltung" mountpoint="~/Buchhaltung"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>
<volume fstype="cifs" server="tux.gehr.lan" options="vers=3.0" path="Bibliothek" mountpoint="~/Bibliothek"> <not><user>root</user></not> <not><user>sddm</user></not> </volume>

but the access is extremely slow. Only 8-10 MB/Sec :frowning:

The same shares are also released via NFS and I can write on them with 90-1110 MB/Sec

Yes, i had here similar at the beginning. The thing is Kernel Oplocks. So we here have only Sambashares. No mixed with NFS. So we did disable Kernel Oplocks in UCR. After restarting Samba and remouting the share. We will copy about 90/95MB/s.

But 8-10MB is really slow. Normal with Kernel Oplocks and default options are about 45-50MB/s.

which one of them:
grafik

I am using ZorinOS, based on ubuntu 18.04.
Remove the client and do step by step as here https://docs.vmware.com/en/VMware-Horizon-7/7.8/linux-desktops-setup/GUID-B4111821-34F2-465B-B290-FC2070EFCB5A.html

It definitely works