UEFI boot, "variable 'prefix' isn't set"

uefi

#1

Attempting to install UCS 4.1 on a Beelink Z83 II, I’m experiencing a similar issue to the one described in Bug 39009. I’m getting this:

Booting in insecure mode
error: variable `prefix´ isn´t set.
Loading step 1

…and then a grub prompt.

I have tried a couple of workarounds mentioned in Bug 39009:

I have removed /efi/boot from the ISO. This didn’t work because the Beelink Z83 II does not support legacy boot mode. There is no way to disable UEFI.

I have tried installing UCS_3.2-4-UEFI-amd64.iso. The Beelink Z83 II will not boot from a USB key with this ISO; it behaves the same as when booting from the 4.1 ISO without /efi/boot (ignores the USB key and attempts to boot from the hard drive).

I’d really appreciate any help with this. I’m trying to replace a Zentyal box because UCS is so much better.


Is it possible to build UCS on a Debian install?
#2

From BIOS change legacy and UEFI boot to legacy boot, it will work fine.


#3

Thanks, but, as I mentioned, there is no way to disable UEFI and use legacy boot on this PC.


#4

Hey there,

AFAIR the message “error: variable prefix isn't set.” isn’t even the main problem - these are just the last messages one sees when the boot gets stuck in the very next step. On that IBM x3650 M2 mentioned at the bug, that message was printed several times. I think it was once per possible boot device, but I’m not sure.

Any chance that a firmware update is available for that Beelink Z83 II?
You could also try the new UCS 4.2, which was released a couple of hours ago.


#5

Thanks, Grandjean. I’m not too hopeful on getting a firmware upgrade; Beelink support is apparently terrible. I will try the 4.2 release, and if that doesn’t work, I’ll try installing Debian and building UCS on it (Should that work?)


#6

UCS 4.2 release still doesn’t work. Same result as with 4.1.


#7

I guess that will not work.

Maybe you can boot another system and try to sync everything from an installed UCS system. But I’m not sure if it will work and if it is easy. Alternatively you can try to install another system with a virtualization solution on it like Debian with KVM and run UCS inside the virtual machine.

With UCS 3.x we had a separate UEFI DVD, so maybe you can give it a try and upgrade to UCS 4 afterwards: http://updates.software-univention.de/download/ucs-cds/ucs3.3-0/


#8

If I install to another system and then try to sync everything from there, that install must be UEFI as well; otherwise, the cloned install will still not boot on the Z83 II. (I’ve tried it.) So I’ve also tried:

  • Installing on a VirtualBox machine with EFI enabled. The installer hangs after unpacking init.

  • Installing on a Hyper-V Generation 2 (UEFI) machine with Secure Boot disabled. This gives the same result as on the Z38 II: I’m dropped to a grub prompt. (With Secure Boot enabled, the VM refuses to allow the installation to run due to not recognizing its signature.)

The Hyper-V result would at least give Univention a way of reproducing the issue without acquiring special hardware. Could someone there try that? I’ve already created a bug report (bug 44209).

The separate UEFI DVD for UCS 3.x doesn’t work either.

Edit: I don’t know why all my posts were suddenly flagged as spam a few minutes ago. I hope it doesn’t happen again, because they clearly are not spam.


#9

I’m sorry that this happened :sweat: I un-flagged all your posts within minutes. The system’s anti-spam detection was a bit … overambitious. It was somehow related to the number of hyperlinks to the same domain - but they are alle Univention’s domains and all your posts and links are valid. I will add this to our improvements backlog to make sure it doesn’t occur again.


#10

Ah, thanks very much. I appreciate it.


#11

Grandjean, how long does it usually take for someone to start working on a bug report?


#12

That depends on the number of pressing issues, so we usually cannot give a timeschedule for bugfixes. “Showstopper” will normally be addressed quite fast.


#13

Hello,
I had got same problem. My host is similar like your - an Lattepanda (x5-Z8350/4G/64GB)
The solution was this in my case:

  • I downloaded the Univention 4.1-0 (or below/lower) (grub-1.9x). The reason -> 4.1-1 (grub-2.x) and above/higher versions weren’t able to boot (I got the message: error: variable `prefix´ isn´t set.)
  • I installed the Univention 4.1-0. Important: In the last step of the installation you allow that the installer dowloads the updates! (It is patched the system at 4.1-5) If you unchecked the download updates checkbox the installer had finished the installation but after I couldn’t login into the web management neither as ‘Administror’ nor ‘root’. SSH was OK. I got some kind of DBUS error.
  • When the installation finished (4.1-5), I entered into the management console as ‘root’ and updated my system to the latest version (4.2-3)
  • After I login as ‘Administrator’ and registered my system (I uploaded my license)
    At now my system looks like is OK - I have got this bug (System-Fehlerdiagnose Überprüfe Gültigkeit der SSL Zertifikate) but otherwise everthing works in neatly.
    I hope this helps you
    (sorry for my English)