Kopano Webapp Fehler nach UCS Update 4.3

kopano
german
ucs-4-2
deutsch
php
ucs-4-3

#1

Hallo zusammen,

hab hier ein Problem mit Kopano bei bzw. nach dem Update auf UCS 4.3.

Das Update hängt nach einer Weile in der Weboberfläche, im Update-Log finden sich dann folgende Einträge:

Fehler traten auf beim Bearbeiten von:
 php7-mapi
 kopano-dagent
 kopano-server-packages
 kopano4ucs-webapp
E: Sub-process /usr/bin/dpkg returned an error code (1)
Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade"

Nach einem Neustart und dem erneuten Ausführen des Upgrades auf 4.3 bekommt man nach kurzer Zeit die Meldung “Update erfolgreich”.

Ruft man nun die Webapp auf bekommt man einen “Internal Error”. Beim durchsuchen des Forums bin ich auf die Apache2-Module gestoßen. Der Versuch das Modul “PHP7.0” zu starten wurde mit der Meldung “Module does not exist’s” abgebrochen. Bei Prüfung der installierten Pakete stellte ich fest das manche PHP7-Pakete nicht installiert wurden. Händisch nachinstalliert und auf dem Apache aktiviert. Nun erhalte ich folgende Meldung:

PHP-Mapi ist aber laut Paktmanager installiert.

Beim Ersten Versuch letzte Woche scheiterte das Update noch an Einstellungen (Values) von Z-Push die laut Recherche in PHP7 eh nicht mehr benutzt werden, diese habe ich testweise auskommentiert, danach ließ sich auch der Apache wieder starten.

Könnte mir hier vielleicht jemand weiterhelfen?

Vielen Dank!


Update auf 4.3, Apache startet nicht mehr
#2

Huhu,

  1. Bitte verifizieren Sie, dass Apache2-PHP-7.0-Modul und das MAPI-Modul dafür installiert sind: univention-install libapache2-mod-php7.0 php7-mapi
  2. Bitte verifizieren Sie, dass Apache das PHP7.0-Modul und nicht das PHP5-Modul nutzt: a2dismod php5 ; a2enmod php7.0
  3. Bitte verifizieren Sie, dass das MAPI-Modul für PHP7.0 aktiv ist: phpenmod kopano ; php5dismod kopano (warum letzteres: siehe dieser Post)
  4. Starten Sie den Apache neu: systemctl restart apache2.service
  5. Versuchen Sie einen erneuten Zugriff.

Gruß
mosu


#3

Hallo,

vielen Dank für die Rückmeldung, nach ihren Angaben ist die Webapp jetzt wieder erreichbar, eine Testmail geht auch raus…
Allerdings funktioniert das Files-plugin per smb nicht mehr und zeigt einen “HTTP 500, Internal Server Error”
image

und im Update.log habe ich folgende Einträge gefunden:

Paketlisten werden gelesen...
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component kopano-webmeetings_20170808134523/all/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component kopano-webmeetings_20170808134523/amd64/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/all/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/amd64/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/kopano-webmeetings_20170808134523/all/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/kopano-webmeetings_20170808134523/amd64/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/z-push-kopano_20170630110344/all/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/z-push-kopano_20170630110344/amd64/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

Hat dies irgendetwas zu bedeuten?

Danke


#4

Huhu,

Was sagt denn das Apache-Fehler-Log in dem Moment, wenn dieses Fehler-Popup angezeigt wird?

Ist das nur temporär, sprich läuft ein manuell gestartetes apt update sauber durch? Hängt da irgendwie ein Proxy-Server dazwischen?

Gruß
mosu


#5

already reported at https://forum.kopano.io/topic/1200/kopano-webapp-filesbackend-smb-php7


#6

Nach dem Beitrag aus dem Kopano-Forum hab ich das Files-Plugin auch zum Laufen gebracht.
Allerdings sehr umständlich für eine App aus dem App-Center.

Hoffe das nun alles fehlerfrei läuft, auch bei zukünftigen Updates.

Weiterhin ist diese Meldung mit den “ungültigen Signaturen” weiterhin vorhanden.
In der Zwischenzeit hatte ich den Mailserver auch testweise komplett neu aufgesetzt und auch da lief die Kopano erst nach den oben genannten Änderungen und auch die Signaturwarnungen waren dort vorhanden, was mich etwas stutzig macht.


#7

ich erhielt letzte Woche eine Email von Univention, dass die Signaturen für alle 4.1 App Repositories neu generiert wurden und 4.3 damit jetzt auch zufrieden sein sollte. Getestet habe ich dies aber noch nicht.


#8

Danke für die Rückmeldung.

Die Meldungen sind nicht weg aber etwas weniger geworden, betrifft jetzt nur noch z-push.

Fehl:142 https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/all/ Release.gpg
  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
Fehl:144 https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/amd64/ Release.gpg
  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
Paketlisten werden gelesen... Fertig
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/all/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://appcenter.software-univention.de/univention-repository/4.1/maintained/component z-push-kopano_20170630110344/amd64/ Release: Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/z-push-kopano_20170630110344/all/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Fehlschlag beim Holen von https://appcenter.software-univention.de/univention-repository/4.1/maintained/component/z-push-kopano_20170630110344/amd64/Release.gpg  Die folgenden Signaturen waren ungültig: 3550FB4CC61FDB88D334E31A1DD67AFB2CBDA4B0
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

#9

Meine Lösung unten