Kein DHCP nach Installation von UCS@School

Hallo !

Nach Abschluss der Basisinstallation mit

Active Directory-kompatibler Domänencontroller
DHCP-Server
Software-Installationsmonitor

sowie der abschließenden Konfiguration des IP-Adressbereiches des voreingestellten Subnetzes
für den DHCP-Server funktioniert der Dienst.
Die Clients erhielten wie erwartet IP-Adressen vom UCS.
Dies sehe ich als Grundvoraussetzung für die weitere Installation und Nutzung von UCS@School.

Sobald ich danach aber UCS@School installierte funktionierte der DHCP-Server nicht mehr.

Systemdienste
univention-dhcp - gestoppt - Automatisch - DHCP-Server

Er ließ sich trotz geduldigem Studiums der Univention Hilfe, u.a. hier


oder hier

mit meinen Kenntnissen auch nicht mehr reparieren.

Letzte Hinweise dazu:

# tail -f -n 10 /var/log/univention/dhcp.log    erzeugte fortlaufende Zeilen von
...
21.08.20 12:09:20.451  DEBUG_INIT

# tail -f -n 10 /var/log/dhcp-ldap-startup.log   ergab diese Meldungen
...
#DHCP Service
  option domain-name "gsg34.dd-dns.de";
option wpad "http://server1.gsg34.dd-dns.de/proxy.pac";

Ein Blick in die /etc/dhcp/dhcpd.conf zeigte nach der Installation von UCS@School zwei neue Einträge:

...
option wpad code 252 = text;
authoritative;

Ein …

# journalctl -xn
-- Logs begin at Thu 2020-08-20 10:26:37 CEST, end at Fri 2020-08-21 12:47:42 CEST. --
Aug 21 12:47:42 server1 dhcpd[6107]: LDAP: cannot parse dhcpService entry 'cn=grundschule,cn=dhcp,ou=Grundschule,dc=gsg34,dc=dd-dns,dc=de'
Aug 21 12:47:42 server1 dhcpd[6107]: Configuration file errors encountered -- exiting
Aug 21 12:47:42 server1 dhcpd[6107]: ...

Mir ist nicht klar, ob der Fehler in der dhcpd.conf zu suchen ist oder im LDAP-Verzeichnis.
Kann mir hier jemand helfen.

Vielen Dank …

Die Lösung:

Die Installation von UCS@School erzeugt ein weiteres DHCP-Dienst-Objekt,
hier mit dem Kürzel/der OU für die Schule (gs).
In diesem fehlt ein DHCP-Subnetz-Objekt.

grafik

HINZUFÜGEN > DHCP: Subnetz > WEITER > Grundeinstellungen - DHCP-Subnetz

grafik

Ergebnis

grafik

# systemctl restart univention-dhcp.service

# cat /var/log/univention/dhcp.log

#DHCP Service
	subnet 192.168.20.0 netmask 255.255.255.0 {
	range 192.168.20.101 192.168.20.120;
	option routers 192.168.20.7;
	option domain-name "gsg34.dd-dns.de";
	option domain-name-servers 192.168.20.204;
	}

Mit diesen Einstellungen war/ist das o.g. Problem behoben.