Erster UCC installieren

german

#1

Hallo zusammen,

ich würde nun gerne meinen ersten UCC installieren aber habe da wie so oft ein paar Fragen. Durch den Quick-Start habe ich mich schon mal geslesen, am Handbuch bin ich noch.

Im Quick-Start steht es handelt sich um einen Linux-Client mit KDE. Ich meine mich zu erinnern etwas gelesen zu haben dass es mittlerweile ein Ubuntu mit dessen eigenen Desktop ist?

Vor längrer Zeit habe ich mal nachgefragt ob es ein Client-Image in 64 BIt gibt. Damals war die Antwort “offiziell nicht”. Hat sich daran inzwischen etwas geändert?

Ich würde gerne mit einem 64 Bit Linux UCC mit aktuellem KDE Plasma arbeiten. Ist dies das irgendwie mit einen, für einen UCC-Erstuser vertretbaren Aufwand, möglich?

Viele Grüße
Sven


#2

Am liebsten würde ich diese Distribution nutzen:

https://neon.kde.org

aber leider weiß ich noch gar nicht wie genau die Verzahnung von UCC mit UCS ist.

Kann ich damit irgendwie ein UCC-Image erstellen?


#3

und was mir gerade auffällt ist dass der UCC ja kostenpflichtig ist. Ich finde aber nirgends einen Preis. In meinem Fall wären das 1 User mit zwei Clients (PC & Laptop). Kann mir jemand sagen was das kostet?


#4

Ja, das UCC 3-Desktop-Image ist jetzt offiziell in 64 Bit.

Also ich konnte es problemlos direkt auf den Clients installieren. Daraus ein Image zu bauen, hat hat mal jemand, leider erfolglos, probiert. Aber eigentlich sehe ich keinen Grund, wieso das nicht funktionieren würde. Wenn du genügend Clients zu versorgen hast, würde ich es an deiner Stelle mal selber probieren.

UCC ist AFAIK in den kostenlosen Lizenzen (Free for personal use, UCS Core) enthalten. Bei mir hat zumindest noch keiner deswegen geklingelt :wink:


#5

Da ist wider mein Verständnis-Problem. “Direkt installieren” bedeutet ISO von der Projekt-Homepage herunterladen und auf PC und Laptop installieren, oder? Aber dass mach ich ja ohnehin und damit habe ich doch keinen UCC. Oder installiere ich wie gehabt und mach die Installation nachträglich zum UCC?


#6

Direkt Installieren heißt, daß erst das UCC-Image ohne KDE neon auf den Client ausgerollt wird, anschließend das neon-Repository hinzugefügt wird und neon mittels

aptitude install neon-desktop neon-all neon-keyring neon-settings

installiert wird.


#7

Danke, hab’s kapiert. Werde ich gleich mal testen.


#8

Letzte Frage bevor ich installiere: Ich habe jetzt lediglich den ersten Benutzer der den UCC nutzen soll eingerichtet und den Client unter Rechner angelegt. Ich habe noch keine Freigaben definiert. Muss ich nun noch eine Freigabe für das Home anlegen oder passiert dies automatisch?


#9

Für jedes UCS-System wird AFAIK automatisch eine Freigabe von /home erstellt. Diese müßtest du aber manuell per Richtlinie an die UCC-Systeme verteilen. Außerdem muß auf diesen das Paket nfs-common installiert werden. Das geht leider wirklich nicht im Image. Aber das könntest du problemlos per Richtlinie machen.


#10

Auf dem Server habe ich alles wie im Quick-Start beschrieben durchlaufen. Die Images liegen in:

root@tux:/var/lib/univention-client-boot# ls
95ucc-3.0-rev2-desktop-image.img.inst  ldlinux.e32        pxelinux.0      syslinux.efi64                         ucc-3.0-rev2-desktop-image.img.kernel
custom_start_scripts                   ldlinux.e64        pxelinux.cfg    ucc-3.0-rev2-desktop-image.img         ucc-3.0-rev2-desktop-image.img.md5
ldlinux.c32                            partition-scripts  syslinux.efi32  ucc-3.0-rev2-desktop-image.img.initrd  ucc-3.0-rev2-desktop-image.img.xz.spec

Den Rechner habe ich korrekt angelegt und dort ist auch dieses:

ucc-3.0-rev2-desktop-image.img

ausgewählt. Es wurde die Fraigabe:

client-boot
/var/lib/univention-client-boot

angelegt. Ich starte den PC mittles PXE, bestätige continue mit yes und erhalte die Fehlermeldung:

Begin: Runing /scripts/init-premount … Error: The UCC image assigned to this client (configure …) could not be found
192.168.24.5:/var/lib/univention-client-boot

Aber die Daten stimmen alle und im Netzwerk ist der Client auch korrekt. Starte ich ihn mit einem Live-System bekommt er die festgelegte IP


#11

Habe ein Post gefunden dass der NFS nach hinzufügen der Freigabe nicht gestarett wird. Nach Neustart funktioniert es


#12

Ich habe gemäß Anleitung installiert was nun auch fehlerfrei durch lief. Wenn ich mich mit dem Benutzer am Client anmelden möchte heißt es lediglich:

Invalid password …

Es ist aber korrekt.

Ein hinweis noch. Am Master wurd keine Freigabe für /home angelegt. Muss man dies manuell machen?


#13

noch vergessen zu erwähnen.

Ich werde automatisch mit Guest angemeldet aber da kann ich ja nicht wirklich was tun.


#14

Mit Guest wird man eigentlich nur angemeldet, wenn der Client nicht gejoint ist. In dem Fall funktioniert natürlich auch die Anmeldung mit einem Domain-Konto nicht


#15

Wir der Join nicht automatisch durchgeführt?

Im Handbuch finde ich zwar den Befehl wie man den Join ausführt aber ich finde auf dem Desktop weder eine Konsole um die durchzuführen. Mit Alt Strg n?F1 komme ich zwar auf die Konsole aber ich habe ja keinen Login.


#16

ich denke ich habe gerade gemerkt woran es liegt. Die Installation startet mit englischem Tastatur-Layout. Mein Passwort hat Sonderzeichen.

Kann man die Installation mit deutscher Tastatur starten?


#17

Also die Variabeln in der ConfigReg sind nach meinem Dafürhalten alle richtig. Als Richtlinie für den Rechner habe ich:

cn=ucc-desktop-settings,cn=ucc,cn=policies,dc=gehr,dc=lan

gewählt. Ich habe mal zusätzlich darin mal die Variablen:

locale = de_DE.UTF-8
XkbLayout = de
timezone = Europe/Berlin

gesetzt was aber nichts ändert. Die Installation läuft mit dem US-Keyboard-Layout


#18

Ich habe nun das Passwort einfach auf’s US-Layout “übersetzt”. Der Join wird ausgeführt aber mit meinem User kann ich mich nicht anmelden. Genauso wenig mit “Administrator”.


#19

Auch nicht mit dem Paßwort nach deutschem Tastatur-Layout?


#20

Im Quickstart steht: “Benuzer mit minimalen Angaben…” Die Anmeldung klappt wenn er in der gruppe Users ist. Allerdings habe ich das Problem das die DNS-Auflösung nicht korrekt funktioniert.

In der resolv.conf steht die richtige domain aber 127.0.1.1 als nameserver.