Clients erkennen Netzwerk nur noch als "öffentliches Netzwerk", nicht als "Domain Netzwerk"


#1

Hi,

alle Clients erkennen das Netzwerk plötzlich nur noch als “öffentliches” Netzwerk oder stellen den User vor die Frage um welches Netzwerk es sich handelt. Er erkennt also nicht mehr das es sich um ein Domainnetzwerk handelt. Jahrlang war es kein Problem… Es wurden in letzter Zeit keinerlei Änderungen am System gemacht. Alles andere funktioniert, User können sich anmelden, DHCP vergibt ordentlich IP’s und der DNS läuft auch.

Gruss!

Erik


#2

Neuen Router installiert ?


#3

nein nichts dergleichen


#4

Vermute etwas liegt an fehlenden DNS Einträgen (obwohl in der Weboberfläche zu sehen), jemand eine Idee?

root@ucs:~# /usr/share/univention-samba4/scripts/check_essential_samba4_dns_records.sh
Host gc._msdcs.gr.gc not found: 3(NXDOMAIN)
_gc._tcp.gr.gc has SRV record 0 100 3268 ucs.gr.gc.
Host _ldap._tcp.gc._msdcs.gr.gc not found: 3(NXDOMAIN)
_ldap._tcp.gr.gc has SRV record 0 100 389 ucs.gr.gc.
Host _ldap._tcp.dc._msdcs.gr.gc not found: 3(NXDOMAIN)
Host _ldap._tcp.pdc._msdcs.gr.gc not found: 3(NXDOMAIN)
Host _ldap._tcp.d3dbc4bd-0acf-4605-8bdf-3a4aa0a83b84.domains._msdcs.gr.gc not found: 3(NXDOMAIN)
Host _kerberos._tcp.dc._msdcs.gr.gc not found: 3(NXDOMAIN)
_kerberos._tcp.gr.gc has SRV record 0 100 88 ucs.gr.gc.
_kerberos._udp.gr.gc has SRV record 0 100 88 ucs.gr.gc.
_kpasswd._tcp.gr.gc has SRV record 0 100 464 ucs.gr.gc.
_kpasswd._udp.gr.gc has SRV record 0 100 464 ucs.gr.gc.
Located DC 'ucs' in site 'Default-First-Site-Name'
Host 8f407b41-55f5-4b2a-9b1b-32faefa679da._msdcs.gr.gc not found: 3(NXDOMAIN)
## Records for site Default-First-Site-Name:
_ldap._tcp.Default-First-Site-Name._sites.gr.gc has SRV record 0 100 389 ucs.gr.gc.
Host _ldap._tcp.Default-First-Site-Name._sites.dc._msdcs.gr.gc not found: 3(NXDOMAIN)
_kerberos._tcp.Default-First-Site-Name._sites.gr.gc has SRV record 0 100 88 ucs.gr.gc.
Host _kerberos._tcp.Default-First-Site-Name._sites.dc._msdcs.gr.gc not found: 3(NXDOMAIN)
## Optional GC Records for site Default-First-Site-Name:
_gc._tcp.Default-First-Site-Name._sites.gr.gc has SRV record 0 100 3268 ucs.gr.gc.
Host _ldap._tcp.Default-First-Site-Name._sites.gc._msdcs.gr.gc not found: 3(NXDOMAIN)
_kerberos.gr.gc descriptive text "GR.GC"


#5

weitere details:

irgendwie scheinen einträge “doppelt” im samba dns zu sein…

grafik

auch habe ich ein reject, den ich nicht weg bekomme:

root@ucs:~# univention-s4connector-list-rejected

UCS rejected


S4 rejected

    1:    S4 DN: DC=@,DC=gr.gc,CN=MicrosoftDNS,DC=DomainDnsZones,DC=gr,DC=gc
         UCS DN: zonename=gr.gc,cn=dns,dc=gr,dc=gc

        last synced USN: 1524739

auch bekomme ich connector error:

08.07.2019 10:02:36.276 LDAP        (INFO   ): dns con2ucs: Object (zonename=gr.gc,cn=dns,dc=gr,dc=gc) is of type forward_zone
08.07.2019 10:02:36.276 LDAP        (INFO   ): __get_s4_msdcs_soa: search _msdcs in S4
08.07.2019 10:02:36.277 LDAP        (INFO   ): Search S4 with filter: (&(objectClass=dnsZone)(DC=_msdcs.gr.gc))
08.07.2019 10:02:36.277 LDAP        (INFO   ): Search S4 with filter: (&(objectClass=dnsZone)(DC=_msdcs.gr.gc))
08.07.2019 10:02:36.278 LDAP        (INFO   ): Search S4 with filter: (&(objectClass=dnsZone)(DC=_msdcs.gr.gc))
08.07.2019 10:02:36.279 LDAP        (INFO   ): encode_s4_object: attrib objectGUID ignored during encoding
08.07.2019 10:02:36.280 LDAP        (INFO   ): __get_s4_msdcs_soa: search DC=@ for _msdcs in S4
08.07.2019 10:02:36.280 LDAP        (INFO   ): Search S4 with filter: (objectClass=dnsNode)
08.07.2019 10:02:36.281 LDAP        (INFO   ): encode_s4_object: attrib objectGUID ignored during encoding
08.07.2019 10:02:36.282 LDAP        (INFO   ): encode_s4_object: attrib dnsRecord ignored during encoding
08.07.2019 10:02:36.282 LDAP        (INFO   ): object_from_element: olddn: DC=@,DC=_msdcs.gr.gc,CN=MicrosoftDNS,DC=ForestDnsZones,DC=gr,DC=gc
08.07.2019 10:02:36.282 LDAP        (ERROR  ): Unknown Exception during sync_to_ucs
08.07.2019 10:02:36.283 LDAP        (ERROR  ): Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/univention/s4connector/__init__.py", line 1540, in sync_to_ucs
    result = self.property[property_type].ucs_sync_function(self, property_type, object)
  File "/usr/lib/python2.7/dist-packages/univention/s4connector/s4/dns.py", line 1745, in con2ucs
    ucs_zone_create(s4connector, object, dns_type)
  File "/usr/lib/python2.7/dist-packages/univention/s4connector/s4/dns.py", line 1431, in ucs_zone_create
    soa['serial'] = str(max(int(soa['serial']), int(msdcs_soa['serial'])))
KeyError: 'serial'

hoffe ihr könnt mir helfen.

Danke! 

#6

stelle ich das dns backend auf ldap geht “alles”, nur dann bekomme ich:

grafik


#7

Ich würde mir dies ansehen :

lg

Christian


#8

bringt leider nichts, univention-s4search DC=_msdcs --cross-ncs dn bringt:

root@ucs:~# univention-s4search DC=_msdcs --cross-ncs dn
# record 1
dn: DC=_msdcs,DC=gr.gc,CN=MicrosoftDNS,DC=DomainDnsZones,DC=gr,DC=gc

# returned 1 records
# 1 entries
# 0 referrals

ausserdem mit samba4 backend:

root@ucs:~# host gc._msdcs.$(ucr get domainname) 127.0.0.1
Using domain server:
Name: 127.0.0.1
Address: 127.0.0.1#53
Aliases:

Host gc._msdcs.gr.gc not found: 3(NXDOMAIN)


#9

ist es nicht irgend einfach möglich den samba4 DNS zu “löschen” und vom ldap “neu” zu generieren?


#10

Doch, ist es; wird im folgenden Support-DB-Artikel beschrieben:

Vorher Backups und/oder Snapshots anlegen.