Zarafa mit Spamfilter und Virenscan

german

#1

Hallo zusammen,

ich nutze Zarafa auf UCS 4.0-0 errata17. Die Clients sind mit Outlook bzw. Z-Push oder imap angebunden.

Wie schaffe ich es, dass alle Emails bevor sie in die Postfächer der User einsortiert werden auch nach Spam und Viren gescannt werden?

/etc/fetrchmailrc:

poll imap.strato.de with proto IMAP auth password user 'user@domain.com' there with password 'geheim' mda "/usr/bin/zarafa-dagent test" ssl keep

So wie ich das verstanden habe, muss die SPAM- und Virenprüfung doch vor der Übergabe an den “mda - zarafa-dagent” erfolgen. Dazu habe ich aber keine Informationen in der Dokumentation gefunden.

Bin für jeden Tipp dankbar.

Gruß
Hasenhubert


#2

Hallo,

wenn Sie den dagent verwenden, können Sie den lokalen Antivirus-/Antispam-Stack nicht einbinden. Das ist allgemein nur empfohlen, wenn man einen entsprechend abgesicherten externen und vertrauenswürdigen Mailserver hat.
Anstelle der offensichtlich manuellen Konfiguration wäre entweder die Fetchmail-Integration aus dem AppCenter oder etwas gleichwertiges sinnvoller.
Siehe auch UCS 3.2 + Zarafa + fetchmail.

Viele Grüße,
Dirk Ahrnke


#3

Hallo zusammen,

habe die meine Konfiguration entsprechend angepasst und nutze nun den dagent nicht mehr.

Leider erfolgt aber immer noch keine SPAM-Filterung. Das Paket univention-spamassassin ist installiert und die Filterung sollte doch automatisch aktiv sein.
Auch in den UCR-Variablen ist “Antivir”- und “antispam”- aktiviert.

Mit freundlichem Gruß
Hasenhubert


#4

Hat sich erledigt.
Da Zarafa wohl den Outlooksupport einstellt ist es hinfällig hier in irgendeiner Form Zeit und Mühe zu investieren.
Ich werde mich nach einer anderen Lösung umsehen müssen.
Mit einer funktionsfähigen Outlookanbindung steht und fällt auch einiges mehr.


#5

Hallo,

ich möchte dieses Thema noch einmal aufgreifen.

Ich nutze ebenfalls kein Fetchmail. Mein MX Eintrag zeigt auf meinen eigenen Mailserver den ich mit Zarafa betreibe.

Ist es mit diesem Setup nicht möglich eine antiviren/spam funktionalität einzubinden?

Hin und wieder gibt es emails die bei mir im Spam Ordner landen. Wie kommt dies zustande? Zarafa scheint dem zu folge nach der Standardinstallation schon irgendwie Emails Filtern können.

edit= ich habe gerade gesehen, dass scheinbar spamassasin automatisch mit installiert wird. Das heißt Spamassassin scheint die arbeit zu übernehmen. Damit ist meine Frage soweit eigentlich auch beantwortet wenn dem so ist.

Danke.

Gruß,


#6

Hallo,

das Verhalten des Spam- und Virenfilters wird, sofern die Pakete “univention-spamassassin” und “univention-antivir-mail” installiiert sind, über die UCS-Variablen “mail/antivir/" und "mail/antispam/” gesteuert.

Zarafa hat im dagent per default folgende Einstellungen:

[code]# The following e-mail header will mark the mail as spam, so the mail

is placed in the Junk Mail folder, and not the Inbox.

The name is case insensitive.

set to empty to not use this detection scheme.

spam_header_name = X-Spam-Status

If the above header is found, and contains the following value

the mail will be considered as spam.

Notes:

- The value is case insensitive.

- Leading and trailing spaces are stripped.

- The word ‘bayes’ also contains the word ‘yes’.

spam_header_value = Yes,[/code]

Wer diese Konfiguration nicht mag, kann sich die UCR-Variablen zarafa/cfg/dagent/spam_header_value und zarafa/cfg/dagent/spam_header_name nach Bedarf setzen.

Viele Grüße,
Dirk Ahrnke


#7

Danke für die Ausführung.


#8

Hallo zusammen,

auch ích greife das Thema nochmal auf. Wir haben ein Qnap NAS mit UCS Virtualisierung mit Zarafa. Dort sind die Pakete “mail/antivir/" und "mail/antispam/” vorhanden und auch eingerichtet bzw. entsprechend aktiviert. Leider erfolgt aber immer noch keine SPAM-Filterung. Auch in den UCR-Variablen ist “Antivir”- und “antispam”- aktiviert. In den Mailheader kann ich das X-Virus-Scan Flag sehen:“X-Virus-Scanned: by amavisd-new-2.6.4” , aber der X-SPAM-Flag fehlt und es findet auch definitiv keine Spamfilterung statt.
Nun habe ich bereits einen ganzen Tag damit verbracht, alle möglichen Config-Files durchzusehen. Ich kann den Fehler einfach nicht finden. Kann mir hier jemand einen Tip geben, an welcher Stelle Änderungen vornehmen muss? Ich danke allen im Voraus!

MfG S. Hönes


#9

Hallo,

ich glaub, dass die X-Header erst ab einem Score von 5 gesetzt wird. Wenn Sie Zweifel haben, dass SpamAssassin arbeitet, könnte Sie mal mail/antivir/amavis/debug/level setzen. Dann müsste eigentlich auch der durch Amavis getriggerte SA Spuren im Log hinterlassen.

Viele Grüße,
Dirk Ahrnke


#10

Hallo,

Danke für den Hinweis. Das werden wir mal testen.
Viele Grüße
S. Hönes


#11

Allerdings werden auch die Test-Spammails nicht erkannt … Aber wir werden mal das Logfile auf Debug einstellen.

Viele Grüße
S. Hönes