Using ZFS with UCS

Anyone here with experience from using ZFS filesystem with UCS. Planning on using a ZFS filer for my KVM VM’s.
Would it be possible to install UCS on top of ZFS.

Feedback would be appreciated.

1 Like

Hi,

as UCS is (more or less) Debian you could try this link.

But I am not aware someone has tried this. I know from my own experience having UCS with BTRFS for data. So just using ZFS for data should be much easier than putting the complete system (incl /) on ZFS.

/CV

i am using zfs with proxmox and running ucs as a guest
the trick is to share the files with nfs and pickup with ucs as a dc
you can find a example here

Thats great, however I’m not using Proxmox and not planning to.

My ambition is to stay with UCS for servers and Ubuntu for clients, possibly a single Windows10 laptop.
I was hoping for a scenario where I can set up a UCS file server on top of ZFS one way or another.
My box has 16 GB RAM, 3x1Tb HDD, 2x250GB SSD (SATA 3). The motherboard has a RAID controller and I have added 1XSATA3 PCI RAID controller. The HDD’s are on the motherboard and the SSD’s on the PCI controller

I have a UCS domain with two UCS-KVM servers in production. I was hoping for a more flexible solution for storing my VM’s and a better solution for snapshots. Currently I’m using local storage for my VM’s and that’s a bit cumbersome. As I’m understanding it, is iSCSI not supported on Linux with ZFS so I guess I have to do with NFS, will 1Gb Nics be sufficient for data transfer? Currently I have a light load on all servers both virtual and physical.

I have an idea but I dont know if it’s viable.

  1. Set up a 40 GB partition on as mirror on the SSD. leaving the remainder (210 GB) for ZFS intent log and possibly L2ARC.
  2. Install UCS file/printserver on the 40 GB partition.
  3. Install ZFS on the file/printserver
    4 Configure the rest of the storage with ZFS

I understand that FreeNAS could be a solution but that means I no longer have a consistent serverplatform.

Any suggestion.

I GOT IT ! host on SSD RAID1 (ext4) and the rest of the storage as ZFS Raidz.

However I haven’t made any performance test yet.

I haven’t figured out yet how to set up ZFS as Univention boot and root yet. What I did is a Univention setup master DC onto a software RAID 1 on my SSD drives. Leaving the 3 hard-drives not configured.
Using https://linuxhint.com/install-zfs-debian/ the installation was a breeze no hiccups at all, only difference was that the hard-drives were already set up as a ZFS pool from my previous experiment with FreeNas. Using “zpool import -f tank1” solved the problem.
My first Univention server is a primary DC with file/print, KVM and UVMM.

  1. First I changed the KVM default pool to /tank1/iocage/images (the folder structure came from my FreeNas experience. I first destroyed the /var/lib/libvirt/images pool and created /tank1/iocage/images pool only to realize that there was a UCR variable that I needed to change. my guess is that I only had to change the UCR variable.
  2. Created a Univention share on /tank1/iocage/images as Images and it worked perfectly from my WIN10 laptop.
  3. Created a KVM guest using without problem. Default settings could not be used “No host caching, no forced sync (none)”, I used “Hypervisor default”. You need to save the VM configuration and then edit the Caching variable. I have yet to figure out the other caching methods.

Anyway my Univention VM is working as it should. Could be a different thing when loaded.
Snapshot’s are working. Whats bugging me is that I cannot snapshot my host :frowning: but that’s comes from the setup, my SSD’s are still ext4.

With the easy setup and snapshot’s, and easy management/configuration I can only wish that it will be a future option for UCS.

Regards Bengt-Åke