Upgrade from 4.4.8 to 5.0 - apps not compatible, yet

The system can not be updated to UCS 5.0 due to the following reasons:

default_master_packages:

The Kopano App is or was installed in your domain.
A newer version of the Kopano App is needed in order to update to UCS 5.0.
Kopano and Univention are currently working on providing this new version
as soon a possible.

If the Kopano App is no longer used and has already been removed from the domain
the package kopano4ucs-udm can be removed from this server
in order to update to UCS 5.0: univention-remove --purge kopano4ucs-udm

This check can be disabled by setting the UCR variable ‘update50/ignore_default_master_packages_apps’ to ‘yes’.

Error: Update aborted by pre-update script of release 5.0-0

Have just upgraded the system.

First Kopano Core/WebApp/Sync, then UCS 5.
The first part went through fine, the second one stopped at one point because the coturn server wouldn’t restart.
After manual de-installation of it, the upgrade went through.

Let’s see if it runs stable but I don’t have real doubts.

Thank you very much!

Is the Kopano Server installed on the Master DC or Backup DC ?

at my installation it is on Backup DC and so got the error i posted above - seems only upgrade path with kopano on master to work for now

rg
Christian

As this is a private installation I only have one server, so master.

We also get the same error above when trying to upgrade our Kopano servers or Master DC’s to UCS 5.0.
Our Kopano servers are on member servers and are never on the Master DC.

i uninstalled kopano4ucs-udm package on the master - then the upgrade worked

Ok, and were you able to reinstall the package? Because now you did’nt have an graphical interface for the kopano configuration, right?

no this package is no more needed - it seems to be replaced by another package maybe kopano4ucs-app package - the management is still possible in the UCS Web Gui

I was also able to upgrade the master to 5.0 after removal of kopano4ucs-udm. Package notes:
This is a transitional package. It can safely be removed.

Hello,

the kopano updates went fine! THX to everybody!
Upgrade to 5.0.2 is still not possible, because I get the following errors in log.
Can s.b. please help me.

22.07.22 07:09:22.058  DEBUG_INIT
**** Starting univention-updater with parameter=['/usr/share/univention-updater/univention-updater', 'net', '--updateto', '5.0-2', '--ignoressh', '--ignoreterm']
Version=4.4
Patchlevel=9
starting net mode
--->DBG:update_available(mode=net, cdrom_mount_point=/media/cdrom, iso=None)
Checking network repository
Update to = 5.0-0
**** Downloading scripts at Fri Jul 22 07:09:32 2022
**** Starting actual update at Fri Jul 22 07:09:40 2022

Starting /tmp/tmpmTym0O/preupEWNquo.sh (Fr 22. Jul 07:09:40 CEST 2022):

HINT:
Please check the release notes carefully BEFORE updating to UCS 5.0-0:
 English version: https://docs.software-univention.de/release-notes-5.0-0-en.html
 German version:  https://docs.software-univention.de/release-notes-5.0-0-de.html

Please also consider documents of following release updates and
3rd party components.

Do you want to continue [Y/n]?
Custom preupdate script /var/lib/local-preup.sh not found
Checking adc_mapping ...                          OK
Checking adc_multiinstance_mapping ...            OK
Checking architecture ...                         OK
Checking blocking_apps ...                        Unable to cache apps
Unable to cache apps
OK
Checking default_master_packages ...              OK
Checking disk_space ...                           OK
Checking failed_ldif ...                          OK
Checking for_postgresql94 ...                     OK
Checking hold_packages ...                        OK
Checking kernel ...                               OK
Checking kolab_schema ...                         OK
Checking ldap_connection ...                      OK
Checking ldap_schema ...                          62da3128 /etc/ldap/slapd.conf: line 201: rootdn is always granted unlimited privileges.
OK
Checking legacy_objects ...                       OK
Checking master_version ...                       OK
Checking md5_signature_is_used ...                OK
Checking min_version ...                          OK
Checking minimum_ucs_version_of_all_systems_in_domain ... FAIL
Checking old_packages ...                         FAIL
Checking overwritten_umc_templates ...            OK
Checking ox_schema ...                            OK
Checking package_status ...                       OK
Checking python_ucr_template_compatibility ...    OK
Checking python_ucsschool_hooks_compatibility ... OK
Checking role_package_removed ...                 OK
Checking samba_server_schannel ...                OK
Checking samba_tdb_size ...                       OK
Checking sha1_signature_is_used ...               OK
Checking slapd_on_member ...                      OK
Checking ssh ...                                  OK
Checking system_date_too_old ...                  OK
Checking system_role ...                          OK
Checking term ...                                 OK
Checking tls_public_key_size ...                  OK
Checking tls_public_key_size_ucs-sso ...          OK
Checking ucsschool_computerroom_compatibility ... OK
Checking usr_mountpoint ...                       OK
Checking valid_machine_credentials ...            OK

The system can not be updated to UCS 5.0 due to the following reasons:

old_packages:
WARNING: The following packages from UCS-4 are still installed, which are no longer supported with UCS-5:
	univention-nagios-server
	univention-kde	Mark KDE as manually installed "apt-mark manual kde-standard" to keep KDE
	univention-kdm
	univention-mozilla-firefox
	univention-x-core

Use "univention-remove --purge" with the packages as following arguments to remove them

minimum_ucs_version_of_all_systems_in_domain:
The following extensions are incompatible with UCS 5.0:
	cn=guacamole,cn=udm_syntax,cn=univention,: [unspecified..unspecified)
	cn=guacamole/config,cn=udm_module,cn=univention,: [unspecified..unspecified)
	cn=58openid-connect-provider.ldapacl,cn=ldapacl,cn=univention,: [unspecified..unspecified)
	cn=oidc/rpservice,cn=udm_module,cn=univention,: [unspecified..unspecified)

Error: Update aborted by pre-update script of release 5.0-0

Starting univention-upgrade. Current UCS version is 4.4-9 errata1272

Checking for package updates:                           none
Checking for app updates:                               found
Please rerun command without --check argument to install.

Nagios and Guacamole have been removed some time ago.
How can I savely remove the other packages?

Best regards,
Stefan

Slowly, things are getting serious… :sunglasses:

Hi,

The following extensions are incompatible with UCS 5.0:

The removal of “leftovers” of Apps to prepare the update to UCS 5.0 is described i.e. here Upgrade to UCS 5 fail - #18 by stone1978

Best,
Ingo

After 6hours work, and so many tests, i give up to upgrade Kopano.

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 kopano-webapp : Hängt ab von: php7-mapi soll aber nicht installiert werden
 univention-appcenter : Hängt ab von: python-univention-appcenter (= 9.0.2-45A~5.0.0.202105171344) soll aber nicht installiert werden
                        Empfiehlt: univention-appcenter-docker soll aber nicht installiert werden
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade"
exitcode of univention-updater: 1

Has now worked. Whole environment incl. Kopano updated. Am still working out. Very many things where everything got stuck. Also UCS Kopano uninstalls itself every time. Also the license is invalid since the update of the apps still on UCS4.4. Furthermore, the wrong package sources were entered by Kopano with each upgrade…

1 Like

With primary on 5.0.2 and mailserver (replica directory node) on 5.0.2 as well, a fresh install of Kopano Core, Kopano WebApp and Z-Push worked. Big thumbs up to the people making this possible!

I still have this

Further release updates are available but cannot be installed. The currently installed version of the application Kopano Meet is not available for all newer UCS releases. You may wait for the app to be released for the new UCS version. Using the [“App Center” module](javascript:void(0)), you may also search for alternative apps or uninstall the application.

This also holds for:

* GitLab Enterprise Edition (Beta) (no update available yet)

update

Really… no Kopano Meet anymore :confused:

I have not seen info on gitlab or Kopano Meet so far. Anyone has info about those two?

Ok So I remove kopano meet but what about for

  • GitLab Enterprise Edition (Beta) (no update available yet)**

Vincent