UCS 4.4/Kopano - DNS

Hallo allerseits,

ich habe offensichtlich ein Problem mit der DNS-Konfiguration im UCS.

Mein Heimnetz: Debian10 Server hinter einer Fritzbox mit fester öffentlicher IP.
Auf dem Server habe ich eine UCS 4.4 Virtual Appliance (KVM/QEMU). Darin soll Kopano laufen.
Internet-/Netzwerkverbindung der VM ist tadellos.Der UCS heißt intra.domain.tld.

Beim Domainprovider gibt es diverse A- und CNAME-records “sub.domain.tld”, z.B. mail.domain.tld, die vom Homeserver einwandfrei aufgelöst werden - aber eben nicht von der UCS-VM:

intra:/# ping sub.domain.tld
Der Name oder Dienst ist nicht bekannt

intra:/# host -t A sub.domain.tld
Host sub.domain.tld not found: 3(NXDOMAIN)

Offen gestanden: Ich hatte heute schon mal eine Installation, da hat es funktioniert. Ich konnte ein LetsEncrypt-Zertifikat für den UCS und Kopano anfordern. Weil ich mich aber an anderer Stelle verzettelt hatte, habe ich die Inst wieder verworfen und dachte, das machen wir nochmal. Und jetzt kriege ich’s einfach nicht mehr hin.

Was habe ich übersehen, worauf muss ich achten?

Danke und Gruß
Andreas

Ich bin einen Schritt weiter.

Bei der Installation hat der UCS seine eigene IP als Domain-DNS eingetragen, was ja auch eigentlich nicht überraschend ist. Ich habe dies nun auf die IP der Fritzbox geändert.

Gleichzeitig habe ich im Nginx des Homeservers ein proxy_pass von port 80 auf die IP des UCS gesetzt.

Das klappt, jetzt kann ich mit dem UCS ein Letsencrypt-Zertifikat für mail.domain.tld anfordern.

Was mich irritiert: Warum hat es bei meiner ersten Installtion ohne diese Maßnahmen geklappt?
Anyway, ich hoffe, dass ich jetzt erstmal weiterkomme.

Gruß
Andreas

Bitte mal die Ausgabe schicken:
ucr search "^nameserver.$|forwarder"

Und hier gucken.

1 Like