UCS 4.0-0 OX Oxtender kein Zugriff mehr

german

#1

Hallo,

ich habe gerade einenen UCS 4.0-0 mit aktueller OX App Suite aufgesetzt. Der Browserzugriff auf die App Suite funktioniert problemlos. Nach einem Update des Oxtenders auf 7.2.11 (Windows 7) scheitert der Zugriff mit folgenden Meldungen. Habe ich etwas vergessen zu installieren oder zu konfigurieren?

Zugriff über 192.168.1.3/usm-json

[code]---- Sync State ----
Error during Login (SST_LOGIN)

---- Message ----
HTTP 404

---- Location ----

---- Details ----
Die angeforderte Ressource ist auf dem Server nicht vorhanden (HTTP 404, Not Found).

---- Error Object ----
{
“code”: 2148369412,
“code_hex”: “0x800d8404”,
“code_description”: “USM error: HTTP error”,
“state”: 2,
“state_description”: “SST_LOGIN”,
“last_usm_call”:
{
“func”: “/usm-json/login”,
“argument”:
{
“user”: “xxxxx”,
“device”: “5cbb463d19b28b4889577d498c648580”,
“local_time”: “2014-12-11 20:50:30.510”,
“version”: “2.2.0”,
“password”: “****”
},
“reply_string”: “\u003Chtml>\u003Chead>\u003Ctitle>Grizzly/2.2.22\u003C/title>\u003Cstyle>\u003C!–div.header {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#003300;font-size:22px;-moz-border-radius-topleft: 10px;border-top-left-radius: 10px;-moz-border-radius-topright: 10px;border-top-right-radius: 10px;padding-left: 5px}div.body {font-family:Tahoma,Arial,sans-serif;color:black;background-color:#FFFFCC;font-size:16px;padding-top:10px;padding-bottom:10px;padding-left:10px}div.footer {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#666633;font-size:14px;-moz-border-radius-bottomleft: 10px;border-bottom-left-radius: 10px;-moz-border-radius-bottomright: 10px;border-bottom-right-radius: 10px;padding-left: 5px}BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;}B {font-family:Tahoma,Arial,sans-serif;color:black;}A {color : black;}HR {color : #999966;}–>\u003C/style> \u003C/head>\u003Cbody>\u003Cdiv class=“header”>Not Found\u003C/div>\u003Cdiv class=“body”>Resource identified by path ‘/usm-json/login’, does not exist.\u003C/div>\u003Cdiv class=“footer”>Grizzly/2.2.22\u003C/div>\u003C/body>\u003C/html>”
}
}[/code]

Zugriff über 192.168.1.3/usm-json

[code]---- Sync State ----
Error during Login (SST_LOGIN)

---- Message ----
Die Zertifizierungsstelle ist ung�ltig oder fehlerhaft. (0x80072f0d)

---- Location ----

---- Details ----

---- Error Object ----
{
“code”: 2147954445,
“code_hex”: “0x80072f0d”,
“code_description”: “Die Zertifizierungsstelle ist ung\uFFFDltig oder fehlerhaft.\r\n”,
“state”: 2,
“state_description”: “SST_LOGIN”,
“last_usm_call”:
{
“func”: “/usm-json/login”,
“argument”:
{
“user”: “xxxxxx”,
“device”: “5cbb463d19b28b4889577d498c648580”,
“local_time”: “2014-12-11 20:51:34.906”,
“version”: “2.2.0”,
“password”: “****”
}
}
}[/code]

Im Apache2 error.log stehen viele dieser Einträge:

[error] (111)Connection refused: proxy: HTTP: attempt to connect to 127.0.0.1:8009 (localhost) failed [error] ap_proxy_connect_backend disabling worker for (localhost)


Lizenz für OXtender
#2

Hallo,

sind die USM-Pakete denn installiert?

Viele Grüße,
Dirk Ahrnke


#3

Hallo,

wie stelle ich fest, welche USM-Pakete installiert sind und welche installiert sein müssen?

Gruß,
Sören Wiechert


#4

Das müsste in etwa so aussehen:

# aptitude search "\-usm" i A open-xchange-help-usm-eas - Open-Xchange OXTender for Business Mobility Help. i A open-xchange-usm - The Open-Xchange Server USM Bundle i univention-ox-usm - Open-Xchange USM OX integration metapackage i univention-ox-usm-ox - Open-Xchange USM OX integration metapackage and db update i univention-ox-usm-udm - Open-Xchange USM integration metapackage (mobility)

Hier zwar noch UCS 3.2-4, aber ich erwarte eigentlich keinen Unterschied.


#5

Sieht bei uns so aus:

p open-xchange-help-usm-eas - Open-Xchange OXTender for Business Mobilit p open-xchange-usm - The Open-Xchange Server USM Bundle p univention-ox-usm - Open-Xchange USM OX integration metapackag p univention-ox-usm-ox - Open-Xchange USM OX integration metapackag p univention-ox-usm-udm - Open-Xchange USM integration metapackage (

Bedeutet das “i” bei Ihnen vorne, dass es installiert ist und das “p” bei mir, dass es das nicht ist?


#6

Genau das.

univention-install univention-ox-usm

könnte schon reichen.


#7

Nach der Ausführung wird am Ende ausgegeben:

[code]Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
univention-ox-usm : Hängt ab von: univention-ox-usm-ox soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.[/code]

Das Ergebnis des Aufrufs von aptitude search “-usm” bleibt unverändert auf “p”. Ich versuche mal das angegebene Paket vorher zu installieren.

EDIT:

Die Installation von univention-ox-usm-ox meldet:

Die folgenden Pakete haben unerfüllte Abhängigkeiten: univention-ox-usm-ox : Hängt ab von: open-xchange-eas soll aber nicht installiert werden

Die Installation von open-xchange-eas meldet:

[code]Paket open-xchange-eas ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »open-xchange-eas« existiert kein Installationskandidat.[/code]


#8

Und das bei einer frischen Installation?
Erstmal Status prüfen:

dpkg --audit

Je nach Resultat

dpkg --configure -a

#9

[quote=“ahrnke”]Und das bei einer frischen Installation?
Erstmal Status prüfen:

dpkg --audit

Ja, frische Installation. Der Befehl meldet nichts.

EDIT:

Ich habe die Angaben aus diesem Beitrag umgesetzt und konnt bisher folgenden Zustand erreichen. Das “open-xchange-eas”-Paket lässt sich leider noch nicht installieren.

root@ucs:/# aptitude search "\-usm" i open-xchange-help-usm-eas - Open-Xchange OXTender for Business Mobilit i open-xchange-usm - The Open-Xchange Server USM Bundle p univention-ox-usm - Open-Xchange USM OX integration metapackag p univention-ox-usm-ox - Open-Xchange USM OX integration metapackag i univention-ox-usm-udm - Open-Xchange USM integration metapackage (

EDIT 2:

Nach einem Neustart funktioniert nun der Zugriff über den OXtender. Dennoch sind die beiden Pakete “univention-ox-usm” und “univention-ox-usm-ox” nicht installiert, weil sich weiterhin das Paket “open-xchange-eas” nicht installieren lässt. Die Angaben dazu in dem oben genannten Beitrag habe ich alle überprüft. Ich kann da keine Abweichung erkennen.


#10

Hallo,

hab grad mal eine Testinstallation gemacht. “open-xchange-eas” liegt auf software.open-xchange.com und ist somit erst nach Aktivierung der OX-Lizenz zu bekommen.

Viele Grüße,
Dirk Ahrnke