Strange problem with mailserver here


#1

I can send out to another mailadress but they will not arrive.
Have checked is ports is open and yes they ar open.
Checked Kopano status is runing.
Happen after update to 4.3-1 erratta 112
Can some tell me what is wrong cant find


#2

Hello,
I can send out an email from my server but nothing coming to that email adress I sending to.
THat happen yesterday last email i got was kl 12:01
Chcked my ports 25, 110 they are open used ping.eu
where in my server can find logs and see where my emails going to think exchange 2013 and 2016 have an program I can check if stopped


#3

Hello, found mailq and was connection was refused.
how can remove that will have help with that very noob

Bengt


#4

Hey,
how can stop connection being stopped
Can some help me is that an command or do inside my server
Can I remove an line:
This variable configures the use of TLS encryption by the SMTP client for certain mail domains or mail servers. The entries are stored in /etc/postfix/tls_policy (see http://www.postfix.org/TLS_README.html#client_tls_policy). Each variable value contains a complete line of the table (e.g. mail/postfix/tls/client/policy/1=’[127.0.0.1]:10024 none’).
have an line
[127.0.0.1]:10024 none
Or can stop
mail/postfix/tls/client/policy/amavis


#5

I cant get to fixed tryed remove an line in postfix file main.cf and master.cf
I being crazy here and angry for cant get rigth (sorry for my english)
can sent out but not more is stopped in mailque.
Happen after that update yesterday before working great
please can some help me
Not sure what I will do now


#6

Please do not edit files in /etc/postfix directly. Most of those files are generated from templates and will be overwritten with the next update. Please see UCR variables to change the configuration:

When you have a problem with your mail server, please post (copy & paste) a relevant section of the logfile /var/log/mail.log here.

When a command like mailq has a problem, please post (copy & paste) both the command and its output here.

Greetings
Daniel Tröder


#7

Hey,
I have not changed in /etc/postfix/ checked just now.
My problem is mailserver happen after an update then was all mail out and incoming stopped or refused could see that in mailq what I know.
have no problem with mailq was seeking why nothing email coming in and out.
For could sent out kopano sayning nothing was problem that strange.
checked that /var/log/mail.log could see nothing error
But have another problem now is could not surfing to website outside for read my email working yesterday not sure why that problem coming now.
Are very noob to use just linux and I thinking remove mailserver and my website moving they to an webhotel will not have problem again


#8

Hello,
verything working but my problem is mail not coming in or out for mailq says
92153442E0C 1527 Wed Jun 20 03:39:03 root@mailserver.olssondata.local
(delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
root@mailserver.olssondata.local
there are 149 mail waiting coming in to my mailbox
how can remove that !!
that working before updated to 4.3-1 before was mail incoming and could sent out
something happen.
I try stop antivirus spam clam


#9

The service that cannot be connected to is Amavis. It is required. Please start it:
service amavis start
Then you can tell Postfix to try to send the queued mails:
postqueue -f


#10

I wil do that get an error

● amavis.service - LSB: Starts amavisd-new mailfilter
   Loaded: loaded (/etc/init.d/amavis; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2018-06-20 14:42:06 CEST; 1min 33s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 27455 ExecStart=/etc/init.d/amavis start (code=exited, status=0/SUCCESS)
      CPU: 1.848s

jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .lzo
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .rar
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .rpm
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .swf
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .zoo
jun 20 14:42:06 mailserver amavis[27477]: Using primary internal av scanner code for Clam Antivirus-clamd
jun 20 14:42:06 mailserver amavis[27477]: Deleting db files __db.001,snmp.db,nanny.db,__db.003,__db.002 in /var/lib/amavis/db
jun 20 14:42:06 mailserver amavis[27477]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.55, libdb 5.3
jun 20 14:42:07 mailserver amavis[27477]: (!!)TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?
jun 20 14:42:07 mailserver amavis[27477]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?

how do that update


#11

I found more for postfix now

root@mailserver:/home/Administrator# tail /var/log/mail.log
Jun 20 14:50:15 mailserver postfix[28129]: To disable backwards compatibility use "postconf compatibility_level=2" and "postfix reload"
Jun 20 14:50:16 mailserver postfix/postfix-script[28187]: warning: not owned by root: /etc/postfix/./main.cf
Jun 20 14:50:16 mailserver postfix/postfix-script[28237]: starting the Postfix mail system
Jun 20 14:50:16 mailserver postfix/master[28239]: daemon started -- version 3.1.8, configuration /etc/postfix
Jun 20 14:55:16 mailserver postfix/qmgr[28241]: 53E383442EC1: from=<bengt@olssondata.se>, size=1963, nrcpt=1 (queue active)
Jun 20 14:55:16 mailserver postfix/qmgr[28241]: 78D533442EBE: from=<root@mailserver.olssondata.local>, size=1527, nrcpt=1 (queue active)
Jun 20 14:55:16 mailserver postfix/smtp[28407]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Jun 20 14:55:16 mailserver postfix/smtp[28409]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Jun 20 14:55:16 mailserver postfix/smtp[28407]: 53E383442EC1: to=<gytepr@hotmail.com>, relay=none, delay=476, delays=476/0.04/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Jun 20 14:55:16 mailserver postfix/smtp[28409]: 78D533442EBE: to=<root@mailserver.olssondata.local>, orig_to=<root>, relay=none, delay=973, delays=973/0.05/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

why is connection refused have not been before that update installed in mondays after that not email working what i know worked good before


#12

Run /etc/cron.daily/spamassassin

The service that cannot be connected to (on port 10024) is Amavis. It is required. Please start it:
service amavis start


#13

how can start
etc/cron.daily/spamassassin

and amavis are started

● amavis.service - LSB: Starts amavisd-new mailfilter
   Loaded: loaded (/etc/init.d/amavis; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2018-06-20 14:42:06 CEST; 36min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 27455 ExecStart=/etc/init.d/amavis start (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   Memory: 0B
      CPU: 0
   CGroup: /system.slice/amavis.service

jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .lzo
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .rar
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .rpm
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .swf
jun 20 14:42:06 mailserver amavis[27477]: No decoder for       .zoo
jun 20 14:42:06 mailserver amavis[27477]: Using primary internal av scanner code for Clam Antivirus-clamd
jun 20 14:42:06 mailserver amavis[27477]: Deleting db files __db.001,snmp.db,nanny.db,__db.003,__db.002 in /var/lib/amavis/db
jun 20 14:42:06 mailserver amavis[27477]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.55, libdb 5.3
jun 20 14:42:07 mailserver amavis[27477]: (!!)TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?
jun 20 14:42:07 mailserver amavis[27477]: (!)_DIE: Suicide () TROUBLE in pre_loop_hook: config: no rules were found!  Do you need to run 'sa-update'?
root@mailserver:/home/Administrator#

#14

Run the command on the command line. (It starts with a /.)

No it’s not:

Please run the commands I wrote on the command line.


#15

How write that to start spamassassin
why is amavis not started
what is problem if not started


#16

Login via SSH and run the commands.


#17

sorry cant login to ssh have one computer with my mailserver, have another computer on another ip-adress cant see that computer.
why is my email refused was working on monday before run an update, that I not understand !!
are noob on linux take time for me understand .


#18

Why is connection for that email are waiting refused!!
That worked on monday before do an update to 4.3-1
when working my problem have no patience when not will work for me


#19

Now runing amvis

 amavis.service - LSB: Starts amavisd-new mailfilter
   Loaded: loaded (/etc/init.d/amavis; generated; vendor preset: enabled)
   Active: active (running) since Wed 2018-06-20 17:51:21 CEST; 15s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 17155 ExecStop=/etc/init.d/amavis stop (code=exited, status=0/SUCCESS)
  Process: 17161 ExecStart=/etc/init.d/amavis start (code=exited, status=0/SUCCESS)
    Tasks: 3 (limit: 4915)
   Memory: 126.7M
      CPU: 3.160s
   CGroup: /system.slice/amavis.service
           ├─17181 /usr/sbin/amavisd-new (master)
           ├─17182 /usr/sbin/amavisd-new (virgin child)
           └─17183 /usr/sbin/amavisd-new (virgin child)

jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .lrz
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .lz4
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .lzo
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .rar
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .rpm
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .swf
jun 20 17:51:21 mailserver amavis[17181]: No decoder for       .zoo
jun 20 17:51:21 mailserver amavis[17181]: Using primary internal av scanner code for Clam Antivirus-clamd
jun 20 17:51:21 mailserver amavis[17181]: Deleting db files __db.001,snmp.db,nanny.db,__db.003,__db.002 in 

was in system service restarted

now working email again
was thinking here