Smtp_tls_wrappermode und main.cf

Hey Leute,
ich bin neu hier und möchte erst einmal “Hello” sagen :wink:
Kurz zu mir :slight_smile: ich bin eine privat Person die einen eigenen Mailserver mit active Sync (oder alternativ Z-Push) haben möchte. Mein Setup ist eine QNAP TS251+ mit 8 GB Ram
Darauf habe ich soweit den Univention Kopano Server zum Laufen gebracht (war ja auch im Vergleich zu Kolab .org einfach, downloaden und gut :smiley: ) nunja…

Nun zu meinem Problem:
Ich kann dauerhaft keine Emails über einen SMTP-Relayhost senden.
Nachdem ich zahlreiche Forenbeiträge und andere Seiten sowie Postfix durchgestöbert habe, habe ich es geschafft für 2 Sekunden Mails nach Extern zu senden.

Das Problem was ich habe ist, dass mit das Maillog sagt ich muss ‘smtp_tls_wrappermode = yes’ und ‘smtp_tls_security_level = encrypt’ einstellen muss. Soweit so gut…

In der UCR registrie habe ich auch mit ewigen suchen die security_level variabel einstellen können. Diese behält er auch.

Das Problem ist wenn ich jetzt in die main.cf den wrappermode direkt unter den security_level schreibe werden die Mails gesendet, er überschreibt ja aber die main.cf wieder. Soweit auch logisch. Nun habe ich in einem Template versuchsweise erst den wrappermode wert eingesetzt und dann mal beide, leider ohne erfolg. Anscheinend muss der wrappermode auch direkt unter dem security_level variabel geschrieben werden.

Meine Frage nun :smiley:
wo kann ich den wert “smtp_tls_wrappermode = yes” direkt unter der den “smtp_tls_security_level = encrypt” speichern?

ich habe auch:

Postfix/Kopano versendet nicht mehr nach Update auf 4.2-1 errata52

und

https://www.linet-services.de/vorlagen-fuer-konfigurationsdateien-in-univention/

versucht, beides irgendwie ohne Erfolg
Ich hoffe es ist verständlich. Und danke euch schonmal im Vorraus für eure Hilfe.

Hallo,

sie können die Datei /etc/postfix/main.cf.local erstellen und dort die gewünschte Zeile hineinschreiben. Anschließend ucr commit /etc/postfix/main.cf und service postfix reload.

Dokumentation:
https://docs.software-univention.de/handbuch-4.4.html#mail::serverconfig::maincflocal

Grüße
Daniel Tröder

Vielen Dank für die Hilfe, dass hat auch soweit funktioniert. Ich habe nur irgendwie immer noch das Problem, dass es immer noch nicht funktioniert.

Wenn ich die main.cf per Hand ändere und die smtp_tls_wrappermode = yes direkt unter die Variable smtp_tls_security_level = encrypt schreibe sendet er die Mails in der Warteschlange ordnungsgemäß raus, allerdings kann ich danach auch wieder keine neues Emails über den SMTP-Relayhost versenden.

Ist mir schon peinlich, dass ich nochmal fragen muss…

Gibt es eine möglichkeit diese wrappermode Variable dauehaft direkt unter die security_level zu bekommen? Ich weiß leider nicht wo die smtp varialben hergenommen werden, habe schon gesucht aber irgendwie nichts gefunden. Alle anderen habe ich in den Templates gefunden aber die haben sich irgendwie versteckt.

Nochmals vielen Dank im Vorraus

Guten Morgen, ich habe meinen Fehler gefunden :sleepy:
Ich habe nochmal alles neu installiert und konfiguriert, erst mit gleichem Ergebnis. Aber ich habe jetzt mal Testweise den Port 587 genommen mit den gleichen Einstellungen. Den hatte ich vorher nicht genommen weil mein Provider in seiner Description stehen hat, dass ich dann einen anderen SMTP Server nehmen muss. (ich habe meinen Server intern wie meine MX-Domain benannt um mir ein paar einstellungen zu sparen)
ich hatte den Port 465 genommen, und jetzt testweise den 587 gesetzt… Jetzt funktioniert es…

Vielen lieben DANK trotzdem für eure / Ihre Hilfe. Die Info ist trotzdem gut gewesen.