Scalix lässt sich nicht installieren

mail
german

#1

Hallo,

ich versuche Scalix nach der Anleitung [url]Scalix 11.4.5 für UCS 2.2] zu installieren.

das System ist ein frisch installiertes 2.2 auf i386, ohne eine einzige Congfigänderung.

root@brain:~# uname -an Linux brain 2.6.18-ucs105-686 #1 SMP Fri Feb 6 21:01:18 UTC 2009 i686 GNU/Linux

root@brain:~# ucr set repository/online/component/scalix=yes Setting repository/online/component/scalix File: /etc/apt/sources.list.d/20_ucs-online-component.list File: /etc/apt/mirror.list File: /etc/apt/sources.list.d/15_ucs-online-version.list File: /etc/apt/sources.list.d/18_ucs-online-security.list

Installationstart:

[code]oot@brain:~# DEBIAN_FRONTEND=noninteractive \

apt-get install univention-scalix univention-scalix-amavis
univention-kolab2-framework- univention-kolab2-webclient-
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
E: Konnte Paket univention-scalix nicht finden[/code]

Auszug vom Ende der /var/log/univention/actualise.log:

[code]File: /etc/clamav/freshclam.conf
Stopping ClamAV daemon: clamd.
Starting ClamAV daemon: clamd LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON’T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON’T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
executing: /usr/sbin/univention-mount-homedir.
executing: /usr/bin/univention-skel.
executing: /usr/share/univention-kde/univention-set-kdedirs.
executing: /usr/sbin/univention-user-quota.
.
Restarting SpamAssassin Mail Filter Daemon: spamd.
Stopping amavisd: amavisd-new.
Starting amavisd: amavisd-new.

***** Starting univention-actualise at Tue Nov 24 11:38:54 2009
Ign http://brain.gollhardt.local 2.2-0/all/ Release.gpg
Ign http://brain.gollhardt.local 2.2-0/extern/ Release.gpg
Ign http://brain.gollhardt.local 2.2-0/i386/ Release.gpg
Ign http://brain.gollhardt.local 2.2-0/all/ Release
Ign http://brain.gollhardt.local 2.2-0/extern/ Release
Ign http://brain.gollhardt.local 2.2-0/i386/ Release
Ign http://brain.gollhardt.local 2.2-0/all/ Packages/DiffIndex
Ign http://brain.gollhardt.local 2.2-0/extern/ Packages/DiffIndex
Ign http://brain.gollhardt.local 2.2-0/i386/ Packages/DiffIndex
Ign http://brain.gollhardt.local 2.2-0/all/ Packages
Ign http://brain.gollhardt.local 2.2-0/extern/ Packages
Ign http://brain.gollhardt.local 2.2-0/i386/ Packages
Hit http://brain.gollhardt.local 2.2-0/all/ Packages
Hit http://brain.gollhardt.local 2.2-0/extern/ Packages
Hit http://brain.gollhardt.local 2.2-0/i386/ Packages
Ign http://apt.univention.de scalix/all/ Release.gpg
Ign http://apt.univention.de scalix/i386/ Release.gpg
Ign http://apt.univention.de scalix/extern/ Release.gpg
Ign http://apt.univention.de scalix/source/ Release.gpg
Ign http://apt.univention.de scalix/all/ Release
Ign http://apt.univention.de scalix/i386/ Release
Ign http://apt.univention.de scalix/extern/ Release
Ign http://apt.univention.de scalix/source/ Release
Ign http://apt.univention.de scalix/all/ Packages/DiffIndex
Ign http://apt.univention.de scalix/i386/ Packages/DiffIndex
Ign http://apt.univention.de scalix/extern/ Packages/DiffIndex
Ign http://apt.univention.de scalix/source/ Sources/DiffIndex
Ign http://apt.univention.de scalix/all/ Packages
Ign http://apt.univention.de scalix/i386/ Packages
Ign http://apt.univention.de scalix/extern/ Packages
Ign http://apt.univention.de scalix/source/ Sources
Hit http://apt.univention.de scalix/all/ Packages
Hit http://apt.univention.de scalix/i386/ Packages
Hit http://apt.univention.de scalix/extern/ Packages
Hit http://apt.univention.de scalix/source/ Sources
Reading package lists…
Reading package lists…
Building dependency tree…
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
***** Starting univention-actualise at Tue Nov 24 11:44:39 2009[/code]

ein dist-upgrade macht auch nix:

root@brain:~# univention-actualise --dist-upgrade Running apt-get update Setting pkgdb/scan File: /etc/apt/apt.conf.d/60invoke Dist-upgrading system E: failed to upgrade Setting pkgdb/scan File: /etc/apt/apt.conf.d/60invoke Setting pkgdb/scan File: /etc/apt/apt.conf.d/60invoke Reading package lists... Done Building dependency tree... Done

wo ist mein denkfehler?

thx,
plepps


#2

Hallo,

funktioniert die Installation wenn zusätzlich folgende Variable gesetzt ist?

ucr set repository/online/component/scalix/server="apt.univention.de"

Alternativ sollte das lokale Repository für die Scalixinstallation deaktiviert werden.

ucr set repository/online="yes" ucr set repository/online/server="apt.univention.de" ucr set repository/mirror="false"

Mit freundlichen Grüssen
Tobias Scherer

Edit: Korrektur an ucr set repository/online/server="apt.univention.de"


#3

Hatte das selbe Problem: Scalix lässt sich auf einem jungfräulichen UCS 2.2-0 nicht installieren (Auflösung der Pakete schlägt fehl). Die vorgeschlagene Lösung von Scherer hat bei mir nicht funktioniert.

Nach einem Update auf UCS 2.2-2 klappt die Installation allerdings problemlos:

  1. alle Quellen in /etc/apt/sources.list auskommentieren (falls vorhanden)

  2. Online Repository aktivieren (Lokales deaktivieren)

ucr set repository/online="yes"
ucr set repository/online/server="apt.univention.de"
ucr set repository/mirror="false"
  1. Update durchführen (lange warten :slight_smile: )
univention-updater net
  1. Scalix Installationsquelle hinzufügen
ucr set repository/online/component/scalix=yes
apt-get update
  1. Scalix Installation durchführen (wie in Scalix 11.4.5 für UCS 2.2 beschrieben)

DEBIAN_FRONTEND=noninteractive \ apt-get install univention-scalix univention-scalix-amavis \ univention-kolab2-framework- univention-kolab2-webclient-

mfg, Jürgen Kurzmann


#4

Achtung bei Update (auf 2.3)!
Siehe: sdb.univention.de/content/8/115/ … erden.html


#5

Hallo zusammen ich werden den Bug hier mit diesem Forum Post verbinden um meine Probleme hier auch bekannt zu geben.

forge.univention.org/bugzilla/s … i?id=17622

Hoffe das hilft in Zukunft das ganze etwas besser zu verstehen was eigentlich genau passiert wenn man Scalix auf UCS 2.2.2 installiert.

LG

Franz


#6

Hallo,

leider ist mir in meinem letzten Posting ein Fehler unterlaufen. Ich habe diesen korrigiert und bitte um Entschuldigung.

Der Wert der UCR-Variable “repository/online/server” enthielt den falschen Hostname für den Repository Server.

Die Installation von Scalix auf UCS 2.2-0 kann durchgeführt werden wenn die angepassten Daten aus dem vorherigen Posting verwendet werden.

Mit freundlichen Grüssen
Tobias Scherer


#7

[quote=“Scherer”]Hallo,

funktioniert die Installation wenn zusätzlich folgende Variable gesetzt ist?

ucr set repository/online/component/scalix/server="apt.univention.de"

Alternativ sollte das lokale Repository für die Scalixinstallation deaktiviert werden.

ucr set repository/online="yes" ucr set repository/online/server="apt.univention.de" ucr set repository/mirror="false"

Mit freundlichen Grüssen
Tobias Scherer

Edit: Korrektur an ucr set repository/online/server="apt.univention.de"[/quote]

So und jetzt nochmal für Anfänger :slight_smile:

ich sehe hier keinen Unterschied zwischen den geposteten und dem editierten.

Betreffend der Zeile: [ ucr set repository/online/component/scalix/server=“apt.univention.de

LG

Franz

Gut dann werde ich hier den Vorgang fortsetzen.

[Fortsetzung vom geschlossenen Bug]
ich beginne das ganze nochmal von vorne weil es witzlos ist wenn man solch
einen anscheinend fatalen Fehler macht. das update auf 2.3 sollte man nicht
abbrechen.

aus Fehlern lernt man bekannter weise.

beim Update von 2.2.1 auf 2.2.2 derzeit keine Probleme wegen apache und univention-management-console-server Rechte bei den Startskripten. dies dürfte passiert sein wie ich auf 2.3 abgebrochen habe.

Security Updates sind jetzt erfolgreich jetzt installiere ich mal Scalix ich versuch es zumindest.

Security Update wurd in einem Sprung auf Level 4 upgedatet.
somit habe ich derzeit den Versionsstand 2.2.2.4


#8

Scalix lässt sich noch immer nicht installieren

ich hab den selben Fehler wie ich auch die Variablen setze:

DEBIAN_FRONTEND=noninteractive apt-get install univention-scalix univention-scalix-amavis univention-kolab2-framework- univention-kolab2-webclient- Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut... Fertig E: Konnte Paket univention-scalix-amavis nicht finden

ucr set scalix/mailnode="scalix"

Create scalix/mailnode
root@coppermaster:~# ucr set repository/online/component/scalix/server="apt.univention.de"
Create repository/online/component/scalix/server
File: /etc/apt/sources.list.d/20_ucs-online-component.list
File: /etc/apt/mirror.list
File: /etc/apt/sources.list.d/15_ucs-online-version.list
File: /etc/apt/sources.list.d/18_ucs-online-security.list
root@coppermaster:~# ucr set repository/online="yes"
Setting repository/online
File: /etc/apt/sources.list.d/15_ucs-online-version.list
File: /etc/apt/sources.list.d/18_ucs-online-security.list
File: /etc/apt/sources.list.d/20_ucs-online-component.list
File: /etc/apt/mirror.list
root@coppermaster:~# ucr set repository/online/server="apt.univention.de"
Setting repository/online/server
File: /etc/apt/sources.list.d/15_ucs-online-version.list
File: /etc/apt/sources.list.d/18_ucs-online-security.list
File: /etc/apt/mirror.list
File: /etc/apt/sources.list.d/20_ucs-online-component.list

Die Registry ist so eingestellt:

ucr set repository/
repository/mirror/basepath="/var/lib/univention-repository"
repository/online/maintained=“yes”
repository/mirror=“false”
repository/online/port=“80”
repository/mirror/recreate_packages=“yes”
repository/online/server=“apt.univention.de
repository/mirror/threads=“10”
repository/online/unmaintained=“no”
repository/online/component/scalix/server=“apt.univention.de
repository/online=“yes”
repository/online/hotfixes=“no”

LG

Franz


#9

Hallo,

ist es möglich den Inhalt der Datei /etc/apt/sources.list und der Dateien unterhalb von /etc/apt/sources.list.d/ als Anhang bereitzustellen? Am besten mit den zu diesem Zeitpunkt aktuellen UCR-Variablen bzgl. der Repositorykonfiguration.

Mit freundlichen Grüssen
Tobias Scherer


#10

ucr set repository/
repository/mirror/basepath="/var/lib/univention-repository"
repository/mirror=“false”
repository/mirror/recreate_packages=“yes”
repository/mirror/threads=“10”
repository/online/component/scalix/server=“apt.univention.de
repository/online/hotfixes=“no”
repository/online/maintained=“yes”
repository/online/port=“80”
repository/online/server=“apt.univention.de
repository/online/unmaintained=“no”
repository/online=“yes”

im Anhang die gewünschten Dateien
LG
Franz
scalix.zip (2.21 KB)


#11

Hallo,

vielen Dank für die Daten.
Sie sollten mit den aktuellen Einstellungen Scalix nach dieser Anleitung installieren können. Die Datei "/etc/apt/sources.list.d/00_ucs_temporary_installation.list " sollte allerdings gelöscht werden. Ausserdem empfiehlt es sich das “unmaintained” Repository einzubinden. ucr set repository/online/unmaintained="yes"

Mit freundlichen Grüssen
Tobias Scherer


#12

Hallo,

offensichlich haben sehr viele ein Problem mit der Installation von Scalix.

Ist es nicht möglich von Seiten Univentions eine vollständige Anleitung bereitzustellen wie man von einem “jungfräulichen” UCS 2.3 zu ein funktionsfähigen Scalix-System kommen kann?

Vielen Dank.

MfG,
Joachim


#13

Hallo,

leider habe ich den Beitrag unter

sdb.univention.de/content/8/115/ … erden.html

zu spät gelesen, wo darauf hingewiesen wird, dass Scalix unter Debian GNU/Linux 5.0 (lenny) und somit unter UCS 2.3 noch nicht unterstützt wird.

Grüße,
Joachim


#14

Guten Morgen ich versuche Scalix unter 2.2.2.4 zu installieren.

leider funktioniert dieser Vorgang nicht bekomme diese Fehler/Warnungen

root@coppermaster:~# ucr set repository/online/component/scalix=yes
Create repository/online/component/scalix
File: /etc/apt/sources.list.d/20_ucs-online-component.list
File: /etc/apt/mirror.list
File: /etc/apt/sources.list.d/15_ucs-online-version.list
File: /etc/apt/sources.list.d/18_ucs-online-security.list
root@coppermaster:~# DEBIAN_FRONTEND=noninteractive apt-get install univention-scalix univention-scalix-amavis univention-kolab2-framework- univention-kolab2-webclient-
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
W: Kann nicht auf die Liste apt.univention.de scalix/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de scalix/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de scalix/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de scalix/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de scalix/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de scalix/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-0/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-0_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-0/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-0_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-0/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-0_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-1/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-1_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-1/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-1_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-2/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-2_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.0-2/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.0_unmaintained_2.0-2_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-0/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-0_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-0/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-0_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-0/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-0_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-1/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-1_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-1/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-1_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-2/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-2_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-2/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-2_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.1-2/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.1_unmaintained_2.1-2_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-0/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-0_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-0/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-0_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-0/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-0_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-1/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-1_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-1/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-1_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-1/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-1_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-2/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-2_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-2/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-2_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de 2.2-2/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_2.2-2_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec1/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec1_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec1/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec1_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec1/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec1_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec2/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec2_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec2/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec2_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec2/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec2_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec3/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec3_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec3/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec3_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec3/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec3_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec4/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec4_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec4/extern/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec4_extern_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste apt.univention.de sec4/i386/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_unmaintained_sec4_i386_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
W: Probieren Sie âapt-get updateâ, um diese Probleme zu korrigieren.
E: Konnte Paket univention-scalix-amavis nicht finden

root@coppermaster:/etc/apt/sources.list.d# [code]ucr set repository/

repository/mirror/basepath="/var/lib/univention-repository"
repository/online/hotfixes=“no”

repository/mirror=“false”
repository/online/maintained=“yes”

repository/mirror/recreate_packages=“yes”
repository/online/port=“80”

repository/mirror/threads=“10”
repository/online/server=“apt.univention.de

repository/online/component/scalix/server=“apt.univention.de
repository/online/unmaintained=“yes”

repository/online/component/scalix=“yes”
repository/online=“yes”[/code]

LG

Franz
sources.list.d.zip (2.12 KB)


#15

[code]root@coppermaster:~# apt-get update
E: Konnte Lock /var/lib/apt/lists/lock nicht bekommen - open (11 Die Ressource ist zur Zeit nicht verfügbar)
E: Kann kein Lock auf das Listenverzeichnis bekommen
root@coppermaster:~# DEBIAN_FRONTEND=noninteractive \

apt-get install univention-scalix univention-scalix-amavis
univention-kolab2-framework- univention-kolab2-webclient-
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Paket univention-kolab2-framework ist nicht installiert, wird also auch nicht entfernt
Paket univention-kolab2-webclient ist nicht installiert, wird also auch nicht entfernt
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
kreiert oder aus Incoming herausbewegt wurden.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben nichterfüllte Abhängigkeiten:
univention-scalix: Hängt ab: scalix-chardet ist aber nicht installierbar
Hängt ab: scalix-libical ist aber nicht installierbar
Hängt ab: scalix-wireless ist aber nicht installierbar
E: Kaputte Pakete
[/code]

Vielleicht hilft das etwas weiter trotz der Änderung wieder nicht sehr viel weiter…

LG
Franz


#16

Hallo zusammen,

hier scheint es ja ein paar unterschiedliche Schwierigkeiten gegeben zu haben.

Zu Scalix für UCS 2.3 gibt es einen SDB Artikel, hier dauert es noch ein wenig, bis die Version zur Verfügung steht:
sdb.univention.de/1116

Mit UCS 2.2-x kann Scalix 11.4.6 eingesetzt werden. Die Anleitung, wie im Forum beschrieben kann jetzt so durchgeführt werden. Zwei kleine Fehler sind in der Anleitung noch korrigiert worden: Scalix 11.4.6 für UCS 2.2

Zu den einzelnen Problemen:

[quote=“FJE_84”]root@coppermaster:~# apt-get update E: Konnte Lock /var/lib/apt/lists/lock nicht bekommen - open (11 Die Ressource ist zur Zeit nicht verfügbar) E: Kann kein Lock auf das Listenverzeichnis bekommen
[/quote] Das apt-get update muss ohne Fehlermeldung durchlaufen. Läuft vielleicht noch ein apt-get-Prozess (ps -ef | grep -i apt-get)? Ist das Verzeichnis /var/lib/apt/lists noch vorhanden?

[quote=“FJE_84”]Guten Morgen ich versuche Scalix unter 2.2.2.4 zu installieren.

leider funktioniert dieser Vorgang nicht bekomme diese Fehler/Warnungen

root@coppermaster:~# ucr set repository/online/component/scalix=yes
Create repository/online/component/scalix
File: /etc/apt/sources.list.d/20_ucs-online-component.list
File: /etc/apt/mirror.list
File: /etc/apt/sources.list.d/15_ucs-online-version.list
File: /etc/apt/sources.list.d/18_ucs-online-security.list
root@coppermaster:~# DEBIAN_FRONTEND=noninteractive apt-get install univention-scalix univention-scalix-amavis univention-kolab2-framework- univention-kolab2-webclient-
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
W: Kann nicht auf die Liste apt.univention.de scalix/all/ Packages (/var/lib/apt/lists/apt.univention.de_2.2_maintained_component_scalix_all_Packages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis nicht gefunden)
[/quote] Da fehlte das “apt-get update”. Das wurde mittlerweile in der Anleitung nachgebessert.

[quote=“Scherer”]
Ausserdem empfiehlt es sich das “unmaintained” Repository einzubinden. ucr set repository/online/unmaintained="yes"
[/quote] Das ist nicht notwendig. Die Anleitung wurde entsprechend angepasst.

Damit sollten eigentlich alle Probleme gelöst sein. Wenn es noch nicht funktioniert oder ich jemanden vergessen habe, dann einfach nochmal melden.

Viele Grüße
Stefan Gohmann


#17

durch apt-get clear und apt-get update

konnte ich jetzt Scalix installieren.

Vielen Dank

mit dem Administrator und dem Kennwort konnte ich die SAC einsteigen.

sxadmin muss man selbst ändern falls man etwas nachsehen muss. :wink:

LG

Franz


#18

Korrektur

wenn dann nehmt den Befehl:

apt-get clean

LG
Franz