Samba VFS recycle Module via UDM

german

#1

Hallo Miteinander,

wir haben einen Fileserver wo UCS drauf läuft. Es gibt diverse Freigaben und ich möchte an einer dieser freigegebenen Ordnern das VFS Module “recycle” einsetzten. Ich habe erstmals die Anweisungen der folgenden Forumpost gefolgt [url]Samba VFS Parameter] und es hat leider nicht geklappt.
Ich habe unter Samba-Allgemein - VFS-Objekte folgende Einstellungen eingetragen: “vfs objects = recycle” “recycle:versions = yes” “recycle:noversions = *.pst” “recycle:exclude = *.tmp *.TMP *.bak *.BAK” “recycle:touch = Yes” “recycle:keeptree = Yes” “recycle:repository = .recycle” und ich konnte die gesetzten Einstellungen in der /etc/samba/shares.conf.d/freigabe Datei schon sehen.
Dann habe ich die Einstellungen unter Samba-Allgemein - VFS-Objekte weggenommen und habe die Datei /etc/samba/local.conf wie folgend konfiguriert:
vfs objects = recycle
recycle:repository = .NetworkRecycleBin
recycle:versions = yes
recycle:noversions = *.pst
recycle:maxsize = 0
recycle:exclude = *.tmp *.TMP *.bak *.BAK
recycle:touch = Yes
recycle:keeptree = Yes
recycle:directory_mode = 0750
recycle:subdir_mode = 0700
Ein Neustart des Samba Dienstes mit “/etc/init.d/samba restart” ist vorgenommen worden. Es ist ein .NetworkRecycleBin Ordner erzeugt aber nicht für die gewünschte Freigabe sondern in einem anderen freigegebenen Ordner. Wie kann ich diese Parameter an meinem gewünschten freigegebenen Ordner einsetzten?

beste Grüße
Julian


#2

Hallo,

ich weiß nicht, ob ich deine Frage richtig verstehe.

Wenn du die Parameter auf einer berstimmten Freigabe setzen möchtest, öffne im UMC die Freigabe, “Erweiterte Einstellungen -> Erweiterte Samba Einstellungen”.


#3

Hallo DBGTMaster,

wie Du meinst bei Erweiterte Einstellungen für Samba-Freigaben sehe ich nur “Key”, “Value” und “Einträge” und keinen platz für VFS-Objekte. VFS-Objekte sind bei mir unter Samba Allgemein zu finden, aber damit hat es trotzdem nicht geklappt.

Gruß
Julian


#4

Hallo,

Unter “Samba Allgemein” trägst du das benötigte VFS Module ein, unter den Erweiterten Einstellungen die Werte, welche das recycle Modul benötigt:


Falls dieses auch nicht funktioniert, poste bitte die gesamte Ausgabe vom Befehl “testparm”.

lG


#5

Hallo DBGTMaster,

ich habe eigentlich UDM Version8.0.78-1.344.201108121441, Build12.08.2011, local InstallationUnivention Corporate Server 2.4-3-2 (golden beech) aber trotzdem habe es wie Du es beschrieben hast eingetragen und es hat endlich geklappt. Danke schön fürs Antworten.

für Interessierte:
in meinem UDM unter Freigaben -> Samba-Allgemein -> VFS Objekte habe nur recycle eingetragen und dann bei Freigaben -> Erweiterte Samba-Einstellungen -> mehreren Eigenschaften eingetragen z.B. bei Key recycle:repository und bei Value .NetworkRecycleBin

testparm gibt folgende Ausgabe zum freigegeben Ordner aus:

[sharedfolder]
path = /daten/fileserver/sharedfolder
read only = No
create mask = 0770
force create mode = 0770
security mask = 0770
force security mode = 0770
directory mask = 0770
force directory mode = 0770
directory security mask = 0770
force directory security mode = 0770
strict locking = No
vfs objects = recycle
recycle:maxsize = 0
recycle:touch = true
recycle:keeptree = true
recycle:versions = true
recycle:repository = .NetworkRecycleBin

beste Grüße
Julian


#6

Hallo liebe Leute!

Der Post ist zwar schon ein wenig älter, aber vielleicht kommt trotzdem noch eine Antwort auf meine Frage:

Ich hab auf meinem UCS-(File)Server mit den Ansätzen aus diesem Thread wunderbar für meine Shares einen “Netzwerkpapierkorb” einrichten können. Wie aber stell ich auf den User-(Home-)Laufwerken die VFS-recycle-Option ein? Für die gibts ja keine Freigabe in der Form, dass ich sie in den Eigenschaften bearbeiten könnte, oder?
Ich kann das natürlich in dem templates ändern, aber ich wär dann doch gerne “sauber” bzw. “updatesicher” unterwegs…

lG


#7

Moin,

Die Home-Share ist in »/etc/samba/base.conf« enthalten. Diese Datei wiederum wird vom Template »/etc/univention/templates/files/etc/samba/base.conf« erzeugt. Wenn ich mir das Template so anschaue, so wird klar, dass hier wenig Flexibilität geboten wird.

Aber: Sie haben die Möglichkeit, die Erzeugung dieser automatischen Home-Share zu verhindern, indem Sie die UCR-Variable »samba/share/home« (Achtung: Singular!) auf »no« setzen. Anschließend können Sie über die UMC manuell eine Share namens »homes« (Achtung: Plural!) anlegen und dort dann nach Herzenslust die entsprechenden Einstellungen vornehmen.

Sinnvollerweise sollten Sie sich vorher einmal den Inhalt von »/etc/samba/base.conf« anschauen, um zu wissen, wie Sie Ihre neue »homes«-Share konfigurieren müssen.

Gruß,
mosu


#8

Das ist ein guter Ansatz, danke!

Ich probier das mal aus…


#9

Ich hab mich ein wenig herumgespielt: Wirklich sauber ist das auch nicht. Das geht schonmal damit los, dass der Share manuell erzeugt werden muss für jeden User (oder hab ich da was nicht verstanden?). Darüber hinaus wird dann zB. ein NFS-Mount auf das User-home-Verzeichnis nimmer stimmen bzw. aufs gleiche Verzeichnis zeigen.

Die schöne Konsistenz von dem System geht so leider flöten.


#10

Moin,

schauen Sie sich doch bitte einmal die Konfiguration der [homes]-Share in »/etc/samba/base.conf« an. Hier wird klar, dass der Name der Share selber »homes« ist – und Samba macht dann aus dieser Share mit diesem speziellen Namen intern ein »jeder User hat seine eigene Freigabe«.

Wenn ich das richtig sehe, dann müssen Sie bei den ganzen »recycle«-Anweisungen keinen Benutzernamen angeben. Soweit schon mal gut.

Nun können Sie weiterhin bei der Pfadangabe in der Share auf Sonderzeichen wie %U zurückgreifen, was durch den Usernamen ersetzt wird.

Also: in der UMC eine neue Share namens »homes« anlegen, in den Optionen NFS ausschalten. Beim Verzeichnis »/home/%U« eintragen, bei »Samba« muss der »Windows name« natürlich »homes« heißen, »show in Windows network environment« aus.

Speichern.

Das war’s. Bei einem kurzen Test bei mir klappte das (ohne die »recycle«-Dinger). Eine Share, nicht eine pro Benutzer.

MfG,
Moritz Bunkus


Papierkorb .recycle funktioniert in der Benutzer-Homes Freigabe nicht
#11

Hallo,

trotz der testparm Ausgabe:

[ShareName] path = /Public/Documents/Folder read only = No inherit acls = Yes csc policy = documents include = /etc/samba/shares.conf.d/Public vfs objects = acl_xattr recycle recycle:exclude = *.tmp *.TMP *.bak *.BAK recycle:repository = .NetworkRecycleBin recycle:versions = true recycle:keeptree = true recycle:touch = true recycle:maxsize = 0

passiert hier nach einem restart und anschließenden Tests nichts. Den Ordner habe ich auch manuell einmal testweise angelegt, wie unter http://blog.is-a-geek.org/papierkorb-fur-samba-freigaben-auf-ubuntu-einrichten beschrieben, wobei dies natürlich einen auch unter SMB sichtbaren Ordner erzeugt und damit nicht so sinnvoll ist, da dieser Ordner eigentlich für die normalen User unerreichbar bleiben sollte.

Die Einstellungen in der UMC sind:
Freigaben: Freigabename
Samba -> VFS-Objekte: recycle
Erweiterte Einstellungen -> Erweiterte Samba-Einstellungen
recycle:maxsize = 0
recycle:repository = .NetworkRecycleBin
recycle:exclude = *.tmp *.TMP *.bak *.BAK
recycle:versions = true
recycle:keeptree = true
recycle:touch = true

Vielleicht hat jemand einen Tipp?

Toll wäre (als Anregung gemeint) natürlich eine Option in der GUI wie bei QNAP oder Synology-NAS, wo der Netzwerkpapierkorb für SMB ganz einfach einzurichten ist!

VG,
TP


#12

Moin,

was in der von Ihnen verlinkten Anleitung leider nicht steht, ist dass der Ordner, in den die Dateien verschoben werden, für den aktuellen Benutzer beschreibbar sein muss. Ein einfaches »chmod 777 .NetworkRecycleBin« sollte helfen.

Gruß,
mosu


#13

Hallo,
vielen Dank für die (mal wieder) superschnelle Hilfe!
Sobald ich wieder im Büro bin, werde ich gleich testen und hier eine Rückmeldung abgeben!
VG,
TP


#14

Hallo,

nein, leider keiner Erfolg, auch mit 777 nicht. Ich musste die Optionen auch aus der Freigabe entfernen, da es ansonsten Probleme gab. Ich finde den Fehler so nicht, für eine ausführliche Analyse des Samba-Log habe ich momentan leider keine Zeit.
Sollte ich noch etwas herausfinden, werde ich hier berichten!
VG,
TP


#15

Moin,

schade… Ich hatte es extra ausprobiert, mit copy & paste Ihrer Einstellungen der Share übernommen. Solange die Berechtigungen dem User auf dem Recycle-Verzeichnis keine Schreibrechte gegeben hatten, klappte es auch bei mir nicht, nach einem »chmod a+rwx« ging’s dann aber sofort.

Würde mich interessieren, woran es lag, falls Sie’s noch herausfinden sollten.

Gruß,
mosu