Root Passwort in UCS 5.0?

Hello all,

I am trying to follow up this post: How To Set An UCR Variable During Installation
During the installation, I press CTRL + ALT + F(something) -> that takes me to the console but not the way that is mentioned in the article. However, there I am first asked for the login. User “root”, Password “univention” does not work. I can’t find other passwords in the source code and also no hint in the forum etc. How can I set UCR variables during the installation?

I tried it with UCS 4.4 as well, results in the same.
Addition: I use virtual box appliances. By the way, this is what it looks like when I press CTRL + ALT + F1:
image

UCS root password is set during the base installation, before the domain configuration.

Hi @dejavu, thank you for your answer. Please have a look at the tutorial I linked in the first post. That is what I want to achieve but that leads me to another input mask that asks for the login before there was the chance to set the root password. That is why I am asking. :slight_smile:

Hello. I’m possibly still confused. I looked at the provided link in your original post and tested an installation of UCS from scratch in a virtual machine before commenting. Instructions for the Step1 are pretty clear. In the Step 2, “Ctrl-Alt-F2” did not work in my setup because of the existing key reservations, so I ended up using tty4 and needed to login.

If one does the base installation, which is basically a graphical Debian server installation, the root password is known as it is to be entered by hand during that time.

Otherwise, the unknown root password issue could be resolved by reinstalling UCS or chrooting into UCS after booting from a live Debian ISO and resetting the root password.

I cannot easily test the same on a physical box to verify if “Ctrl-Alt-F2” would open something different other than the login prompt you and I were seeing. Also, I wonder what setup the author of the tutorial was using, under which the switch to the passwordless BusyBox console is expected. Another difference may be that I tested UCSv5 while the tutorial is for UCSv4. They gotta be somewhat different under the hood. Regardless, if the root password is known, any secure tty should not be a show stopper.

Hi @dejavu,

to avoid conflicts with existing key reservations I used a softboard from Virtualbox. CTRL ALT F2 does nothing when I am in the graphical mode BUT returns me to the graphical mode if I am coming from the login prompt. So existing key reservations shouldn’t be a problem. I Also testet UCS 4.4 with the same result. Might there be the problem that root login is permitted until I set a password for Administrator? I think other Linux distros do not allow logins as root user until there is a second user with a password. Anyway there is also another article where a user reports that the login with root/univention shall be working: NetBIOS Namen bei der Installation festlegen