Proxy Error Owncloud 9.1

docker
owncloud

#1

Hi everyone,

after some troubles, and tipps from the forum, i successfully updated my owncloud 8.2 to 9.0 and than to 9.1.

But now i get the following 502 error when i try to access it:

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /owncloud/.

Reason: Error reading from remote server

Apache/2.2.22 (Univention) Server at owncloudsrv Port 80

Where should i search for log files with the new dockerized owncloud app?
Anyone had similar problems?

Best Regards,
René


Owncloud 9.1 Proxy Fehler
#2

You can access the container with

univention-app shell owncloud82

There you can check the logs (/var/log/apache2/*). Maybe it’s enough to restart the apache:

service apache2 restart 

#3

Thats funny, theres no apache in the docker app :-/

root@owncl-77572173:/# service apache2 status
apache2: unrecognized service
root@owncl-77572173:/# 


#4

Interesting. Is the output like this?

# dpkg -l|grep apache
ii  apache2-mpm-prefork                        2.2.22-13.101.201609281005               amd64        Apache HTTP Server - traditional non-threaded model
ii  apache2-utils                              2.2.22-13.101.201609281005               amd64        utility programs for webservers
ii  apache2.2-bin                              2.2.22-13.101.201609281005               amd64        Apache HTTP Server common binary files
ii  apache2.2-common                           2.2.22-13.101.201609281005               amd64        Apache HTTP Server common files
rc  libapache2-mod-php5                        5.4.45-0.235.201611171529                amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  libapache2-mod-php7.0

You can ignore libapache2-mod-php5


#5

Sadly no :confused:

root@owncl-77572173:/# dpkg -l | grep apache
root@owncl-77572173:/#

Edit1:
I am going to reinstall the owncloud app
 let’s see if it helps

Edit2:
it seem’s that the container doesn’t get deleted, theres no new download of the docker app during the installation process

Reinstalled and still no apache there, the apache should be within the docker app (docker shell) right?


#6

Anyone an Idea? :slight_frown:


#7

The current system state is not clear to me, so lets start with some basics. What is currently installed on the UCS host? That would be the output of univention-app info

Its not an error that the docker image for the owncloud app is not downloaded again upon reinstalling the app, the base image is present on the UCS host - see the output of docker images

What would probably be helpful is the information in the logfile /var/log/univention/management-console-module-appcenter.log from the time of the app installation


#8

Okay, here we go:

root@owncloudsrv:~# ucr search --brief ^version
version/erratalevel: 429
version/patchlevel: 4
version/releasename: Vahr
version/version: 4.1
root@owncloudsrv:~# ucr search --brief server/role
server/role: memberserver
root@owncloudsrv:~# docker images
REPOSITORY                                       TAG                 IMAGE ID            CREATED             VIRTUAL SIZE
appcenter-backup-owncloud82                      1497635278          ae1ef15d7346        2 days ago          413.5 MB
hello-world                                      latest              f054dc87ed76        4 days ago          1.84 kB
docker.software-univention.de/ucs-appbox-amd64   4.1-3               964dd49306b2        10 months ago       407.8 MB
root@owncloudsrv:~# 

i installed the app with univention-app install owncloud82=9.1.4-20170427 so theres nothing in the Appcenter Log.


#9

Sorry, i assumed that you reinstalled the app via the UMC App Center module. To capture the installation log from the installation via command line, something like this should create the logfile install.log in the current directory:

univention-app install owncloud82=9.1.4-20170427 2>&1 | tee install.log


#10

Doesnt look so well :frowning2:

install.log (21.2 KB)


#11

Is 192.168.168.100 an UCS system? If yes which role has it?

ucr search role

Is this the system where you try to install Owncloud?

You should also sheck the service records via the UMC


#12

The docker container inherits the nameserver settings from the UCS host. That host has to have a nameserver configured, that is capable of resolving UCS domain servers. Set the UCR variable nameserver1 on your UCS host to such a server and retry the installation. The default setting would be the domaincontroller master.


#13

192.168.168.100 is the UCS Master

nameserver1 of our owncloudsrv points to 192.168.168.100 the UCS Master.

i still have the question, if there shold be a apache package inside the docker application, cause there isn’t any apache package, and in the installer log, you can see that the installer is trying to call “a2enmod” which retuns “not found”



#14

The join of the appbox image failed. The app was therefor never installed, so the correct php and apache2 packages are missing.

First, we have to fix the issue that the docker container cannot join your domain. As SirTux suggested, check the DNS service records. This sdb article contains the default settings that should be present in a UCS domain.


#16

The DNS Settings are all correct:

root@owncloudsrv:~# host -t SRV _domaincontroller_master._tcp.domain.local
_domaincontroller_master._tcp.domain.local has SRV record 0 0 0 ucsmaster.domain.local.
root@owncloudsrv:~# 

But i have an idea, our system is allready on 4.2, only the owncloudsrv is still at 4.1-4.
I am currently updating it to 4.2 with removed owncloud.

When it’s finished i will reinstall owncloud, maybe this way works 
 fingers crossed :nerd:


#17

And again :rolling_eyes:

Search DC Master: 

**************************************************************************
* Join failed!                                                           *
* Contact your system administrator                                      *
**************************************************************************
* Message:  missing dns service record for _domaincontroller_master._tcp.domain.local
**************************************************************************
Something went wrong while joining the system

On the owncloud server, where owncloud should be installed i can successfully resolve _domaincontroller_master, and also rejoin the host.

But the Docker Application still says no :frowning:

Edit1:

my Owncloud docker app isn’t even able to communicate with anyone :flushed:

root@owncloudsrv:~# univention-app shell owncloud82
root@owncl-46995696:/# nslookup ucsmaster
;; connection timed out; no servers could be reached

root@owncl-46995696:/# ping 192.168.168.100 -c2
PING 192.168.168.100 (192.168.168.100) 56(84) bytes of data.
^C
--- 192.168.168.100 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1013ms

root@owncl-46995696:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.17.42.1     0.0.0.0         UG    0      0        0 eth0
172.17.0.0      *               255.255.0.0     U     0      0        0 eth0
root@owncl-46995696:/# ping 172.17.42.1
PING 172.17.42.1 (172.17.42.1) 56(84) bytes of data.
64 bytes from 172.17.42.1: icmp_req=1 ttl=64 time=0.123 ms
64 bytes from 172.17.42.1: icmp_req=2 ttl=64 time=0.068 ms
^C
--- 172.17.42.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1014ms
rtt min/avg/max/mdev = 0.068/0.095/0.123/0.029 ms
root@owncl-46995696:/# exit
root@owncloudsrv:~# ifconfig 
docker0   Link encap:Ethernet  Hardware Adresse 02:42:e5:fb:06:f6  
          inet Adresse:172.17.42.1  Bcast:0.0.0.0  Maske:255.255.0.0
          inet6-Adresse: fe80::42:e5ff:fefb:6f6/64 GĂŒltigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:883 errors:0 dropped:0 overruns:0 frame:0
          TX packets:166 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 SendewarteschlangenlÀnge:0 
          RX bytes:54830 (53.5 KiB)  TX bytes:13915 (13.5 KiB)

eth0      Link encap:Ethernet  Hardware Adresse 82:02:7e:87:73:f3  
          inet Adresse:192.168.168.27  Bcast:192.168.168.255  Maske:255.255.255.0
          inet6-Adresse: fe80::8002:7eff:fe87:73f3/64 GĂŒltigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:126015 errors:0 dropped:585 overruns:0 frame:0
          TX packets:71161 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 SendewarteschlangenlÀnge:1000 
          RX bytes:173701016 (165.6 MiB)  TX bytes:6388658 (6.0 MiB)

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 GĂŒltigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:65536  Metrik:1
          RX packets:615 errors:0 dropped:0 overruns:0 frame:0
          TX packets:615 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 SendewarteschlangenlÀnge:1 
          RX bytes:111130 (108.5 KiB)  TX bytes:111130 (108.5 KiB)

veth689c9c4 Link encap:Ethernet  Hardware Adresse 66:7c:b9:08:09:c9  
          inet6-Adresse: fe80::647c:b9ff:fe08:9c9/64 GĂŒltigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:883 errors:0 dropped:0 overruns:0 frame:0
          TX packets:179 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 SendewarteschlangenlÀnge:0 
          RX bytes:67192 (65.6 KiB)  TX bytes:14913 (14.5 KiB)

root@owncloudsrv:~# 


#18

Somehow the nameserver settings are not correctly applied to the docker container. Please check the nameserver settings inside the container:
univention-app shell owncloud82 ucr search --brief {nameserver,forwarder} cat /etc/resolv.conf ping -c 1 $(ucr get nameserver1)


#19

As edited before,

my docker app isn’t able to reach the outside, maybe because i disabled the univention firewall on the Host system.

Currently trying :slight_smile:


#20

Uh, yes, that might be the cause - or part of it. univention-firewall also does some important NAT rules for the Docker containers, as far as i know.


#21

YEEES FINALY!!!

Here’s the solution:
You must not disable the univention firewall!! :joy:

root@owncloudsrv:~# ucr set security/packetfilter/disabled='no'

Currently joining, i’ll update the post when finished :slight_smile:

Edit1:

Everything works now :slight_smile:
As told, the problem was the disabled univention firewall which is required for the NAT rules for the docker container.

I only had to rejoin our ‘owncloud host server’ because the owncloud Service was missing in the UMC.

Thanks for the help to everyone.

Best Regards,
René