Owncloud 10.2 Proxy Error / No MySQL Connection

Hey Guys,

I keep struggling with installing the OwnCloud App:
The setup:

  • Univention 4.4-2
  • Let’s Encrypt
  • Owncloud 10.2.1-1 (installation worked without warnings)
  • Server works behind a router (FritzBox), only Port 443 is open, https is forced

The problem:
I reach the UMC without any problem via https. After opening the Owncloud App I see the following:

Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /owncloud.

Reason: Error reading from remote server

Apache/2.4.25 (Univention) Server at kkserver.selfhost.eu Port 443

According to this topic I enabled the firewall with root@owncloudsrv:~# ucr set security/packetfilter/disabled='no' and reinstalled the app without success.

Then I checked the logs of the app and found the following:

Waiting for MySQL...
wait-for-it: waiting 180 seconds for
wait-for-it: timeout occurred after waiting 180 seconds for
Creating volume folders...
Creating hook folders...
Waiting for MySQL...
wait-for-it: waiting 180 seconds for

So OwnCloud is not able to reach the MySQL Database. According to this topic I checked if MySQL listens to 3306 and the result was

Administrator@ucs:~$ sudo lsof -PniTCP:3306 -sTCP:LISTEN
mysqld  5954 mysql   17u  IPv4 1976045      0t0  TCP *:3306 (LISTEN)

This looks quite fine for me. Someone has an idea what I may have done wrong? Do I miss something? Do I have to activate the firewall of the Univention Server after enabling it? Do I have to open the Port 3306 in the Univention firewall?

Edit: A new installation with the new ISO Image solved the problem.

Hello @Heisenberg,

it looks like you have run into this problem: https://www.univention.com/blog-en/2019/10/technical-difficulties-with-ucs-4-4-2-download-image/

Can you please provide me some details on the origin of what you are using?

  1. What appliance do you use? UCS appliance or the pre-configured ownCloud App appliance?
  2. Where did you download it from?
  3. When did you download it?

The problem should only occur, when you have used either the UCS appliance or the UCS ISO image and downloaded it before Oct, 1st.

It may be related to this issue, which passed quality assurance and is waiting to be released.

I’m looking forward to your details. Thank you very much.

Best regards,

Hey Nico,

I downloaded the UCS ISO-Image from here https://www.univention.de/download/download-ucs/ at the first of October at eleven o’ Clock and installed the OwnCloud App in the Univention Management Console.

What would be your recommended solution? Shall I install Univention again with the new ISO?

Thank you very much so far!

Hello @Heisenberg,

yes, please download the updated ISO which includes the fix.

Best regards,