Problem bei Update auf 4.4-8

Today I tried to upgrade my server from 4.4-7 to 4.4-8. Now I’ve got the following error:

Apr 23 10:35:58.774 [45961] info: config: SpamAssassin failed to parse line, "6,0" is not valid for "required_score", skipping: required_score 6,0
sa-compile: not compiling; 'spamassassin --lint' check failed!

I’ve done spamassassin --lint and --update and also checked the local.cf to change the required_score to 6,0. Also after restarting the SpamAssassin-Service the error was the same.

Has someone a hint for me, how to solve this?

Thx for help.

Maybe change it to 6.0?

I’ve changed it to 6.0 but the error is still the same. But thx for your comment!
Best wishes
Helmut

Still the same with a comma?

In UCS 4.4-7 there is in
/usr/share/spamassassin/local.cf as comment:
# required_score 5.0
in /etc/spamassassin/local.cf:
required_score 5.0
So the dot seems to be the right one.

compiling Spamassassin needs to be done with sa-compile, if h am right.

I’ve done the changes and started to compile. Here you can see what has happened:

root@ucs:/etc/spamassassin# sa-compile
Apr 24 20:04:57.103 [64419] info: config: SpamAssassin failed to parse line, "6,0" is not valid for "required_score", skipping: required_score 6,0
Apr 24 20:04:58.491 [64419] info: generic: base extraction starting. this can take a while...
Apr 24 20:04:58.491 [64419] info: generic: extracting from rules of type body_0
  0% [                                           ]   0.00 rules/sec --m--s LEFT
zoom: rule __FOR_SALE_PRC_10K will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
  7% [===                                        ]  83.82 rules/sec 00m06s LEFT
zoom: rule __LARGE_PERCENT_AFTER will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 17% [=======                                    ]  67.48 rules/sec 00m07s LEFT
zoom: rule __FOR_SALE_NET will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558

zoom: rule __GAPPY_SALES_LEADS will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 30% [============                               ]  76.01 rules/sec 00m06s LEFT
zoom: rule __UNICODE_OBFU_ASC will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 37% [================                           ]  52.44 rules/sec 00m05s LEFT
zoom: rule __FOR_SALE_LTP will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 42% [==================                         ]  55.86 rules/sec 00m05s LEFT
zoom: rule __FOR_SALE_OBO will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 61% [==========================                 ]  77.09 rules/sec 00m03s LEFT
zoom: rule __DAY_I_EARNED will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558

zoom: rule __PILL_PRICE_02 will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558

zoom: rule __CLEAN_MAILBOX will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 73% [===============================            ]  68.60 rules/sec 00m02s LEFT
zoom: rule __FOR_SALE_PRC_100K will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 80% [==================================         ]  73.37 rules/sec 00m01s LEFT
zoom: rule __FOR_SALE_PRC_1K will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558

zoom: rule __UNICODE_OBFU_ZW will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 87% [=====================================      ]  84.32 rules/sec 00m01s LEFT
zoom: rule __PILL_PRICE_01 will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
 94% [========================================   ]  82.30 rules/sec 00m00s LEFT
zoom: rule __LOWER_E will loop on SpamAssassin older than 3.3.2 running under Perl 5.12 or older, Bug 6558
100% [===========================================]  70.27 rules/sec 00m08s DONE
100% [===========================================] 288.85 bases/sec 00m09s DONE
Apr 24 20:05:16.822 [64419] info: body_0: 1328 base strings extracted in 18 seconds
sa-compile: not compiling; 'spamassassin --lint' check failed!
root@ucs:/etc/spamassassin# spamassassin --lint
Apr 24 20:05:35.839 [65025] warn: config: SpamAssassin failed to parse line, "6,0" is not valid for "required_score", skipping: required_score 6,0
Apr 24 20:05:37.611 [65025] warn: lint: 1 issues detected, please rerun with debug enabled for more information
root@ucs:/etc/spamassassin#

There is still the “6,0” somewhere behind. Don’t know where!

Greetings and thx
Helmut

maybe you set the wrong entry in UCR
grafik

that will overwrite your etc config file

rg
Christian

Hello, Christian,

Thx for the hint! That was the solution. Unfortunately, the following error still occurs:

Checking for package status: iF  sa-compile                                          3.4.2-1~deb9u4                                                      all          Tools for compiling SpamAssassin rules into C
failed
ERROR: The package state on this system is inconsistent.
       Please run 'dpkg --configure -a' manually
Error: Update aborted by pre-update script of release 4.4-8

When I run “dpkg --configure -a” manually, I get the error message

root@ucs:~# dpkg --configure -a
sa-compile (3.4.2-1~deb9u4) wird eingerichtet ...
Running sa-compile (may take a long time)
chmod: Beim Setzen der Zugriffsrechte für '/var/lib/spamassassin/compiled/5.024/3.004002/Mail/SpamAssassin/CompiledRegexps/body_0.pm': Die Operation ist nicht erlaubt
dpkg: Fehler beim Bearbeiten des Paketes sa-compile (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 sa-compile
root@ucs:~#

Do you also have a hint for this problem ?

Best wishes
Helmut

Today I tried to update my server an I got the following error:

File: /etc/apt/apt.conf.d/55user_agent
sa-compile (3.4.2-1~deb9u4) wird eingerichtet ...
Running sa-compile (may take a long time)
command 're2c -i -b -o scanner1.c scanner1.re' failed: exit 0
dpkg: Fehler beim Bearbeiten des Paketes sa-compile (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 12 zurück
Fehler traten auf beim Bearbeiten von:
 sa-compile
E: Sub-process /usr/bin/dpkg returned an error code (1)

ERROR: An error occurred during update. Please check the logfiles.
Mit Apr 28 20:07:11 CEST 2021

Starting univention-upgrade. Current UCS version is 4.4-7 errata965

Is there someone with an idea ? I think that’s something refering to the error I listed above?!

BW Helmut

OK - I’ve done the update! I deinstalled spamassassin, updated and installed spamassassin again. But now - and I think this perhaps could be another topic - I don’t get new eMails via Kopano!

Is there now a idea what to do - or have I to go to Kopano-Forum for this ?

I also have renewed user, password and server for to get the eMails. But they are not received.

What can I do ?

Regards
Helmut

You now have to check in /var/log/mail.log, whether incoming mails still will be handled as expected.

mail.log is as follows:

May  1 12:38:37 ucs postfix/scache[55414]: statistics: start interval May  1 12:35:17
May  1 12:38:37 ucs postfix/scache[55414]: statistics: domain lookup hits=0 miss=2 success=0%
May  1 12:38:37 ucs postfix/scache[55414]: statistics: address lookup hits=0 miss=2 success=0%
May  1 12:39:18 ucs fetchmail[5894]: 8642 Nachrichten (8642 gesehene) für yyy@xxx.at bei mail.xxx.xxx.
May  1 12:39:18 ucs fetchmail[5894]: 121126 Nachrichten (121124 gesehene) für xxx@xxx.at bei mail.xxx.xxx.
May  1 12:39:19 ucs postfix/smtpd[55573]: connect from localhost[127.0.0.1]
May  1 12:39:19 ucs postfix/smtpd[55573]: NOQUEUE: reject: MAIL from localhost[127.0.0.1]: 552 5.3.4 Message size exceeds fixed limit; proto=ESMTP helo=<ucs.xxx.local>
May  1 12:39:19 ucs fetchmail[5894]: Nachricht xxx@xxx.at@mail.xxx.xxx:120322 von 121126 wird gelesen (13947 Bytes im Nachrichtenkopf) (Log-Meldung unvollständig)
May  1 12:39:19 ucs fetchmail[5894]: SMTP-Fehler: 552 5.3.4 Message size exceeds fixed limit
May  1 12:39:19 ucs postfix/smtpd[55877]: connect from localhost[127.0.0.1]
May  1 12:39:19 ucs postfix/smtpd[55877]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <SRS0=5cENjMlKomRd=I6=xxx.gv.at=ooo@xxx.at>: Recipient address rejected: User unknown in virtual mailbox table; from=<> to=<SRS0=5cENjMlKomRd=I6=xxx.gv.at=ooo@xxx.at> proto=SMTP helo=<ucs.xxx.local>
May  1 12:39:19 ucs postfix/smtpd[55877]: disconnect from localhost[127.0.0.1] helo=1 mail=1 rcpt=0/1 quit=1 commands=3/4
May  1 12:39:19 ucs fetchmail[5894]:  nicht gelöscht
May  1 12:39:19 ucs postfix/smtpd[55573]: NOQUEUE: reject: MAIL from localhost[127.0.0.1]: 552 5.3.4 Message size exceeds fixed limit; proto=ESMTP helo=<ucs.xxx.local>
May  1 12:39:19 ucs fetchmail[5894]: Nachricht xxx@xxx.at@mail.xxx.xxx:120891 von 121126 wird gelesen (6543 Bytes im Nachrichtenkopf) (Log-Meldung unvollständig)
May  1 12:39:19 ucs fetchmail[5894]: SMTP-Fehler: 552 5.3.4 Message size exceeds fixed limit
May  1 12:39:19 ucs postfix/smtpd[55877]: connect from localhost[127.0.0.1]
May  1 12:39:19 ucs postfix/smtpd[55877]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <SRS0=gXbB0y23A4HB=JT=xxx.gv.at=ooo@xxx.at>: Recipient address rejected: User unknown in virtual mailbox table; from=<> to=<SRS0=gXbB0y23A4HB=JT=xxx.gv.at=ooo@xxx.at> proto=SMTP helo=<ucs.xxx.local>
May  1 12:39:19 ucs postfix/smtpd[55877]: disconnect from localhost[127.0.0.1] helo=1 mail=1 rcpt=0/1 quit=1 commands=3/4
May  1 12:39:19 ucs fetchmail[5894]:  nicht gelöscht
May  1 12:39:19 ucs postfix/smtpd[55573]: disconnect from localhost[127.0.0.1] ehlo=1 mail=0/2 rset=2 quit=1 commands=4/6

There are a lot of reject-messages but i didn’t make any changes :unamused:

The mails are too big. - There is a limitation of mail size.

Hello, again :wink:
I’ve fixed that limitation via registry entry. Mails are received from the external mailserver but now I get this error:
May 2 12:06:31 ucs fetchmail[45454]: 121149 Nachrichten (121148 gesehene) für helmut@xxx.at bei yyy.xxx.zzz. May 2 12:06:32 ucs postfix/smtpd[47063]: fatal: cannot handle socket type AF_INET6 with "inet_protocols = ipv4" May 2 12:06:33 ucs postfix/master[45377]: warning: process /usr/lib/postfix/sbin/smtpd pid 47063 exit status 1 May 2 12:06:33 ucs postfix/master[45377]: warning: /usr/lib/postfix/sbin/smtpd: bad command startup -- throttling
After that I changed the mail/postfix/inet/protocols-variable to “all” an now I get this:

ay  2 12:27:54 ucs fetchmail[45454]: Nachricht helmut@xxx.at@yyy.xxx.zzz:121150 von 121150 wird gelesen (2823 Bytes im Nachrichtenkopf) (773 Bytes im Nachrichtenkörper) nicht gelöscht
May  2 12:27:54 ucs postfix/qmgr[45379]: F1B46E06C: from=<SRS0=cS48dCEC5/gR=J5=fff.gv.at=vn.nn@xxx.at>, size=3881, nrcpt=1 (queue active)
May  2 12:27:54 ucs postfix/smtp[54020]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
May  2 12:27:54 ucs postfix/smtp[54020]: F1B46E06C: to=<helmut@xxx.at>, relay=none, delay=0.09, delays=0.09/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
May  2 12:27:54 ucs postfix/smtpd[54106]: disconnect from localhost[::1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5

I think the inet-protocols are right now. But why is the connection refused at 10024? Is there a problem with amavis?
BW and thx
Helmut

Because you did remove Spamassassin, which listened at port 10024. So forwarding to port 10024 needs to be stopped.

Yes, I removed it and after the update of univention I reinstalled it. Therefore I expected that the port will be the same than before. The port 10024 is in the registry variable mail/postfix/tls/client/policy/amavis. Actually it contains “[127.0.0.1]:10024 none”. Do I have to insert an other port or should there be an empty field? At the other side: can I reconfigure amavis / spamassassin again to work like before?

Maybe one of these threas might help:



I went back to my backup of 4.4-7 and after a day there comes an update to errata 4.4.(!)8 968 and now there was no problem to update to 4.4-(!)8.

The problem is solved but I don’t know what has been :frowning:

After the update there was a further update to errate 4.4-8 969.

Thx to all for hints and info!

BW Helmut