PLUCS für UCS 4.2+

ucs-4-2
plucs

#1

Hallo zusammen, hallo IT25-Team,

ich wollte mich nur einmal kurz erkundigen, ob eine Aktualisierung von PLUCS für UCS 4.2+ geplant ist.
Momentan ist dies noch die App, welche unsere Aktualisierung zurück hält, sollte es jedoch kein Update geben, müssen wir sowieso nach einer anderen Lösung suchen, daher wäre ein kurzer Hinweis sehr praktisch für die weitere Planung.

Vielen Dank vorab,
vG, Christian.


#2

I would like to chime in here. I started off with USC 4.1, had already installed PLUCS and installed for my small amount of users… an update had occured and low and behold - PLUCS is GONE! As a helpful suggestions, alert users of what will NOT work and will be ultimately uninstalled after upgrade to 4.2, this way we could chose stability over functionality or vice-versa. It may have been in the fine print, but who reads that anyways!

I would like to see this software come back, but githubs activity for this project has not been touched for 4 years now… OpenFire will integrate with LDAP, will probably have to go that route, a bit much but I need XMPP!

Any planning or timeframe on when or if ever this (among another handful of very useful apps not supported yet) will come into the new platform 4.2?

Cheers


#3

Hi,

I’ll switch to english hoping that this is ok for all readers.

We havent worked on a UCS 4.2 version of PLUCS for a couple of reasons. The main reason is (surprise!); money. PLUCS is completely free and until now there was nothing which could compensate the time and money needed for a new release.
At the time we released the first version of PLUCS we hoped that we could get at least some customers who would ask for commercial support. Beside one paid enhancement request regarding the integration of mod_filter which was published last year this was unfortunately not the case.

We see still some new installations of PLUCS as we get informed about these events. But we dont know anything about installations in production apart from companies we have in our contact list through other channels. I have asked the responsible people at Univention more than one year ago to get at least a number of running installations but did not get any data until now. (yes, this data is available but not passed to the app vendors).

Nearly 2 years ago we decided to put the sources on Github (https://github.com/it25gmbh/plucs). There have been some contributions by Univention staff and another Univention partner but I did not have the feeling that there is a larger interest. There have been 3 pull requests which have been merged last year.

In December we have been contacted by Univention regarding the dockerization of PLUCS. At this time I have stated clearly that we are not going to put additional work into a task which would not bring additional functionality without knowing about chances to refund the effort. In addition I offered to fork PLUCS and continue to those who get the highest value from this integration. During the last months I have renewed this offering. There seems to be interest but nobody has decided yet,

Based on the usual behaviour with earlier upgrades of UCS I would expect that upgrades are not possible if there is any component installed which is not available for UCS 4.2.

As there seems to be a valid interest for PLUCS on UCS 4.2 I have already escalated my question to the sales and product team at Univention. In addition I had the idea to start a crowd funding campain for the new release: I havent put much time to search for an appropriate platform and other related things but I do have an idea how much working time we would need to publish a new version.

If anyone is interested to donate in general and without the commitment to a specific amount please contact me either here or through any other channel. If I get at least 5 responses within the next 2 weeks I will search for a funding platform.

Thanks for reading,

Dirk Ahrnke


#4

Hello Ahrnke,

I would be interested in donating to the new app.
May be Univention would donate, too, because this app makes UCS more powerful :slight_smile:

Christian.


#5

Hello Dirk,

what is the current status? Is there a chance for PLUCS for UCS 4.2?

SirTux


#6

There is still a chance that we will find a way and there are ongoing discussions about this topic.
Decisions are to be published until the end of this month.

cheers,
Dirk


#7

Thank you. I hope there will be a solution.

By the way, is Docker a requirement for new applications on UCS?


#8

There is no such requirement. We suggest that new Apps should be created as Docker Apps, but do not enforce it or reject Apps if the ISV wants to create a non Docker App. For some Apps it does not make sense, e.g. if it ships kernel modules.


#9

Is there already a decision?


#10

Depending on other running projects we are planning to release PLUCS for UCS 4.2 in June or July.
PLUCS will remain free but we will offer optional subscriptions for all who want to support the further development of the integration.


#11

Hello Dirk,

just wanted to ask what is the current status? Is there a chance soon for PLUCS for UCS 4.2?

dNano


#12

The main task is solved on my dev system

Next step is packaging, upload and test. No ETA but I still try to finish in July.


#13

Thanks! Appreciate your feedback.


#14

Hello, what’s the current status?


#15

ping @ahrnke :wink:

Beitrag muss mindestens 20 Zeichen lang sein


#16

Strange, I get only notified on threads when I am directly addressed, not on updates. Anyway.
The 3rd quarter is over and there was not much progress. So lets try to continue in Q4.


#17

Just want to add myself to the queue of desiringly waiting people to hear good news regarding the PLUCS implementation in UCS 4.2 + :slight_smile:


#18

Hey,

as a workaround I had simply removed the Plucs app, updated my servers and installed ejabberd manually. Then I adjusted the YAML-based configuration file to include the same settings that the old Plucs plugin set in the old configuration format. We did not use those group-based features Plucs offers; therefore I got away with the following settings (only showing the important/changed settings, not the whole configuration file):

loglevel: 5
hosts:
  - "linet-services.de"
listen: 
  - 
    port: 5222
    ip: "::"
    module: ejabberd_c2s
    certfile: "/etc/ssl/acme/jabber.linet-services.de/fullchain-and-privkey.pem"
    starttls: true
    protocol_options:
      - "no_sslv3"
    max_stanza_size: 65536
    shaper: c2s_shaper
    access: c2s
  - 
    port: 5269
    ip: "::"
    module: ejabberd_s2s_in
  - 
    port: 5280
    ip: "::"
    module: ejabberd_http
    web_admin: true
    http_poll: true
    http_bind: true
    captcha: true

s2s_use_starttls: optional
s2s_certfile: "/etc/ssl/acme/jabber.linet-services.de/fullchain-and-privkey.pem"
s2s_protocol_options:
  - "no_sslv3"
ldap_servers:
  - "trinculo.bs.linet-services.de"
ldap_encrypt: tls
ldap_port: 7636
ldap_rootdn: "uid=ldapsearch,cn=users,dc=bs,dc=linet-services,dc=de"
ldap_password: "…"
ldap_base: "dc=bs,dc=linet-services,dc=de"
ldap_uids:
  - "uid": "%u"
ldap_filter: "(&(objectClass=univentionXMPPAccount)(xmppEnabled=TRUE)(xmppDomain=linet-services.de))"
acl:
  admin:
     user:
         - "mbunkus": "linet-services.de"
  local: 
    user_regexp: ""


modules: 
  mod_shared_roster_ldap:
    ldap_base: "dc=bs,dc=linet-services,dc=de"
    ldap_rfilter: "(objectClass=univentionXMPPGroup)"
    ldap_ufilter: "(&(objectClass=univentionXMPPAccount)(uid=%u))"
    ldap_gfilter: "(objectClass=univentionXMPPGroup)"
    ldap_groupattr: "cn"
    ldap_memberattr: "memberUid"
    ldap_memberattr_format: "%u"
    ldap_filter: "(xmppEnabled=TRUE)"
    ldap_useruid: "uid"
    ldap_userdesc: "decos"
    ldap_groupdesc: "cn"
    ldap_user_cache_validity: 30
    ldap_group_cache_validity: 30

  mod_vcard_ldap:
    ldap_vcard_map:
      "NICKNAME": {"%u": []}
      "FN": {"%s": ["displayName"]}
      "LAST": {"%s": ["sn"]}
      "FIRST": {"%s": ["givenName"]}
      "ORGNAME": {"%s": ["o"]}
      "LOCALITY": {"%s": ["l"]}
      "STREET": {"%s": ["street"]}
      "PCODE": {"%s": ["postalCode"]}
      "DESC": {"%s": ["description"]}
      "TEL": {"%s": ["telephoneNumber"]}
      "EMAIL": {"%s": ["mailPrimaryAddress"]}
      "BDAY": {"%s": ["univentionBirthday"]}
      "PHOTO": {"%s": ["jpegPhoto"]}
    ldap_search_fields:
      "User": "%u"
      "Name": "givenName"
      "Family Name": "sn"
      "Email": "mailPrimaryAddress"
      "Birthday": "birthDay"
    ldap_search_reported:
      "Full Name": "FN"
      "Nickname": "NICKNAME"
      "Birthday": "BDAY"

As you can see in the LDAP filter we kept on using the extended LDAP attributes provided by the Plucs package.

Maybe this’ll can be a starting point for others who want to implement a similar workaround.

In the meantime we’ve switched to using Mattermost and don’t use Jabber anymore; hence all the past tense above.

Kind regards,
mosu


#19

And Mattermost can be installed from the appcenter as well: https://www.univention.com/products/univention-app-center/app-catalog/mattermost/


#20

Hi,

@ahrnke could you give an perspective when the 4.2 relase will be available?