OpenProject erlaubt keinen Login

openldap
german
ucs-4-2
openproject

#1

Hallo Univention!

Ich habe Probleme mit der OpenProject-App.

Ich habe anfangs versucht, OpenProject mit meinem persönlichen Konto zu installieren (Ist Mitglied von Domain Admin), was aber wohl teilweise scheiterte. Nach der Installation als Administrator läuft die App irgendwie, erlaubt aber keinen Login mit irgendwelchen Daten. Das getestete Konto ist für OpenProject freigeschaltet und hat auch eine Primäre E-Mail-Adresse gesetzt.

Schaue ich mir auf der Konsole das Log an (journalctl -f --unit=slapd.service), dann sehe ich … nichts. OpenProject unternimmt nicht mal den Versuch einer Authentifizierung.

Ich habe die App jetzt auch mal deinstalliert und reinstalliert, aber ohne Änderung.

Wie kann ich herausfinden, was schiefläuft. Und wie kann ich das ändern?

Besten Gruß
MasinAD


#2

Huhu,

ich kann das in einer frischen OpenProject-Installation unter UCS 4.3-0 bestätigen. Allerdings lag es bei mir daran, dass der Benutzer zwar in OpenProject angelegt wurde, dort aber gesperrt war. Ich musste mich also zuerst als Benutzer admin (Initialpasswort: admin) bei OpenProject anmelden, in die Administration gehen und dort den regulären Benutzer entsperren. Anschließend klappte auch die Anmeldung mit dem regulären Benutzer.

Gruß
mosu


#3

So, nach Datenbankhacking konnte ich mich dann auch als Admin anmelden. In der ucs_ldap-Konfiguration fehlte der Haken “create user accounts on the fly”. Dann ging auch die Anmeldung wieder.


#4

Huhu,

Ich bin mir 99% sicher, dass der absichtlich aus ist. Andernfalls kann man sich höchstwahrscheinlich mit jedem Benutzer, der im LDAP existiert, in OpenProject anmelden, unabhängig davon, ob der Haken dafür im LDAP gesetzt ist oder nicht.

Die Benutzer werden normalerweise vom Listener-Modul in OpenProject angelegt, aber halt nur dann, wenn der OpenProject-Haken im LDAP gesetzt ist.

Gruß
mosu