NFS-Freigabe für Homeverzeichnisse

german

#1

Hallo,

ich habe auf dem UCS Server eine Freigabe Namens homes angelegt (NFS), und auf dem LDAP Container der die Rechner enthält verknüpft als Richtlinie.
Leider wird das ganze auf den CLients (UCC) aber nicht angewandt?

Führe ich auf dem CLient als root das Script /usr/lib/univention-directory-policy/nfsmounts aus, funktioniert es, das Verzeichniss wird gemounted. Als User ausgeführt gibts jedoch eine Permission denied Meldung auf /etc/machine.secret

Woran liegts? Wieso wird das beim Start nicht automatisch mit gemounted, obwohl die RIchtlinie ja scheinbar zieht.

Viele Grüße
Daniel


Anleitung NFS-Freigabe
Terminalserver: Homeverzeichnisse vom UCS mounten
#2

Hallo,

ich kann das beschriebene Verhalten in einer Testumgebung nicht beobachten.
Ich bin folgendermaßen vorgegangen:
[ul]
[li]1. UCC Software-Update-Einstellungen Richtlinie erstellt für das Paket nfs-common[/li]
[li]2. NFS-Freigabe freigabe erstellt[/li]
[li]3. NFS-Freigabe Richtlinie erstellt[/li]
[li]4. NFS-Freigabe Richtlinie verknüpft mit dem entsprechenden Container in welchem sich der Client befindet[/li]
[li]5. UCC Software-Update-Einstellungen Richtlinie mit Client verknüpft[/li][/ul]

Das Verzeichnis wird anschließend erfolgreich automatisch gemounted.

Haben Sie den Client erfolgreich gejoined? Bitte prüfen Sie auch einmal direkt nach der Benutzeranmeldung die Ausgabe von:

mount cat /etc/fstab

Mit freundlichen Grüßen,
Tim Petersen


#3

Hallo,

ich muß hier mal diesen alten Thread aufwärmen…

[quote] 1. UCC Software-Update-Einstellungen Richtlinie erstellt für das Paket nfs-common
2. NFS-Freigabe freigabe erstellt
3. NFS-Freigabe Richtlinie erstellt
4. NFS-Freigabe Richtlinie verknüpft mit dem entsprechenden Container in welchem sich der Client befindet
5. UCC Software-Update-Einstellungen Richtlinie mit Client verknüpft[/quote]

1, 2, 3 gehen wunderbar. Aber wie mache ich 4 und 5? Muß ich dann jeden einzelnen Rechner mit dieser Verknüpfung versehen? Und wie verknüpfe ich das überhaupt?

Danke!


#4

Du gehts in das Modul “LDAP-Ansicht” (oder wie das jetzt auch genau heißen mag) navigierst dann in der Bauumstruktur zum Rechnercoontainer, dann Rechtsklick “bearbeiten” und dann auf den Tab Richtlinien. Der Rest sollte sich von selbst erklären.


#5

OMG! Da muß man erst mal drauf kommen…und auch darauf, daß man in dem Drop-Down Feld “ererbt” durch das dort gezeigt LDAP Objekt ersetzen soll…anstatt einfach die Bezeichnung einzutragen, die man vergeben hat.

Ok, erledigt. Danke nochmal.

Der einstieg in UCS/ UCC ist doch recht kompliziert…eigentlich wollten wir ein einfaches System…

/knebb


#6

Hey knebb,

eigentlich ist das alles überhaupt nicht kompliziert - mal ganz davon abgesehen, dass ich ausnahmslos zu allen Fragen die du bisher gestellt hast entsprechende Anleitungen in der Dokumentation gefunden habe.
Falls du es nicht kennst: docs.univention.de
Vielleicht macht es Sinn, wenn du da mal reinschaust :slight_smile:

Grüße


#7

Also die Punkte 4 und 5 konnte ich trotz eifrigem Suchen in der Dokumentation nicht wirklich finden.

Aber ich bin ja sowieso der Meinung, daß kommerzielle Dokumentation zu einem Produkt zwar notwendig, aber meist nicht hinreichend ist…

Und, ganz ehrlich: die Bedienung der Oberfläche, insbesondere der einzelnen Module ist leider alles andere als offensichtlich (von selbsterklärend mal abgesehen).

Aber das ist jetzt Off-Topic und gehört hier nicht wirklich hin.

Danke nochmal für die Hilfe!

/knebb


#8

Naja cny hat schon recht. Gerade das hier wäre mit der Suchfunktion des Browsers schnell zu finden gewesen:

docs.univention.de/handbuch-3.1- … l:policies


#9

Damit habe ich so meine Probleme. In der UMC wechsle ich unter Domäne / Richtlinen und wenn ich dort nach nfs suche finde ich nichts.

Wie lege ich die Richtline an und verknüpfe sie?

Viele Grüße
Sven


#10

Am besten direkt am Client oder Container: Unter “Richtlinien” -> “Richtlinie: NFS-Freigaben” -> “Neue Richtlinie erstellen”


#11

ok, ich habe die Richtlinie angelegt:

Container: lan.gehr:/policies/ucc
typ: Richtlinie: NFS-Freigaben

Aber wie verknüpfe ich diese jetzt oder ist dass überhaupt notwendig wenn sie dem Container ucc zugeordnet wurde?

Und wie muss ich das NFS-Share bezüglich der Rechte anlegen. Ich habe einfach alles so gelassen wie es ist. Im Handbuch finde ich dazu nichts. Also wie man das Home anlegt. Die Rechte sind detailliert beschrieben.


#12

Ja die gilt dann automatisch für die im Container liegenden Clients. Das ist ja der Sinn hinter der LDAP-Hirarchie.


#13

Daneben habe ich noch das Paket nfs-common an den Client verteilt was sich dort danach auch automatisch installiert hat aber das Home wird trotzdem nicht per NFS bezogen.

Sind noch weitere Schritte notwendig?


#14

Ja ich meinte du sollst den Container, in dem die UCC-Clients liegen, mit dem Modul “LDAP-Verzeichnis” in der Kategorie “Domäne” bearbeiten und da dann die Rcihtlinie verknüpfen.


#15

Also:

Domäne -> LDAP-Verzeichnis

-> computers -> ucc-desktops anklicken. Dort sehe ich meinen UCC (Hostname: merkur). Diesen markieren und über hinzufügen:

  • Richtlinie: NFS-Freigaben

?


#16

Nein auf dem Container Rechtsklicken und “bearbeiten” auswählen. Du willst die Rcihtlinie ja schließlich nicht seperat für jeden Client manuell verknüpfen müssen.

Btw. ich kann nur empfehlen einfach mal das Handbuch durchzulesen. Das hab ich damals gemacht und es hat sehr geholfen.


#17

Ich denke ich habe soweit alle korrekt verknüpft. Das Share angelegt mit root:users, in Domäne -> Rechner eine Richtlinie “ucc-updates,” erzeugt/zugeordnet doe nfs-common ausrollt was auch passiert.

Die NFS-Freigabe-Richtline erstellt und über das LDAP-Verzeichnis dem Container “ucc.desktops” zugewiesen.

Aber auf dem Client passiert diesbezüglich nichts und wenn ich währen des booten/anmelden des Clients am Server in das Logfile schaue passiert da in Sachen NFS auch nichts.


#18

Ist es in die /etc/fstab übernommen worden?

cat /etc/fstab

#19

ja, da wurde es korrekt eingetragen

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
UUID=400cd4ad-09de-4261-968a-90d2a5023714       /boot   ext4    defaults        0       2
UUID=a05ff871-da41-4953-9df7-417e7d6ada05       none    swap    sw      0       0
/dev/loop0      /       ext4    errors=remount-ro       0       1
UUID=71dd69dc-7940-4687-b419-8a7c9f48b29a       /home   ext4    defaults        0       2
192.168.24.5:/home      /home   nfs     defaults        0       0       #LDAP Entry DN: cn=home,cn=tux.gehr.lan,cn=shares,dc=gehr,dc=lan

#20

Ok, und wenn du versuchst es manuell zu mounten?

mount
mount /home
mount