Nextcloud-URL without trailing slash

nextcloud

#1

Hi all!

We’re using UCS@school together with the Nextcloud app. Everything works fine except for one point. The Nextcloud sync app (on Windows) shows its URL without a trailing slash, i.e. “https://my.domain.com/nextcloud”. Additionally this behaviour doesn’t change when inputting the server address with a trailing slash while configuring an account to use with the Nextcloud app.

If you then click on this URL you’ll get a 404 from Apache. Only if you append the trailing slash to the URL the Nextcloud website is shown.

What’s the Univention way to amend the UCS Apache config to treat a hit on “/nextcloud” the same as a hit on “/nextcloud/”?

Best regards, Valentin


#2

Hey,

add a file to Apache, e.g. /etc/apache2/conf-available/nextcloud-fix.conf, with the following content:

RedirectMatch ^/nextcloud$ /nextcloud/

Enable the configuration:

a2enconf nextcloud-fix
systemctl reload apache2

#3

Thanks a lot Moritz! That’s such an easy solution I should have thought of myself, I suppose!

BR
Valentin