Missing Modul Computer: Linux / Computer: Ubuntu

umc
ucs-4-2

#1

I’m trying to change an LDAP setting from UMC. I can chose a lot of modules to extend, but the roles Linux and Ubuntu are missing.
How can I extend modules to work with the Linux and Ubuntu role?
Best, Bernd


Add Custom Attribute to all Computers
Bareos Client on Member or Slave Servers
#2

If I understand Bug 30387 - Some computer types do not show up in “Needed Module”-list correctly it might be possible to create these extended attributes by using the udm commandline.

cheers, Dirk


#3

Thank you for the link! I will look into this as soon as I can…


#4

Thank you again for the link! It took some time to have some time for this, but it is pretty straight forward. Find the relevant dn (in my case bareos-enabled):

you@ucs:~# udm settings/extended_attribute list --filter cn=bareos-enabled

and modify it:

you@ucs:~# udm settings/extended_attribute modify \
	--dn "cn=bareos-enabled,cn=bareos,cn=custom attributes,cn=univention,dc=domain,dc=local" \
	--append module="computers/linux" \
	--append module="computers/ubuntu"

Bernd


UCS in vorhandenes Bareos einbinden, Client installieren
#5

I had same problem thx for help :smiley: