Kopano Files -> Nextcloud

kopano
german
nextcloud

#1

Hallo,

ich möchte in der Kopano WebApp in den Einstellungen eine Verknüpfung zu meiner Owncloud.

Einstellungen -> Files -> Add Account

Aber der Status steht immer nur auf “Rot”.

Funktioniert es überhaupt mit Nextcloud?

Danke

Frank


Kopano Files: Nextcloud
#2

Hallo Frank,

Owncloud - Zarafa verbinden mit Files sollte dein Problem lösen.


#3

uff - ok nicht wirklich verständlich für mich.

zumal ich ein letsencrypt zert nutze (über das univention-letsencrypt modul).


#4

Also das Zert sollte ok sein denke ich wenn es ein offizielles ist aber dein Pfad scheint nicht zu stimmen

der sollte bei owncloud /owncloud/remote.php/webdav heissen und nicht /remote.php/webdav
mit nextcloud nehme ich ann /nextcloud/remote.php/webdav
und die Server Adresse ohne https:// da reicht der reine FQDN zb server.domain.de
LG

Christian


#5

Hallo,

danke - aber Dein Vorschlag hat nicht geholfen ;-(



Grüße

Frank


#6

Hallo Frank,

ich habe dies gerade mal kurz getestet und die Letsencrypt Zeriktikate werden in der Tat bereits als gültig von Curl erkannt. Zusätzlich dazu habe ich einmal gegen eine Nextcloud 11 Demo Instanz von help.nextcloud.com/t/demo-insta … -live/8709 getestet. Hier klappt für mich die Verbindung.


Kopano Files: Nextcloud
#7

Hallo,

ich habe leider das gleiche Problem.
Der Zugriff über die Nextcloud-App vom Handy aus klappt einwandfrei.
Aber eben nich in Kopano

MfG,
Stefan


#8

Hallo @r100gs,

das Vorgehen aus

hilft bei dir nicht?

Gruß, Nico.


#9

Hm,

Nein, der Demo-Server klappt bei mir leider auch nicht.
ich glaube da liegt noch mehr im argen.
Nach einem Neustart kann sich Kopano nicht mehr mit dem LADP und Mysql-server verbinden.
Ich werde über Ostern mal schauen, ob ich da was machen kann.
Ist nur ein Testserver und meine erste Installation. VIelleicht habe ich da etwas falsch gemacht.
Ich denke, dass ich über Ostern den Server neu aufsetze und dann schaue ich weiter.

Vielen Dank und mit freundlichen Grüßen,
Stefan


#10

Hallo Zusammen,

sorry für das Ausgraben dieses Threads aber ich hatte gerade das selbe Problem und habe eine mögliche Lösung!

Egal welchen Server (auch die Nextcloud Demo Instanzen) ich verwendet habe, das Symbol blieb immer rot und ich bekomme keine Fehlermeldung.

Habe es testweise auf einem anderen (komplett unabhängigen) UCS probiert. Dort blitzte ganz kurz die Meldung auf, PHP-Curl sei nicht installiert. Nachdem ich dieses Paket nachinstalliert hatte und Apache neu gestartet hatte, konnte ich Verbindungen zu Nextcloud herstellen.

Auch auf meinem anderen Server, welcher die Fehlermeldung nicht zeigte, hat die Installation von php-curl das Problem behoben.

Hoffe mal das Hilft noch jemandem der hier drüber stolpert.

Lg. Felix