Kein Zugriff auf LDAP per udm nach Upgrade 4.0.1

german

#1

Hallo,

nach einem teilweisen Update von 3.5 auf 4.0.1 habe ich kein Zugriff mehr auf LDAP.
Der Updateverlauf ist durchgelaufen bis zur Aktualisierung von slapd. Dies ist abgebrochen durch übrig gebliebenden Einträge von einer deinstallierten Owncloud App.

Loading the database from the LDIF dump failed with the following error while running slapadd: 551be66d OVER: Loading Translog Overlay 551be66d OVER: db_init 551be66d OVER: Configuring Translog Overlay 551be66d OVER: Configured Translog Overlay to use file "/var/lib/univention-ldap/listener/listener" 551be66d /etc/ldap/slapd.conf: line 200: rootdn is always granted unlimited privileges. 551be66e <= str2entry: str2ad(OWNCLOUDENABLED): attribute type undefined slapadd: could not parse entry (line=1284) 551be66e OVER: db_close 551be66e OVER: db_destroy dpkg: Fehler beim Bearbeiten von slapd (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück Fehler traten auf beim Bearbeiten von: slapd E: Sub-process /usr/bin/dpkg returned an error code (1)

Aufgrund der Fehlermeldung bin ich nach dem Beitrag LDAP verwaitse Objektklassen wegen verwaister Objektklassen vorgegangen.
Der Zugriff auf ldap war hier noch möglich, was aber nicht zum gewünschten Erfolg geführt hat. Über die Weboberfläche habe ich dann in der Config Registry alle “owncloud” Einträge gelöscht.
Eine wiederholt Aktualisierung schlug wieder mit gleicher Fehlermeldung fehl. Danach war kein Zugriff auf das ldap-verzeichniss mehr möglich.
Seither meldet auch der directory-listener “can not connect to LDAP server”. Per ucr kann ich noch auslesen und bearbeiten. Das Progrann ‘udm’ schlägt immer wegen Authentifizierungsfehler fehl. Zwischendurch ist auch zu lesen “Credentitials not valid (49)”.
Der Hostname etc. lässt sich alles auflösen. Der Dämon slapd läuft in der Prozessliste. Auf die Weboberfläche kann zugriffen werden, aber sobald auf die Benutzer oder Rechner zugegriffen wird, läuft es ins timeout.
Ich vermute das die Authentifizierung zum Ldap-Verzeichnis falsch ist für den Benutzer ‘admin’ ( glaub /etc/slapd.secret)

Wo kann ich jetzt anfangen zu suchen ? Das Forum oder Wiki habe ich schon durchgearbeitet. Besteht evtl die Möglichkeit dies zurück zusetzen ?

Vielen Dank
Marco


#2

Hallo,

erstmal abgesehen von der Vorgeschichte (wie es überhaupt dazu kommen kann, dass das ownCloud-Schema das Update nicht überlebt) ein paar grundsätzliche Dinge:

Das Löschen der UCR-Variablen hat erstmal keine Auswirkung auf das LDAP.
An den .secret-Dateien sollte man eher nicht drehen, es sei denn, man weiß genau, dass es daran liegt.

Ich würde an dieser Stelle zunächst mal mit “dpkg --audit” nachschauen, wie der Paketstatus ist und ggf. mit “dpkg --configure -a” nachhelfen.

Viele Grüße,
Dirk Ahrnke