Issues with Kopano WebApp

Hi - I’m still in the process to get my UCS servers to version 5.

  • Upgrade for PDC is done (UCS 1)
  • New installation for BDC is done (UCS 2)
  • Upgrade for Kopano-Core is done (UCS 3)
  • failing with Kopano-WebApp (UCS 4)

First I tried to upgrade to version 5. The upgrade itself was fine - but it removed my Kopano WebApp installtion - and I was unable to get it back installed. So I rolled back my snapshot.
Today I tried to installa fresh new server based on ISO 5.x. The installation was fine - but I was also unable to install Kopano WebApp.

I searched univention help and bug tracker and noticed it didn’t happend the first time.

I found UCS Update 4->5: Kopano Webapp deleted and fails to install - #7 by t0mcat

I checked all the servers → /etc/apt/sources.list.d/20_ucs-online-component.list

  • UCS 1 → no entries (what looks OK to me - becaus no Kopano software is directly installed on the server)
  • UCS 2 → no entries (what looks OK to me - becaus no Kopano software is directly installed on the server)
  • UCS 3 →

deb Index of /univention-repository/5.0/maintained/component kopano-core_20220630105644/all/
deb Index of /univention-repository/5.0/maintained/component kopano-core_20220630105644/amd64/
deb Index of /univention-repository/5.0/maintained/component z-push-kopano_20211125121614/all/
deb Index of /univention-repository/5.0/maintained/component z-push-kopano_20211125121614/amd64/

  • UCS 4 → no entries (based on the fact that it is a fresh installation - looks OK to me)

If I’m added

deb Index of /univention-repository/5.0/maintained/component kopano-webapp_20220622120718/all/
deb Index of /univention-repository/5.0/maintained/component kopano-webapp_20220622120718/amd64/

to the UCS 4 server (as mentiobed in the other post) - it will be removed once I start to install Kopano WebApp via the web-interface.

So where is the trick to get Kopano WebApp running on a UCS 5.0-4 errata803?

Please see also post Comparision PDC (Master) and BDC (Backup) for possible Backup-2-Master migration - #15 by Pepe

No feedback to that post here yet - maybe the reason is the following

Bute would be nice to get a confirmation - and estimation.

Thank you in advance

Hi - any updates to the mentioned Kopano patch? Is the patch now available?

Hi - any updates? Looks like the Kopano WebApp support is not in central focus.

I upgraded once again a UCS 4.x system to the latest UCS 5.0.6 version to see if the part has been fixed. But also there the upgrade removed the Kopano WebApp - and you are unable to re-install it via the App Center.

I tested it as well on my other test system - based direct on UCS 5.0.4 - with no Kopana WebApp in the past. But also the same error message.

I can’t be the only one who is facing such an issue.

Is there anyone from the Kopano or UCS team how is able to assist? All other UCS migration has been finished - just the one with the Kopano WebApp is a nightmare.

Kopano WebApp in UCS store at present →
Kopano WebApp in use on UCS 4.x system →

Looks like - no new software version since a very long period. Why???

Kopano is out of service since 2022: