How to configure collabora online with nexcloud


#1

Hello im running UCS 4.4-1 errata186 with Nexcloud 15.0.8

Ive install “Collabora Online” in nexcloud by going into “Apps” - Office & Text"

Now when we go in “Settings” we see an option for “Collabora Online” asking for a URL

Now what are the step i need to do next

Any documentation how to do this

Thanks !


#2

You have to install Collabora from the UCS App Store, after that you get detailed instructions:

1. Completing the Configuration of Collabora Online

  • First, you need a running File Sync and Share solution like EGroupware, Nextcloud or ownCloud (all are available in Univention App Center).

  • Next, you need to install the Collabora Plugin in your File Sync and Share solution (see below for more information).

  • Then you can give https://FQDN_OF_THIS_SERVER without a port number as the WOPI URL in your preferred File Sync and Share solution.

  • Please make sure the File Sync solution has access to the Root CA of the UCS domain. The respective apps usually take care of this.

  • Use the FQDN of the File Sync server when accessing the File Sync solution.

  • Make sure your browser can resolve the FQDN of the File Sync and Collabora Online server.

  • Make sure that the browser can validate the certificate of the Collabora server. UCS creates his own certificate authority and it is used by the apps. The Univention Knowlege Base may help on this.

  • The administrator console can be found here: /loleaflet/dist/admin/admin.html (HTTPS only).

2. Support Key

Collabora Online requires a support key for production use. After you have purchased one, you receive a support key. To upload and activate it, follow these steps:

  • Go to the App Settings below.
  • Upload the key file via the respective upload dialog.
  • Stop the application at the top of the app settings.
  • Start the application again at the top of the app settings.

3. Integrations

3.1. EGroupware

  • Goto the App Center, select EGroupware and install it.
  • Login in EGroupware with an Admin-Account of EGroupware
  • Go to AdminApplicationsCollaboraSite configuration
  • Insert the URL for the Collabora server e.g. https://FQDN_OF_THIS_SERVER
  • There are happening additional checks for the user “anonymous”, which is required for Collabora and file sharing
  • Next step is to set permissions for groups, which should be able to use Collabora Online . Either edit the User group or use context menu on the user group → Access control and add checkmark for Collabora . So Admin can decide who is able to use Collabora in EGroupware.

3.2. Nextcloud

  • Goto the App Center, select Nextcloud and install it.
  • Install the Collabora Online App in Nextcloud.
    1. Login to Nextcloud as user Administrator .
    2. Goto AppsOffice & Text[Enable] Collabora Online
    3. Goto AdminCollabora Online for Collabora specific settings

3.3. ownCloud

The Collabora Online app in ownCloud is already pre-installed in ownCloud, but deactivated by default. If you install Collabora on the same system as ownCloud, the app will be activated in ownCloud automatically.

You can check and activate the app manually following theses steps:

  • If ownCloud is not installed yet, goto the App Center, select ownCloud and install it.
  • Login to ownCloud as admin user (username owncloud ).
  • Goto SettingsAdmin AppsShow disabled Apps[Enable] Collabora Online
  • Goto SettingsAdminAdditionalCollabora Online : Check the setting for Collabora Online server. By default it is set to the UCS host, where ownCloud is installed.

#3

Thanks for all the info

Presently im already running UCS 4.4-1 errata186 and Nexcloud 15.0.8

So right now to access nexcloud we go to

https://cloud.domainname/nextcloud

What exacly i need to put here in the yellow box

2019-07-18%2013_12_30-

Should i put the same url

https://cloud.domainname

Ive tried it and when im trying to open an .odt file i get this error
2019-07-18%2013_16_15

Thanks again for helping !


#4

You are right, I have the same problem on a more or less fresh install of UCS 4.4-0 errata155 with Kopano, Nextcloud and now Collabora. Same error. No idea how to debug it.

In the yellow box, the default value should be correct, the domain of your server, like https://server.domain.de


#5

ok well let see if anyone have an idea

Thanks !


Nextcloud and Collabora not working out of the box
#6

I created a new thread in the Apps and App Center subforum


You might want to try my solution, it did work for both my productive system as well as the fresh installed one.