Nextcloud and Collabora not working out of the box

collabora
nextcloud

#1

I did a fresh install of the latest UCS version, installed Nextcloud, added my domain to the trusted domains, installed Collabora, activated the Collabora in NC and tried Collabora, it didn’t work.

I tried to install it on a more mature system, which uses Let’s encrypt, same issue.

The problem is discussed in this thread, too:

I created a new thread, so put it in Apps and App Center and also, because we must miss something fundamental.

So what additional steps must be taken, that Collabora works, or how can we debug it? (I suspect there is some issue with some certificates, but I don’t know what to do.)
Can I access Collabora directly without the login to NC?


#2

Hello @FrankM,

how do you access Collabora? Do you use a HTTPS connection to Nextcloud?

No, you cannot access Collabora directly without login to Nextcloud, because Collabora needs a file storage like Nextcloud.


#3

Hi @gulden
I did a fresh install of UCS.
Installed Nextcloud.
Added my domain to the trusted domains

univention-app shell nextcloud sudo -u www-data php /var/www/html/occ config:system:set trusted_domains 3 --value MYDOMAIN.de

Installed Let’s Encrypt
ran

sudo ucr set apache2/force_https=yes
sudo ucr set apache2/hsts/includeSubDomains=yes
sudo ucr set apache2/hsts=yes

restartet the server
Connection via https works without issues.
installed CODE
updated CODE connector in NC
testet it with the given odt document, failed to connect to Collabora


#4

Hello @FrankM,

some more questions:

  1. What is the UCS system’s host and domain name?
  2. What is the fqdn to reach the system from externally?
  3. What URL is configured in the CODE connector in Nextcloud?

You can use examples, if you don’t want to reveal the real names. Key is to have the right ones in the right place.

Best regards,
Nico


#5

Hello,

you can view the Collabora logs with the following command on the UCS host command line:

univention-app logs collabora

If you would like to increase the loglevel, you need to do the following:

  1. Enter the container with univention-app shell collabora. The following commands are executed in the container.
  2. Install your favorite text editor, e.g. vim: apt-get update && apt-get install vim
  3. Open the file /etc/loolwsd/loolwsd.xml in the text editor.
  4. Look for the section <logging> in that file.
  5. Change the value of the tag <level> from warning to a higher level like information or debug. The available levels are documented in that file. Please be careful with changes, because a corrupt file could end in a restart loop of the container.
  6. Usually the Collabora container makes an automatic restart. In my test I had to manually restart it with univention-app restart collabora.
  7. View the logs of the container with univention logs collabora. If you want to follow the output, obtain the container id with docker ps -a and then run docker logs -f $container_id.

I hope this helps.

Best regards,
Nico


#6

Status quo:
With the help of @gulden we were able to narrow it down to a DNS problem.
From my server, I’m able to ping everything, except my own server.
Works: server.domain.de
Also works: ping 9.9.9.9, google.de, …
Doesn’t work: domain.de

If I use server.domain.de to open nextcloud, collabora starts.
If I use domain.de to open nextcloud, collabora doesn’t start, because it can’t reach domain.de from the server itself.

How can I solve this? I have a second, older UCS installation, there I can ping domain.de without any problem.
On the new install, it’s a fresh install, it doesn’t work. So I assume, Univention must have made some change.


#7

From within the collabora container (univention-app shell collabora) I can’t reach ping domain.de
I manually added the public static IP of my server to/etc/hosts in the collabora container. Usingping domain.de I was able to reach my server now and since then, Collabora works from Nextcloud.

Question 1: Will this change be permanent or will it get lost after an update?
Question 2: Why does it not work out of the box, so what’s an official solution to make collabora work from domain.de and not only from server.domain.de.


How to configure collabora online with nexcloud