Horde Anmeldung nicht möglich


#1

Hallo,

die Horde-Webmail App war bereits vollständig installiert, und alles lief prächtig. Urplötzlich ist keine Anmeldung mehr möglich, weder mit Http noch mit Https.
Was ich sehe ist, dass der Benutzername nicht bei Dovecot ankommt, da steht dann im Log “user=<>”. Und es fällt auf, dass aus Docker heraus keine Verbindung zum LDAP-Server möglich ist - “invalid credentials”.
Dieselben Users können sich problemlos direkt beim IMAP-Server anmelden.
Wenn ich Horde über das App-Center deinstalliere und anschießend neu installiere, bleiben dann die User-Daten (Adressbuch, Kalender etc.) erhalten?
Bin ratlos und für jede Hilfe dankbar.

Swimmer


#2

Hallo,

ja, bei der Deinstallation von Horde bleiben die Daten erhalten (alles wird in einer postgresql Datenbank auf dem Docker Host gespeichert, diese wird nicht gelöscht und bei einer erneuten Installation weiterverwendet). Es wird dann aber wieder die Standard-Konfiguration für Horde verwendet, wenn da Anpassungen gemacht wurden, müssen diese dann erneut durchgeführt werden.

Vielleicht wollen wir trotzdem kurz schauen, ob wir das Problem finden und ggf. lösen können.

Meine erste Vermutung ist, dass der Horde Container keinen Zugriff mehr auf das LDAP hat. Bei der Anmeldung an Horde wird ein Script ausgeführt, das entweder eine UID oder eine Email-Adresse bekommt und dafür die entsprechende primäre Email-Adresse aus dem LDAP sucht (so dass man sich an Horde mit UID oder EMail-Adresse anmelden kann).

Testen kann man das auf dem Server, auf dem die Horde App läuft, mit (wobei test1 eine existierende UID sein muss):

-> univention-app shell horde \
    /usr/share/univention-mail-horde/univention-mail-horde-login-wrapper test1

Es sollte hier eine Email-Adresse zurückgegeben werden. Falls das nicht funktioniert, versucht sich horde mit einer leeren ID am IMAP Server anzumelden.

Gibt es hier eine Fehlermeldung?

Viele Grüße
Felix


#3

Hallo,

danke für die Bemühungen. Inzwischen habe ich aber schon alles neu installiert.
Irgendwas hatte sich verknotet. Nach der Deinstallation wurde ich beim Versuch der Neuinstallation auf den Migrationsleitfaden verwiesen. Dem bin ich gefolgt. Da wurde erst mal einiges mehr deinstalliert und dann neu installiert. Jetzt klappt alles. Die Nutzerdaten blieben auch erhalten.

Eine Frage, sorry for off topic: Lässt sich mit Gollem wie bei Kopano der Datenspeicher von Nextcloud einbinden?

Gruß - Swimmer


#4

Zur Zeit wohl nicht, https://bugs.horde.org/ticket/14626

VG
Felix