Gruppe Administrators "verschwunden"

Moin
ich habe mich gewundert warum neue UCS Benutzer nicht in Samba zu nutzen sind und habe dann gesehen, es gibt bei der Synchronisation Probleme, die auf das Fehlen der Gruppe Administrators hinweisen. Ursache könnte mal eine volle root Partition gewesen sein, da zu der Zeit der ldap Server sich auch nicht starten ließ und es Probleme mit einer 0 Byte Datei gab, die ich rekonstruieren konnte.

Was habe ich bis jetzt gemacht:

  • Im ldif Backup habe ich den Eintrag für die Gruppe gefunden
  • Ich habe mir den Beitrag von mahescho und moritz durchgelesen und mir schon vorher das Apache DirectoryStudio geladen
  • Ich habe Zugriff auf openldap und “samba ldap”
    Kann ich jetzt aus dem ldif Backup den Datensatz für die Gruppe Administrators extrahieren und in openldap einfach einspielen und es wird dann in den samba ldap synchronisiert?

Grüße aus Berlin

Ben

Das Problem konnte gelöst werden, mit Hilfe von Univention und durch meine weitere Analyse der Log Files.
Der Grund war eine volle root Partition, die das System durchenander brachte.
Was wurde gemacht:

Hilfe von Univention:
univention-s4search --cross-ncs --show-deleted cn=‘Administrators\0ADEL*’

da hatte ich nichts gefunden aber ein univention-s4search zeigte mir, dass die gelöschte Gruppe Administrators noch im samba vorhanden ist und nur auf dem UCS verschwunden war.

/usr/share/univention-s4-connector/resync_object_from_s4.py CN=Administrators,CN=Builtin,DC=domäne,DC=intranet

mit dem nächsten Befehl kann man die Samba Gruppe wieder in den UCS synchronisieren, muß aber vorher schauen, ob ein univention-s4connector-list-rejected Fehler zeigt. Dies war bei mir genau die fehlende Gruppe Administrators. Also vorher den reject beseitigen, indem man die angezeigte Datei verschiebt.

Dann war die Gruppe wieder im UCS aber es ließen sich noch keine Objekte mit dem S4 Connector synchronisieren.

Daraufhin habe ich mir die logs vom Listener / Notifier angesehen und Fehlermeldungen der folgenden Art gehabt:

25.07.19 16:24:41.359  LISTENER    ( INFO    ) : notifier returned = id:83853	dn:<LDAP>	cmd:*
25.07.19 16:24:41.359  LISTENER    ( ERROR   ) : notifier.c:129:notifier_wait_id_result LDAP failed No such object (32): id:83853

Mit Hilfe der Artikel


konnte ich erfolgreich den Cache reparieren und meine bis dahin fehlenden Objekte waren auch unter Windows zu sehen.

Grüße aus Berlin

Ben

1 Like