Cant Upgrade 4.2-4 to 4.3 because of dependencies:


#1

hi, tried many times to upgrade
hier some of the errors
perhaps you have an idea?
its an installation with letsencrypt, fetchmail and kopano with external repo
kopano repos have been removed, also the apps

Fehler traten auf beim Bearbeiten von:
 emacs24
 emacs24-bin-common
 stunnel4

Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 emacs24 : Hängt ab von: libmagickcore-6.q16-3 (>= 8:6.9.6.8) ist aber nicht installierbar
           Hängt ab von: libmagickwand-6.q16-3 (>= 8:6.9.6.8) ist aber nicht installierbar
 emacs24-bin-common : Hängt ab von: emacs24-common (= 24.5+1-11+deb9u1) aber 24.4+1-5+deb8u1 ist installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

(ging aber auch nicht)

Jul 11 15:45:17 ucs-Leister stunnel4[14341]: [ ] errno: (*__errno_location ())
Jul 11 15:45:17 ucs-Leister stunnel4[14341]: [.] Reading configuration from file /etc/stunnel/univention_saml.conf
Jul 11 15:45:17 ucs-Leister stunnel4[14341]: [.] UTF-8 byte order mark not detected
Jul 11 15:45:17 ucs-Leister systemd[1]: stunnel4.service: Control process exited, code=exited status=1
Jul 11 15:45:17 ucs-Leister systemd[1]: Failed to start LSB: Start or stop stunnel 4.x (TLS tunnel for network daemons).
Jul 11 15:45:17 ucs-Leister stunnel4[14341]: [!] /etc/stunnel/univention_saml.conf:16: "options = NO_SSLv2": Illegal TLS option
Jul 11 15:45:17 ucs-Leister stunnel4[14341]: failed
Jul 11 15:45:17 ucs-Leister stunnel4[14341]: You should check that you have specified the pid= in you configuration file
Jul 11 15:45:17 ucs-Leister systemd[1]: stunnel4.service: Unit entered failed state.
Jul 11 15:45:17 ucs-Leister systemd[1]: stunnel4.service: Failed with result 'exit-code'.
dpkg: Fehler beim Bearbeiten des Paketes stunnel4 (--configure):
 Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 stunnel4
E: Sub-process /usr/bin/dpkg returned an error code (1)

#2
Vorbereitung zum Entpacken von .../241-libss2_1.43.4-2A~4.3.0.201801041304_amd64.deb ...
Entpacken von libss2:amd64 (1.43.4-2A~4.3.0.201801041304) über (1.42.12-2+b1A~4.2.0.201702072125) ...
Fehler traten auf beim Bearbeiten von:
 /tmp/apt-dpkg-install-dA3yJF/058-univention-web-js_2.0.0-11A~4.3.0.201803121613_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade"
exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log

#3
Entpacken von perl-modules-5.24 (5.24.1-3+deb9u2) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/perl-modules-5.24_5.24.1-3+deb9u2_all.deb (--unpack):
 Neue Datei »/var/lib/dpkg/info/perl-modules-5.24.list-new« kann nicht angelegt werden: Die Operation ist nicht erlaubt
Vorbereitung zum Entpacken von .../libgcrypt20_1.7.6-2+deb9u2_amd64.deb ...
Entpacken von libgcrypt20:amd64 (1.7.6-2+deb9u2) über (1.6.3-2+deb8u4) ...
Trigger für man-db (2.7.0.2-5) werden verarbeitet ...
Trigger für libc-bin (2.24-11+deb9u1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/perl-modules-5.24_5.24.1-3+deb9u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade"
exitcode of univention-updater: 1
ERROR: update failed. Please check /var/log/univention/updater.log