Zugriff auf App-Center schlägt fehl

german

#1

Hallo,

immer wenn ich versuche das App-Center aufzurufen läuft die Verbindung in einen Timeout mit der Meldung:

“Ein unbekannter Fehler mit Status-Code 502 trat während des Verbindungsaufbaus zum Server auf. Bitte versuchen Sie es später noch einmal.”

Das aktuelle Debug-Log zeigt

tail -f /var/log/univention/management-console-module-appcenter.log 

ein manueller Test der openSSL-Verbindung mit dem App-Store ergibt:

openssl s_client -debug -connect appcenter.software-univention.de:443

Ist das manuelle Kommando zum Debuggen falsch oder ist mit meiner SSL-Installation etwas nicht in Ordnung?

Viele Grüße
Stefan Lorenz


Unable to Upgrade Open-Xchange
#2

Hallo,

das von Ihnen verwendete openssl Kommando ist wohl korrekt.
Sind Sie sicher, dass das System mit dem App Center (85.214.27.218) redet? Haben Sie evtl. einen Proxy dazwischen?
Zu Testzwecken könnten Sie ja auch mal wget mit http versuchen. Das sollte in etwa so aussehen:

# wget http://appcenter.software-univention.de --2013-10-01 16:58:36-- http://appcenter.software-univention.de/ Auflösen des Hostnamen appcenter.software-univention.de... 85.214.27.218, 2a01:238:43b3:da00:516f:fc92:a5f:d5d3 Verbindungsaufbau zu appcenter.software-univention.de|85.214.27.218|:80... verbunden. HTTP-Anforderung gesendet, warte auf Antwort... 301 Moved Permanently Platz: http://www.univention.de/[folge] --2013-10-01 16:58:36-- http://www.univention.de/ Auflösen des Hostnamen www.univention.de... 88.198.15.85 Verbindungsaufbau zu www.univention.de|88.198.15.85|:80... verbunden. ..

Viele Grüße,
Dirk Ahrnke


#3

Der Hinweis auf den Proxy war gut!

Am Ende war es der falsch konfigurierte Squid der zwar allen Clients die Verbindung ermöglicht hat, auch via https aber dem UCS eben nicht.
Ich habe es jetzt einmal quick n dirty durch das Entfernen des Squid gelöst.
Werde den passenden Hinweis posten wenn ich die Kombi zu Laufen bekommen habe da es sich ja hier nicht um einen UCS-Fehler zu handeln scheint.