Zeitserver Timeserver setzen

german

#1

Hallo zusammen,

habe folgendes Problem und möchte gerne dieses Script ablösen.


#!/bin/bash

/etc/init.d/ntp stop
ntpdate at.pool.ntp.org
/etc/init.d/ntp start


Derzeit habe ich noch nichts über das setzen des Timeservers / Zeitservers in UCS gefunden das funktioniert.

in der Univention Configuration Registry in der UMC (Univention Management Console)

finde ich zwar die Einträge für:

Variable Wert Beschreibung Kategorien
timeserver at.pool.ntp.org Der erste NTP-Server System: Netzwerkeinstellungen
timeserver2 Der zweite NTP-Server System: Netzwerkeinstellungen
timeserver3 Der dritte NTP-Server System: Netzwerkeinstellungen

leider funktioniert dies nicht.

Vielen Dank,

MfG

Franz


#2

Hallo,

was genau funktioniert an Ihrer Konfiguration nicht?
Generell sind bei NTP einigen Punkte zu beachten:

  • Die NTP-Server Konfiguration auf UCS-Systemen standardmäßig den DC-Master als Timeserver konfiguriert. Es sollte daher nur auf dem DC-Master ein externer Timeserver konfiguriert werden.

  • Ein NTP-Sever verweigert die Synchronisation mit einem externen Server mit zu hohem offset oder jitter, da dieser als unzuverlässig eingestuft wird.

  • Bei der Verwendung von NTP in einer Virtualisierten Umgebung kann es, aufgrund von zu großen “Zeitsprüngen” vermehrt zu Probleme kommen. Hier sind entsprechende Hinweise zur verwendeten Virtualisierungstechnik zu beachten.

Wenn Sie einen zuverlässigen, externen NTP-Server auf Ihrem DC-Master konfiguriert und den ntpd neu gestartet haben, können Sie z.B. mit dem Befehl “ntpq -p” prüfen ob Ihr NTP-Server die neue Zeitquelle verwendet (Asterisk vor dem Hostnamen/der IP-Adresse).

Mit freundlichen Grüßen
Janis Meybohm


#3

Hallo,

also wenn ich folgendes setzt hat das auch keine Auswirkungen:

ucr set timeserver=“at.pool.ntp.org

ntpq -p
remote refid st t when poll reach delay offset jitter

*LOCAL(0) .LOCL. 10 l 11 64 377 0.000 0.000 0.004

MfG
Franz Eberl


#4
/etc/init.d/ntpd restart

#5

Danke für die kurze Antort :slight_smile:
aber ich hab es nochmal versucht und ich bekomme nur dieses Ergebnis:

[code]ucr set timeserver=“at.pool.ntp.org
Setting timeserver
File: /etc/ntp.conf
File: /etc/default/ntpdate
root@datensrv:~# /etc/init.d/ntp restart

  • Stopping NTP server ntpd [ ok ]
  • Starting NTP server ntpd [ ok ]
    root@datensrv:~# ntpq -p
    remote refid st t when poll reach delay offset jitter
    ==============================================================================
    pluto4.fips.at 131.130.250.250 2 u 2 64 1 9.137 -350986 0.004
    LOCAL(0) .LOCL. 10 l 1 64 1 0.000 0.000 0.004[/code]

Was mich etwas verdutzt wenn ich so etwas sehe bevor ich den Dienst das zweite mal neustarte wie oben:

[code]/etc/init.d/ntp restart

  • Stopping NTP server ntpd start-stop-daemon: warning: failed to kill 10406: No such process
    [ ok ]
  • Starting NTP server ntpd [ ok ][/code]

Der Dienst dürfte schon wieder nicht gelaufen sein.
(oder er wurde durch mein Script nicht mehr neugestartet durch einen Fehler)

Jetzt läuft der Dienst wieder nicht nach kurzer Zeit:

[code]/etc/init.d/ntp status

  • NTP server is not running.
    root@datensrv:~# date
    Mi 3. Feb 18:06:36 CET 2010
  • Stopping NTP server ntpd start-stop-daemon: warning: failed to kill 17099: No such process
    [ ok ]
    3 Feb 17:09:11 ntpdate[24004]: step time server 193.171.23.163 offset -3502.808782 sec
  • Starting NTP server ntpd [ ok ]
    root@datensrv:~# date
    Mi 3. Feb 17:09:12 CET 2010
    ntpq -p
    remote refid st t when poll reach delay offset jitter
    ==============================================================================
    palmers-0000.no 131.130.251.107 2 u 40 64 3 8.696 222.643 67.297
    LOCAL(0) .LOCL. 10 l 39 64 3 0.000 0.000 0.004[/code]

LG

Franz


#6

Hallo,

das ist soweit in Ordnung. Der NTPd braucht einen Moment um den zu verwendenden Server zu ermitteln. Bei einem derartigem offset wird er allerdings auf den lokalen Server zurückfallen.

Das der NTPd sich unaufgefordert konnte ich bisher noch nicht beobachten. Gibt es dazu Meldungen in der syslog?

Mit freundlichen Grüßen
Janis Meybohm