Zarafa4UCS zarafa-licensed nicht verfügbar

mail
german

#1

Die Installation von Zarafa4UCS 6.40.9 ist zurzeit unter UCS2.4 nicht möglich,
weil der Lizenzserver (zarafa-licensed) wegen Abhängigkeiten nicht installiert werden kann.

Folgt man der Dokumentation:
zarafa4ucs.linet-services.de/dokumentation.html
so wird das System zwar ohne Fehler installiert, jedoch fehlt am Ende der Lizenzserver

eine Nachinstallation ist ebenso nicht möglich:

zarafa-licensed: Depends: libboost-filesystem1.35.0 (>= 1.35.0-1) but it is not installable Depends: libboost-system1.35.0 (>= 1.35.0-1) but it is not installable

fügt man der
/etc/apt/sources.list.d/25_zarafa4ucs.list
noch die Debian Lenny Quellen hinzu, kann der zarafa-licensed installiert werden.

deb http://ftp.de.debian.org/debian lenny main

wird dieses Problem in Zukunft noch direkt von Univention gelöst?


#2

Danke für die Info
forge.univention.org/bugzilla/s … i?id=22664

libboost 1.35er Pakete werden in UCS 2.4-3 maintained aufgenommen


#3

Hallo Herr Schulz,
der von Ihnen beschriebene Workaround wird auch von uns so empfohlen,
da die Debian Lenny Pakte für das Paket libboost keine weiteren Abhängigkeiten nach sich ziehen.
Bitte stellen Sie jedoch folgendes sicher: Nach der Installation der Debian Lenny Pakete entfernen Sie wieder das
das Debian Repository, da ansonsten Probleme bei dem nächsten Update entstehen.

Wir werden das fehlende Paket in die Distribution aufnehmen und mit UCS 2.4-3 zur Verfügung stellen:
[bug]22664[/bug]

Ab UCS 3.0 werden wir das gesamte Debian Repository für UCS bauen,
so dass ähnliche Schwierigkeiten nicht wieder entstehen werden.

Viele Grüße
Cord Martens


#4

[quote=“s.schulz”]Die Installation von Zarafa4UCS 6.40.9 ist zurzeit unter UCS2.4 nicht möglich,
weil der Lizenzserver (zarafa-licensed) wegen Abhängigkeiten nicht installiert werden kann.

Folgt man der Dokumentation:
zarafa4ucs.linet-services.de/dokumentation.html
so wird das System zwar ohne Fehler installiert, jedoch fehlt am Ende der Lizenzserver

eine Nachinstallation ist ebenso nicht möglich:

zarafa-licensed: Depends: libboost-filesystem1.35.0 (>= 1.35.0-1) but it is not installable Depends: libboost-system1.35.0 (>= 1.35.0-1) but it is not installable

fügt man der
/etc/apt/sources.list.d/25_zarafa4ucs.list
noch die Debian Lenny Quellen hinzu, kann der zarafa-licensed installiert werden.

deb http://ftp.de.debian.org/debian lenny main

[/quote]

Dieser Workaround ist nicht mehr notwendig.
Die Pakete wurden soeben in das Repository zarafa4ucs aufgenommen
und die Installation kann wie unter zarafa4ucs.linet-services.de/dokumentation.html
dokumentiert, durchgeführt werden.
Viele Grüße
Cord Martens


#5

Funktioniert leider immer noch nicht…

gerade getestet auf UCS 2.4-2-4

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten: zarafa-licensed: Hängt ab: libboost-filesystem1.35.0 (>= 1.35.0-1) ist aber nicht installierbar Hägt ab: libboost-system1.35.0 (>= 1.35.0-1) ist aber nicht installierbar

im Repository liegt:
libboost-system1.35.0_1.35.0-5_amd64.deb
libboost-filesystem1.35.0_1.35.0-5_amd64.deb

Bitte nochmal prüfen lassen.

Danke,
s.schulz


#6

Hallo s.schulz,

die Pakete wurden in das Repository von zarafa4ucs aufgenommen.
Ein Workaround ist am Bug beschrieben.
forge.univention.org/bugzilla/s … i?id=22664

Die Pakete werden mit dem nächsten Patchlevel-Release UCS 2.4-3 in UCS gebaut sein.
Die Veröffentlichung ist für den 15. September geplant, steht also kurz bevor.

Viele Grüße
Cord Martens


#7

Problem ist auch unter Systemstand UCS 2.4-4-6
noch immer vorhanden

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten: zarafa-licensed: Hängt ab: libboost-filesystem1.35.0 (>= 1.35.0-1) ist aber nicht installierbar Hängt ab: libboost-system1.35.0 (>= 1.35.0-1) ist aber nicht installierbar


#8

Hallo Herr Schulz,

bitte lassen Sie die Online Sources Liste über den Befehl ucr commit /etc/apt/sources.list.d/15_ucs-online-version.list neu aufbauen und führen anschließen ein apt-get update aus.

Falls sich das betroffene Paket noch immer nicht installieren ließ, stellen Sie bitte die Dateien unter /etc/apt/sources.list.d/* und die Ausgabe von ucr search ^repository bereit.

Viele Grüße
Stephan Luft


#9

Hallo,

Ich habe heute nochmal einen frischen UCS 2.4-4-7 aufgesetzt und habe Zarafa installiert
und wie beschrieben:
ucr commit /etc/apt/sources.list.d/15_ucs-online-version.list
und
apt-get update
ausgeführt.

leider ist ‘zarafa-licensed’ weiterhin nicht installierbar

hier die angeforderten ausgaben:
in /etc/apt/sources.list.d/*
liegen:

15_ucs-online-version.list

[code]
#Warning: This file is auto-generated and might be overwritten by

univention-config-registry.

Please edit the following file(s) instead:

#Warnung: Diese Datei wurde automatisch generiert und kann durch

univention-config-registry überschrieben werden.

Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):

/etc/univention/templates/files/etc/apt/sources.list.d/15_ucs-online-version.list

deb http://server/univention-repository/2.4/maintained/ 2.4-0/all/
deb http://server/univention-repository/2.4/maintained/ 2.4-0/extern/
deb http://server/univention-repository/2.4/maintained/ 2.4-0/amd64/
deb http://server/univention-repository/2.4/maintained/ 2.4-1/all/
deb http://server/univention-repository/2.4/maintained/ 2.4-1/extern/
deb http://server/univention-repository/2.4/maintained/ 2.4-1/amd64/
deb http://server/univention-repository/2.4/maintained/ 2.4-2/all/
deb http://server/univention-repository/2.4/maintained/ 2.4-2/extern/
deb http://server/univention-repository/2.4/maintained/ 2.4-2/amd64/
deb http://server/univention-repository/2.4/maintained/ 2.4-3/all/
deb http://server/univention-repository/2.4/maintained/ 2.4-3/extern/
deb http://server/univention-repository/2.4/maintained/ 2.4-3/amd64/
deb http://server/univention-repository/2.4/maintained/ 2.4-4/all/
deb http://server/univention-repository/2.4/maintained/ 2.4-4/extern/
deb http://server/univention-repository/2.4/maintained/ 2.4-4/amd64/[/code]

18_ucs-online-security.list

#Warning: This file is auto-generated and might be overwritten by
#         univention-config-registry.
#         Please edit the following file(s) instead:
#Warnung: Diese Datei wurde automatisch generiert und kann durch
#         univention-config-registry überschrieben werden.
#         Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):
#
#       /etc/univention/templates/files/etc/apt/sources.list.d/18_ucs-online-security.list
#

20_ucs-online-component.list

#Warning: This file is auto-generated and might be overwritten by
#         univention-config-registry.
#         Please edit the following file(s) instead:
#Warnung: Diese Datei wurde automatisch generiert und kann durch
#         univention-config-registry überschrieben werden.
#         Bitte bearbeiten Sie an Stelle dessen die folgende(n) Datei(en):
#
#       /etc/univention/templates/files/etc/apt/sources.list.d/20_ucs-online-component.list
#

# Configuration error: non-existing component prefix: http://server/repository/: zarafa4ucs[/code]

25_zarafa4ucs.list
[code]deb http://zarafa4ucs.linet-services.de/repository/2.4/maintained/component zarafa4ucs/all/
deb http://zarafa4ucs.linet-services.de/repository/2.3/maintained/component zarafa4ucs/amd64/[/code]


Ausgabe:
ucr search ^repository:
[code]repository/mirror/architectures: <empty>
 List of architectures copied to the local repository, space separated

repository/mirror/basepath: /var/lib/univention-repository
 Directory prefix of the local repository [/var/lib/univention-repository]

repository/mirror/httpmethod: <empty>
 HTTP methode for testing the availability of updates [HEAD]

repository/mirror/port: <empty>
 TCP port number of the repository servers [80]

repository/mirror/prefix: <empty>
 Update directory on the repository server [univention-repository]

repository/mirror/recreate_packages: yes
 Re-create list of packages in local repository after updates, instead of copying it [yes]

repository/mirror/server: apt.univention.de
 Server, from which packages are copied for the local repository [apt.univention.de]

repository/mirror/sources: <empty>
 Mirror source code files to local repository

repository/mirror/threads: 10
 Maximum number of parallel downloads [10]

repository/mirror/version/end: <empty>
 Highest version in the local repository

repository/mirror/version/start: 2.4-0
 Lowest version for the local repository

repository/mirror: yes
 Enable/Disable mirroring packages into the local repository [yes]

repository/online/architectures: <empty>
 List of architectures to be used on local system, space separated

repository/online/component/zarafa4ucs/prefix: repository

repository/online/component/zarafa4ucs/server: zarafa4ucs.linet-services.de

repository/online/component/zarafa4ucs/version: 2.4

repository/online/component/zarafa4ucs: enabled

repository/online/hotfixes: no
 Use hotfix packages for security updates [no]

repository/online/httpmethod: <empty>
 HTTP methode for testing the availability of updates [HEAD]

repository/online/maintained: yes
 Use packages from the maintained section [yes]

repository/online/port: 80
 TCP port number of the online repository servers [80]

repository/online/prefix: univention-repository
 Update directory on the repository server [univention-repository]

repository/online/server: wlzarafa.winsen
 Server holding the Repository [apt.univention.de]

repository/online/sources: <empty>
 Make source code files available on local host [no]

repository/online/unmaintained: no
 Use packages from the unmaintained section [no]

repository/online: yes
 Enable/Disable the use of the online repository servers [yes]

#10

Hallo,

die Meldung “Configuration error: non-existing component prefix: server/repository/: zarafa4ucs” in der 20_ucs-online-component.list deutet darauf hin, dass die Komponente nicht (korrekt) in Ihr lokales Repository Synchronisiert wurde. Ich vermute um dies zu umgehen haben Sie die Datei 75_zarafa4ucs.list angelegt.
Die Einträge in der 75_zarafa4ucs.list sind allerdings nicht korrekt. Hier wird das “all”-Repository für UCS 2.4, das “amd64”-Repository aber für UCS 2.3 angegeben.

Bitte korrigieren Sie die 75_zarafa4ucs.list oder Synchronisieren Sie die zarafa4ucs Komponente in Ihr lokales Repository (in diesem Fall sollten Sie die 75_zarafa4ucs.list anschließend entfernen). Anschließend führen Sie bitte erneut “apt-get update” aus und versuchen die Installation noch einmal. Bitte geben Sie im Fehlerfall auch die vollständige Ausgabe von “apt-get update” sowie den “apt-get install” Befehlen an.

Mit freundlichen Grüßen
Janis Meybohm


#11

Hallo Herr Meybohm,

die 25_zarafa4ucs.list habe ich nach den Anweisungen von:
zarafa4ucs.linet-services.de/index.php?id=93
direkt kopiert. Hier hat wohl der 2.3/2.4 Tippfehler seinen Ursprung.

Grüße,
s.schulz


#12

Hallo,

in der Dokumentation ist beschrieben dass die zusätzliche Sources.list Datei 25_zarafa4ucs.list nur auf UCS Versionen bis 2.3 mit einem lokalen Repository verwendet werden muss. Ich würde daher vorschlagen dass Sie die Datei entfernen und die Komponente für die Installation in Ihr lokales Repository Synchronisieren.

Mit freundlichen Grüßen
Janis Meybohm


#13

funktioniert bei mir auch nicht, wenn ich die 25_zarafa4ucs.list nicht anlege, findet er die Pakete auch gar nicht

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten: zarafa-licensed: Hängt ab: libboost-filesystem1.35.0 (>= 1.35.0-1) ist aber nicht installierbar Hängt ab: libboost-system1.35.0 (>= 1.35.0-1) ist aber nicht installierbar

mein Systemstand UCS 2.4-4
P.S.: ich möchte noch kein UCS3 mit Zarafa7 einsetzen


#14

Hallo W_Wagner,

der Fehler liegt bei den Angaben für die
etc/apt/sources.list.d/25_zarafa4ucs.list
auf der Linet Seite

für UCS 2.4 muss es überall repository/2.4/ heissen,
hier ist fälschlicherweise 2.3 eingetragen, was noch immer nicht korrigiert wurde.

so muss es richtig aussehen:

UCS 2.4 / i386

deb http://zarafa4ucs.linet-services.de/repository/2.4/maintained/component zarafa4ucs/all/
deb http://zarafa4ucs.linet-services.de/repository/2.4/maintained/component zarafa4ucs/i386/


UCS 2.4 / amd64

deb http://zarafa4ucs.linet-services.de/repository/2.4/maintained/component zarafa4ucs/all/
deb http://zarafa4ucs.linet-services.de/repository/2.4/maintained/component zarafa4ucs/amd64/

Grüße,
s.schulz


#15

Danke,
genau das war’s
hat super funktioniert!