Z-Push installiert aber keine Verbindung möglich

german

#1

Ich habe im aktuellen UCS Zarafa laufen. Von Aussen kann ich sowohl den UCS als auch die WebApp von Zarafa erreichen.

Jetzt habe ich Z-Push über das appcenter installiert.

Dann auf meinem Smartphone (android 5) verrsucht ein neues Konto anzulegen.

-> Konto hinzufügen -> “Corporate Sync” -> E-Mailadresse xyz@xyz.de angegeben (der benutzername in Zarafa enthält bei mir kein @ und ohne das gehts da nicht weiter)
-> manuell einrichten ->Exchange -> Passwort -> das eingegeben mit dem ich mit auch an der WebApp erfolgreich anmelden kann ->
Domain\Nutzername -> geändert auf den namen mit dem ich mich an der Webapp anmelde (auch mal mit Domäne vorweg ausprobiert)
bei Server die dyndns Adresse eingegeben mit der ich auch per Webapp draufkomme (ohne /webapp)

-> Fertigstellen nicht möglich Verbindung zum Server kann nicht geöffnet werden

Das log vom z-push habe ich mir angesehen. da kommt scheinbar gar nicht an.

Was muss ich noch einstellen damit es funktioniert bzw. wie kann ich den Fehler eingrenzen? Muss man doch noch was in UCS/Zarafa konfigurieren? Ich hab nichts gefunden.


#2

Ich habe zwei Zarafa Installationen an unterschiedlichen Standorten am laufen. Das Z-Push geht auch bei der zweiten Installation nicht. Wobei ich bei beiden das selbe Smartphone zum testen genutzt habe mit Android 5. Vielleicht liegt es ja auch daran!?


#3

Grundsätzlich klappt Android 5. Troubleshooting Infos für Z-Push gibt es unter doc.zarafa.com/trunk/Administra … leshooting

Wobei als erstes (z.B. mit einem Browser) überprüft werden sollte, ob das Mobilgerät den Server tatsächlich erreichen kann.


#4

Zugriff auf den Server über die dyndns Adresse vom Server klappt. Ich kann mich sogar über die WebApp erfolgreich anmelden. ist nur etwas klein und unhandlich über Smartphone :slight_smile:

Wenn ich das z-push über einen Webbrowser anspreche: zxydomaene.mooo.com/Microsoft-Server-ActiveSync bekomme ich auch ein Login bei dem ich mit mit den Anmeldedaten von einem Mailkonto anmelden kann. Es kommt dann nur der Hinweis das der Browser wohl nicht das richtige Werkzeug ist…

Z-Push - Open Source ActiveSync
Version 2.2.1.1939
GET not supported
This is the Z-Push location and can only be accessed by Microsoft ActiveSync-capable devices

More information about Z-Push can be found at:
Z-Push homepage
Z-Push download page
Z-Push Bugtracker and Roadmap

All modifications to this sourcecode must be published and returned to the community.
Please see AGPLv3 License for details.


#5

wenn ich sehe . Es gibt den ein oder anderen ActiveSync Client, der per Default nur über SSL (und teilweise auch nur über valide Zertifikate) kommunizieren will. Für die Gmail App auf dem Nexus gibt es hier die Option “SSL (accept all)”.


#6

Ne diese Option habe auch probiert. mal mit mal ohne SSL. Ergebnis immer das gleiche.


#7

Hmm… so direkt kann ich mir nicht mehr vorstellen woran es liegen könnte. Solltest du eine Zarafa Subskription haben würde ich dir empfehlen ein Ticket bei unserem Support aufzumachen, das müsste sich mal jemand ansehen (vielleicht erwischt du ja sogar mich).


#8

Heute nochmal mit einem anderen Android Tablet uund Android 4.4 probiert.

Ergebsnis ist wieder dasselbe: “Verbindung zum Server kann nicht geöffnet werden”

Wenn ich am PC ausprobiere:

zxydomaene.mooo.com:443 -> Ebenfalls keine Verbindung

zxydomaene.mooo.com/Microsoft-Se … veSync:443 -> Ebenfalls keine Verbindung

zxydomaene.mooo.com/Microsoft-Server-ActiveSync -> Anmeldefenster öffnet sich!

Wenn ich das ganze in ANdroid konfiguriere dann wird dort aber doch eindeutig Port 443 !!! eingestellt. Aber da horcht das Z-Push offenbar gar nicht.
Und auch nicht direkt unter der Adresse zxydomaene.mooo.com/Microsoft-Server-ActiveSync

Muss man da also doch unter UCS/Zarafa etwas umstellen?

So jetzt habe ich einfach mal im Android als Serveradresse: zxydomaene.mooo.com/Microsoft-Server-ActiveSync eingegeben und als Port: 80 Verschlüsselung auf KEINE

Und schwupp geht es. Nur wird das in allen Anleitungen nie so erklärt und ist doch wohl auch falsch!? Adresse und Port sind doch nicht korrekt so! Und SSL Verschlüsselung wäre auch fein.


#9

Bei Port 443 muß es vermutlich https://zxydomaene.mooo.com/Microsoft-Server-ActiveSync heißen.


#10

Wie auch schon von SirTux angemerkt, diese beiden Adressen können gar nicht funktionieren.

[quote=“Notnagel”]http://zxydomaene.mooo.com:443 -> Ebenfalls keine Verbindung

zxydomaene.mooo.com/Microsoft-Se … veSync:443 -> Ebenfalls keine Verbindung
[/quote]
Bei ersterem wird ein https Port versucht mit http zu öffnen. Die Fehlermeldung, die der Browser dabei anzeigt sollte eigentlich auch eindeutig sein:

Die zweite Adresse nutzt den falschen Path, da der Port direkt nach der Domain angegeben werden muss (https://zxydomaene.mooo.com**:443**/Microsoft-Server-ActiveSync)

Hast du irgendwas an deiner Apache Konfig verändert? Per Defaul liegt die Z-Push Konfig in /etc/apache2/conf.d/z-push.conf. Z-Push wird dabei als Alias eingerichtet und ist damit frei vom Domainnamen und http/https. Mit anderen Worten, solange du einen Domainnamen auf die IP des Rechners auflösen kannst geht mein-domainname/Microsoft-Server-ActiveSync. Am Mobilgerät musst du den vollen Pfad jedoch nicht angeben, da reicht einfach “mein-domainname”.

PS: zxydomaene.mooo.com/Microsoft-Server-ActiveSync wird auch nicht als Subdomain bezeichnet.


#11

Tja aber auch diese Variante funktioniert nicht. An Port 443 antwortet einfach nichts.

Und die Adresse OHNE /Microsoft-Server-ActiveSync funktioniert eben NICHT! Weder am PC noch am Mobilgerät.

Und ich habe an der Apache Konfiguration nichts manuell geändert. Ich versuche möglichst alle innerhalb der UCS Gui zu machen und begebe mich auf die Ebene von Config dateien etc nur dann wenn es nicht anders geht.

Wie gesagt habe ich das ganze auf zwei unterschiedlichen Systemen ausprobiert und das Verhalten ist 100% identisch. Kann es nicht einfach sein das in den aktuellen UCS / Zarafa Paketen einfach ein Fehler drin ist den ihr nicht habt weil Eure Systeme schon ewig laufen und ihr die bei denen wahrscheinlich eh alles manuell einstellt?


#12

Hier muss man zwei Dinge unterscheiden. Wenn man die Adresse eines Univention Systems ohne einen weitern Pfad in einem Webbrowser aufruft (also in deinem Falle zxydomaene.mooo.com/), dann wird man immer auf /ucs-overview/#service weitergeleitet. Für ActiveSync Clients jedoch ist der Pfad immer identisch, daher reicht es bei der Einrichtung einfach nur den Hostname anzugeben.

Wenn https bei dir gar nicht geht, dann liegt hier der Fehler begraben. Per Default sollte ein jedes Univention System nämlich auch per https erreichbar sein (ein “netstat -tulpen | grep :443” über die Konsole könnte hier Aufschluss geben).


#13

Eine einfache Frage hätte gereicht: “Hast Du denn auch im Router den Port 443 auf den UCS weitergeleitet”?..

Den Port 80 hatte ich natürlich eingestellt. Den 443 nicht. Das sind wieder diese typischen Dinge die so simpel sind das der Anfänger nicht dran denkt und dem Experten das gar nicht bewust ist das man als Anfänger auch so offensichtliche Dinge falsch machen kann.

Nun funktioniert auch Z-Push mit SSL und Adresse OHNE /Windows-Server-ActiveSync

Wieder ein Problem abgehakt. Aber da sind noch ein paar auf meiner Liste :slight_smile:

Zusatzfrage: Diese Warnung die beim Einrichten eines ActiveSync Kontos bei Android (und wahrscheimnlich auch bei IOS und WindowsPhone) auftaucht das man Adminrechte nach aussen gibt, das das Gerät aus der Ferne platt gemacht werden kann usw. Was ist da dran bzw. nutzt Zarafa irgendeines dieser Rechte?

Das die mit einem echten Exchange Server wirklich funktionieren habe ich bei Kollegen die mehrfach ihr PW falsch eingegeben haben und wonach sich das Smartphone dann wirklich zurückgesetzt hat (inkl. alle Daten futsch) schon mitbekommen. Ein Grund warum ich ganz sicher nicht ein ActiveSync Konto meines beruflichen Mailpostfaches auf meinem privaten handy einrichte…


#14

[quote=“Notnagel”]Eine einfache Frage hätte gereicht: “Hast Du denn auch im Router den Port 443 auf den UCS weitergeleitet”?..
[/quote]
Autsch.

[quote=“Notnagel”]
Zusatzfrage: Diese Warnung die beim Einrichten eines ActiveSync Kontos bei Android (und wahrscheimnlich auch bei IOS und WindowsPhone) auftaucht das man Adminrechte nach aussen gibt, das das Gerät aus der Ferne platt gemacht werden kann usw. Was ist da dran bzw. nutzt Zarafa irgendeines dieser Rechte?[/quote]
Ja, damit kann ich vom Büro aus jetzt dein Telefon löschen :wink:

Spaß beiseite. Unter lib/syncobjects/syncprovisioning.php findest du die einzelnen Policies und wie diese von Haus aus definiert sind, das ist aber alles minimalinvasiv. Die einzige Policy welche wirklich hart genutzt ist, ist die fürs Remote Wipe. Dies kannst du bei Bedarf über z-push-admin durchführen.

Für gewöhnlich nutzen Kunden aber zusätzlich zu Zarafa noch eine komplette MDM Lösung, welche dann die Endgeräte auch fester im Griff hat (Remote Ortung, pushen von Settings und Apps, …)


#15

Aber als Standard ist nichts aktiviert? Also keine remote wipe bei 5 mal PIN falsch …?


#16

Siehe die bereits von mir genannte PHP Datei:

$this->maxdevpwfailedattempts = 8;

The MaxDevicePasswordFailedAttempts setting specifies the number of attempts a user can make to enter the correct password for the mobile phone before a device reset to factory settings is initiated. You can specify any number from 4 through 16. The default is 8.


#17

Und wenn ich unter keinen Umständen einen Factory Reset haben möchte?


#18

Z-Push ist nach dem (UCS und Zarafa) Update das ich am 6.10 eingespielt habe ausgefallen. Es kommen auf meine Handy keine Mails mehr an. Ein paar Tage habe ich das ignoriert undgehofft das sich das mit dem nächsten Update wieder einrenkt. Heute dann dann ein neues (UCS) Update eingespielt aber es will immer noch nicht. Es gibt sowohl auf dem Smartphone als auch in UCS keine offensichtlichen Fehlermeldungen.

Leider habe ich so gut wie alles was ich bei der Zarafa / Z-Push einrichtung gelernt habe wieder vergessen :slight_smile: Wo muss ich hingucken damit ich den Fehler finde?


#19

Schau mal hier: Z-Push funktioniert nicht