Z-push for Zarafa V.2.3

german

#1

Hallo,

weiß schon jemand ab wann es z-push fo zarafa in Version 2.3 gibt? Für Kopano scheint es die Version ja schon länger zu geben…


#2

Hallo cdn,

da ich auch an anderer Stelle Anfragen zu Z-Push 2.3 für Zarafa erhalten habe, habe ich gerade einmal das Update hierfür angestoßen. Nach kurzen Integrationstests sollte das Update wohl in der nächsten Woche im produktiven Univention Appcenter angekommen sein.


#3

Ist immer noch nichts verfügbar…


#4

Die neue Version liegt schon in unserem Test AppCenter. Sobald die Tests durch sind wird es veröffentlicht (1-2 Wochen).

Viele Grüße
Felix Botner


#5

Hallo,
ich habe gerade z-push 2.3.2 aus dem Repo installiert, da wir genau einige der behobenen Probleme mit Outlook 2016 über EAS hatten. Zuvor gab es schon ein erfolgreiches Update auf einem (nicht-UCS) Smartermail-System. Deshalb wiegten wir uns in falscher Sicherheit.

Obwohl ich genau nach dieser Anleitung https://wiki.z-hub.io/display/ZP/Upgrade+to+Z-Push+2.3#UpgradetoZ-Push2.3-Re-synchronizingalldevices vorgegangen bin, können sich die Android (Nine)-Geräte nun nicht mehr synchronisieren (Ordner leer), wohingegen die Outlook Clients bei der Passwortabfrage hängen.

“clearloop” und “fixstate” passen, mittels “lastsync” sieht man, dass sich jene Geräte, bei welchen testweise der Resynch angestoßen wurde, nicht mehr anmelden können “Last sync time: never”.

Der /Microsoft-Server-ActiveSync/ Ordner ist erreichbar und erfordert Anmeldung, welche auch möglich ist.

Keine Ahnung, was da passiert ist…?

Jemand eine Idee?


#6

Ich vergaß: der Login in die Zarafa Webapp ist problemlos möglich!


#7

Eine komplette Deinstallation und Reinstallation von z-push scheint das Problem behoben zu haben.
Vorher hatte ich haufenweise Fehler im z-push-error.log:

12/10/2016 14:53:48 [12094] [ERROR] [username] StatusException: ExportChangesICS->Config(): Error, exporter not available - code: 12 - file: /usr/share/z-push/backend/zarafa/exporter.php:131
12/10/2016 14:53:48 [12094] [ERROR] [username] ZarafaBackend->Logon(): login failed with error code: 0xFFFFFFFF80040116
12/10/2016 15:05:30 [15418] [FATAL] [unknown] Fatal error: /usr/share/z-push/backend/kopano/kopano.php:48 - require_once(): Failed opening required 'backend/kopano/config.php' (include_path='.:/usr/share/php:/usr/share/pear:/usr/share/z-push/') (64)
12/10/2016 15:05:53 [15482] [FATAL] [info] Fatal error: Unknown:0 - Module 'mapi' already loaded (32)
12/10/2016 15:09:52 [ 7172] [ERROR] [user@domain.tld] KopanoBackend->Logon(): login failed with error code: 0xFFFFFFFF80040111
12/10/2016 15:09:52 [ 7172] [FATAL] [user@domain.tld] Exception: (AuthenticationRequiredException) - Access denied. Username or password incorrect
12/10/2016 15:10:44 [ 7171] [ERROR] [username] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command 'Sync' at 12/10/2016 15:10:44 with pid '7236' terminated unexpectedly or is still running.

usw.

Ich habe nun komplett alle user gelöscht, richte alle Outlook mit EAS neu ein und schaue mir mal an, was auf den bereits vorhandenen Android-EAS-Geräten passiert.


#8

Smartermail nutzt auch Z-Push? Ist das offiziell oder selbst konfiguriert mittels IMAP/CalDAV/etc?

Die im Wiki erwähnten Schritte sind so nicht notwendig, da während der Installation bereits z-push-admin -a fixstates ausgeführt wird.

12/10/2016 15:05:30 [15418] [FATAL] [unknown] Fatal error: /usr/share/z-push/backend/kopano/kopano.php:48 - require_once(): Failed opening required 'backend/kopano/config.php' (include_path='.:/usr/share/php:/usr/share/pear:/usr/share/z-push/') (64)

klingt ein wenig so, als wenn das z-push-backend-kopano Paket nicht korrekt installiert wurde. Eine nicht vorhandene config.php könnte das Fehlverhalten erklären.


#9

Ich kenne den Unterbau nicht, habe mich vielleicht etwas vom Frontend in die Irre führen lassen. Wir mussten bei den Kunden jedenfalls bei der Umstellung exakt dieselben Schritte wie für z-push durchführen. Da müsste ich effektiv genauer bei den Kollegen aus Bozen nachfragen.

[quote]Die im Wiki erwähnten Schritte sind so nicht notwendig, da während der Installation bereits z-push-admin -a fixstates ausgeführt wird.[/quote] Interessant, da fixstates angeblich noch Einiges zu beheben hatte.

[quote]klingt ein wenig so, als wenn das z-push-backend-kopano Paket nicht korrekt installiert wurde. Eine nicht vorhandene config.php könnte das Fehlverhalten erklären.[/quote] Eine Deinstallation und Reinstallation hat tatsächlich geholfen - meine Theorie ging eher in Richtung Pfade bei Kopano vs. Zarafa. Ich habe die Scripts aber nicht genauer angeschaut.

“Nine” für Android hatte übrigens Probleme: dort reichte auch ein mehrfacher Resync NICHT aus, um die Synchronisation wieder anzustoßen. Eine Neueinrichtung der Konten war nötig. Dafür entschädigt “Nine” ja mit haufenweise Funktionen, die Outlook in der Desktop-Version für EAS nicht anbietet. Die native Implementierung von Google bzw. jene erweiterte von Samsung waren hingegen nicht betroffen; dort ließen sich die bereits eingerichteten Konten einwandfrei weiterverwenden.

Ein Sonderfall waren alle Konten auf einem Remote Desktop Server: dort ging der angezeigte Status von Outlook bei allen Benutzern und z-push Konten nach der erfolgreichen Erstsynchronisation “disconnected” bzw. “getrennt” und ließ sich nicht mehr beheben (auch nicht mittels Reparatur, Neueinrichtung, deaktivieren der COM-Add-Ins, Offline/Online-Modus, Netzwerkverbindung usw.).
Es war ein komplettes Löschen der Konten und Profile sowie eine komplette Neuinstallation von Office 2016/365 nötig, um das Problem zu beheben. Bis auf den bekannten PHP-MAPI-Fehler war im z-push-error Log dabei nicht viel zu sehen. Im z-push Log hingegen fand man noch einzelne Verbindungsversuche ohne Erfolg - jedoch keine Authentifizierungsfehler.

Whatever… Ich hatte jedenfalls gut zu tun - jetzt läuft es wieder!


#10

Hab gerade auch geupdatet.
Bei einigen Androidclients war das ändern des Anmeldenamens von name@domäne auf domäne\name notwendig, damit sie wider synchonisierten.