X Server gdm

german
feedback

#1

Nach dem Update des UCS c’t Server auf V 3.2 startet der gdm nicht mehr messages: Xorg:4383 und 4504 freeing invalid memtype d001300-d07fc000!
Die Installation von der c’t DVD hatte das Problem nicht !
Gibt es eine Lösung ?
LG Uwe Zeysing


#2

Hallo,

dieses Problem ist uns nicht bekannt - wo genau erhalten Sie diese Meldung?
Bitte hängen Sie uns einmal die folgenden Dateien an:

/var/log/dmesg /var/log/syslog /var/log/univention/updater.log
Mit freundlichen Grüßen,
Tim Petersen


#3

Hallo Herr Petersen,
herzlichen Dank für Ihre Mühe!
Auch nachdem ich die c’t Software nocheinmal installiert habe, den Lizenzschlüssel erneut eingelesen habe, habe ich gleiches Verhalten der grafischen Konsole.
In der Anlage die Log-Dateien

PS: Ich habe nach dem heutigen Update auf 3.1 kein Zugriff auf die Lizenz, der Aufruf über die Admin-Konsole endet in einer Endlosschleife…

Der UCS_Server ist eine prima Idee, und ich hoffe, das auch ich ihn zum “laufen kriege” …Der c’t Debian_Server 4.1 war auch schon eine guter Server für XEN, leider wurde er nicht weiter gepflegt…

Mit freundlichen Grüßen aus Hamburg
Uwe Zeysing
updater.log (319 KB)


#4

Hallo Herr Petersen,
herzlichen Dank für Ihre Mühe!
Das hochladen mehrer Dateien hat er nicht gemacht, darum jetzt als *.zip.

Mit freundlichem Gruß
Uwe Zeysing
Entschuldigung, dass das mit mehreren Dateien so nicht funktionierte …
UCS c’t Edition.zip (146 KB)


#5

Hallo Herr Petersen,
in der Anlage Bilder, die ich vom Monitor machen konnte, nach dem das System den Bildschirm freigegeben hatte, also aus der Warteschlnge aufwachte…
Mit freundlichem Gruß
Uwe Zeysing
X_Server UCS Fehler.zip (3.66 MB)


#6

Hallo,

wurde bereits vor dem Update der nouveau Treiber verwendet?
Sie könnten einmal versuchen, den Treiber zu wechseln, beispielsweise auf nv.
Bitte lassen Sie uns einmal die aktuellen Einstellungen zukommen:

ucr search --brief xorg

Mit freundlichen Grüßen,
Tim Petersen


#7

Hallo Herr Petersen,
herzlichen Dank für Ihre Mühe!
In der Anlage die ermittelte Info…

Mit freundlichem Gruß
Uwe Zeysing
xenucssrv_xorg.txt (2.73 KB)


#8

Hallo,

bitte versuchen Sie einmal die Xorg-Autoerkennung zu deaktivieren:

ucr set xorg/autodetect=no

und in der Folge mögliche Treiber zu testen:

ucr set xorg/device/driver=nouveau reboot #Test ucr set xorg/device/driver=nv reboot #Test ucr set xorg/device/driver=vesa reboot #Test

Mit freundlichen Grüßen,
Tim Petersen


#9

Hallo Herr Petersen,
keine Änderung im Verhalten des X-servers, gleiche Fehlermeldung wie vorher…ich habe alle 3 Varianten ausprobiert…
Danke für Ihre Mühe!

Mit freundlichem Gruß
Uwe Zeysing


#10

Hallo,

wie bereits erwähnt ist uns dieses Verhalten leider nicht bekannt und vermutlich auf die verwendete Desktop-Hardware zurückzuführen.
Sie könnten einmal versuchen eine alternative Live-CD mit grafischer Oberfläche (bsw. Ubuntu, o.Ä.) zu booten und herausfinden mit welchem Xorg-Treiber sowie eventuellen Optionen Ihr Xserver gegebenenfalls erfolgreich startet. Dies könnten Sie dann über die xorg/*-UCR-Variablen entsprechend adaptieren.

Mit freundlichen Grüßen,
Tim Petersen


#11

Hallo,
bei einem reboot, springt der UCSServer in den grafischen Modus ! ?
Warum kann er dann die Grafik des UCS-Systems anzeigen ?

Mit freundlichem Gruß
Uwe Zeysing
PS: Die grafische Oberfläche ist z.B. mit Life CD o DVD pmagic_2013_01_29; Knoppix 7.1 etc. kein Problem…


#12

Hallo,

Ich bin mir nicht sicher, ob ich Sie hier korrekt verstehe. Was genau meinen Sie mit grafischen Modus? Wird der X-Server doch gestartet?
Sind Sie bereits dazu gekommen, die relevante Xorg-Konfiguration eines erfolgreich startenden X-Servers einer Live-CD auszulesen und entsprechend per UCR zu adaptieren?

Mit freundlichen Grüßen,
Tim Petersen


#13

Hallo Herr Petersen,
…wenn ich das System “neu starte (reboot)”, dann wird die grafische “grüne” Maske eingeblendet…und somit ja auch der gdm.
Ich habe auf dem M4A89GTD AMD Phenom II 1100T jetzt die interne Grafik genommen und somit ist die interne Radeon HD 4290 aktiv…bisher hatte ich eine nVidia GTX210 im PCIe Slot als aktive Grafikkarte.
Nun funktioniert auch der grafische Desktop auf dem UCS-Server selbst!
Die relevante Xorg-Konfiguration eines erfolgreich startenden X-Servers einer Live-CD habe ich nicht mehr ausprobiert…

Mit freundlichem Gruß
Uwe Zeysing