Windows7 Beitritt klappt nicht

german

#1

Hallo zusammen,

ich habe den aktuelle UCS vor einiger Zeit eingerichtet mit Samba4 ADS. Mit Windows10 konnte ich der Domäne beitreten. Nun will ich Windows7-Clients einbinden und das klappt nicht. Da der Windows10-Beitritt schon ein paar Wochen her ist vorab ein paar Fragen:

  • Lege ist das Rechnerkonto zuerst auf dem UCS an?
    -> Im Handbuch steht dass dies automatisch beim Beitritt passiert. Wenn ich diese jedoch nicht anlege bekommt der Client do gar keine IP. Wie kann dann ein Beitritt funktionieren?

  • Wie ist der korrekte Domäname bzw. wo kann ich diesen prüfen?
    -> Der UCS hat den FQH: tux.kfb.lan. Gebe ich als Domäne nun KFB oder KFB.lan an? (Ich habe den Win10 leider mitlerweile platte gemacht und kann dort nicht schauen)

Ich habe den Beitritt sowohl mit einer Win7-Pro VM (auf dem UCS, neu installiert) als auch mit einem vorhandenen Client versucht. Vorher immer mit dem lokalen User “Administrator” der lokal das gleiche Passwort wie der UCS-Administrator hat angemeldet. Die loakale Firewall auf den Win7-Hosts deaktiviert.

Als Meldung erhalte ich immer: "Es konnte keine Verbindung mit dem Active Directory-Domänencontroller (AD DC) für die Domäne “KFB.LAN” hergestellt werden…

Wo könnte das Problem liegen?

Viele Grüße
pixel24


#2

Hallo,

wichtig ist zunächst natürlich, dass die Maschine eine korrekte IP-Adresse und den UCS als Nameserver bekommt.

Wenn Sie keinen DHCP-Pool definiert haben und die IP-Konfiguration nicht manuell durchführen wollen, können Sie den Rechner schon vorab im UCS anlegen. Für den Join ist das aber nicht relevant.

Soweit mir bekannt, kann man sowohl die NetBIOS-Domäne (KFB) als auch den kompletten Domainnamen angeben. “samba-tool domain info tux.kfb.lan” zeigt Ihnen die konfigurierten Namen.

Viele Grüße,
Dirk Ahrnke

EDIT meint, ich möge noch auf Domain join of a Microsoft Windows 7 client und dort insbesondere auf das Thema Uhrzeit hinweisen.


#3

Beim Joinen zur Domain am Rechner aufpassen. NETBIOS Namen müssen groß geschrieben werden, komplette Domainnamen ausschließlich in Kleinbuchstaben. Das Problem gibt es auch in reinen Microsoftumgebungen :wink: