Windows 7 Anmeldung verzögert

german

#1

Hallo liebe Forengemeinde,

ich habe folgendes Problem und zwar habe ich hier einen Windows 7 Client vor mir der sich an ner USC Domäne anmelden soll. Die reg. Werte habe ich auch schon geändert damit die Anmeldung überhaupt funktioniert^^ mein Problem ist jetzt nur dass das Anmelden einfach für meinen Geschmack (2-3min) zu lange dauert.

Ich weiß einfach nich wodran das liegen könnte zumal andere Clients in dem Netzwerk (XP-Rechner) arbeiten einwandfrei…

Hat das vielleicht etwas mit der neuen Richtlinien Steuerung von Windows 7 zu tun? Ich bin echt ratlos also bitte erleuchtet mich^^

Lg Sharky


#2

Hallo,

wie genau sieht so eine langsame Anmeldung aus? Dauert es lange bis die Arbeitsfläche erscheint oder ist diese zügig verfügbar, nur das Einbinden von Shares dauert dann noch einige Zeit?
Ist das Arbeiten flüssig nachdem die Anmeldung erfolgt ist oder bestehen auch dann noch Zeitverzögerungen?

Gibt es Hinweise in den SAMBA Logdateien zu diesem Anmeldevorgang?

Mit freundlichen Grüssen
Tobias Scherer


#3

Es dauert lange bis die Arbeitsfläche erscheint (5-10min) und wenn man der Arbeitsplatz öffnet dauert es etwas länger bis er die Netzlaufwerke gemounted hat danach geht alles im normalen Tempo. Die Samba Logs geben einzelne Fehlermeldungen auf hier mal einige als Beispiel:

"log.winbindd:

[2010/07/21 19:09:52, 0] libsmb/namequery.c:saf_store(75)
saf_store: refusing to store 0 length domain or servername!
[2010/07/21 19:10:02, 0] libsmb/clientgen.c:cli_receive_smb(165)
Receiving SMB: Server stopped responding
[2010/07/21 19:10:12, 0] libsmb/namequery.c:saf_store(75)
saf_store: refusing to store 0 length domain or servername!
[2010/07/21 19:10:22, 0] libsmb/clientgen.c:cli_receive_smb(165)
Receiving SMB: Server stopped responding
[2010/07/21 19:10:55, 0] libsmb/namequery.c:saf_store(75)
saf_store: refusing to store 0 length domain or servername!
[2010/07/21 19:11:05, 0] libsmb/clientgen.c:cli_receive_smb(165)
Receiving SMB: Server stopped responding
[2010/07/21 19:11:15, 0] libsmb/namequery.c:saf_store(75)
saf_store: refusing to store 0 length domain or servername!
[2010/07/21 19:11:25, 0] libsmb/clientgen.c:cli_receive_smb(165)
Receiving SMB: Server stopped responding
[2010/07/21 19:11:35, 0] libsmb/namequery.c:saf_store(75)

log.smb:

[2010/07/18 07:23:33, 0] lib/smbldap.c:smbldap_connect_system(1052)
failed to bind to server ldap://tbehost.tbenet.local with dn="cn=admin,dc=tbe$
(unknown)
[2010/07/18 07:42:51, 0] lib/smbldap.c:smbldap_connect_system(1052)
failed to bind to server ldap://tbehost.tbenet.local with dn="cn=admin,dc=tbe$
(unknown)
[2010/07/18 08:00:46, 0] lib/smbldap.c:smbldap_connect_system(1052)
failed to bind to server ldap://tbehost.tbenet.local with dn="cn=admin,dc=tbe$ (unknown)
[2010/07/18 08:07:39, 0] lib/smbldap.c:smbldap_connect_system(1052)
failed to bind to server ldap://tbehost.tbenet.local with dn="cn=admin,dc=tbe$
(unknown)
[2010/07/18 09:56:31, 0] lib/smbldap.c:smbldap_connect_system(1052)
failed to bind to server ldap://tbehost.tbenet.local with dn="cn=admin,dc=tbe$
(unknown)
[2010/07/18 10:06:59, 0] smbd/server.c:main(1278)sing to store 0 length domain or servername!

log.winbindd-idmap:

[2010/06/18 00:03:02, 0] winbindd/idmap.c:smb_register_idmap(149)
Idmap module passdb already registered!
[2010/06/18 00:03:02, 0] winbindd/idmap.c:smb_register_idmap(149)
Idmap module nss already registered!
[2010/06/18 00:03:02, 1] winbindd/idmap_tdb.c:idmap_tdb_alloc_init(341)
idmap uid or idmap gid missing
[2010/06/18 00:03:02, 0] winbindd/idmap.c:idmap_alloc_init(589)
ERROR: Initialization failed for alloc backend, deferred!
[2010/06/18 00:03:02, 0] winbindd/idmap.c:smb_register_idmap_alloc(201)
idmap_alloc module ldap already registered!
[2010/06/18 00:03:02, 0] winbindd/idmap.c:smb_register_idmap_alloc(201)
idmap_alloc module tdb already registered!
[2010/06/18 00:03:02, 0] winbindd/idmap.c:smb_register_idmap(149)"

Lg Sharky


#4

Hallo,

ist auf dem Windows7 Client der korrekte WINS Server eingetragen?
Wurde auf dem Sambaserver Winbind und/oder Wins konfiguriert, läuft dort der NSCD? Welche Systemrolle hat der Sambaserver?

ucr search winbind
ucr search wins
ps waux | grep nscd
ucr search role

Es könnte sich um das in diesem Eintrag in unserem Bug Tracking System beschriebene Verhalten handeln:
https://forge.univention.org/bugzilla/show_bug.cgi?id=17821

In diesem Fall kann auf Memberservern dieser Befehl ausgeführt werden:

net rpc join member

oder auf bspw. einem DC Master oder DC Backup:

net rpc join 

Mit freundlichen Grüssen
Tobias Scherer