Windows 10 build 1607 incorrect username/paswword


#1

Does anyone know if Microsoft have changed something in windows 10 build 1607 that would prevent login to a UCS based domain?

Added a new laptop from the domain that was freshly installed from freshly created windows 10 install media, machine installed as windows 10 home then was upgraded to pro by imputing a valid pro key.
Laptop joined the domain after the upgrade to pro fine but whenever I try to login with a domain user I just get username/password is invalid.

Laptop does connect to the wireless network and it appears to be connecting to the domain controller ok (As If I disconnect from wireless the error message changes to no login servers available)


#2

This turned out to be my Firewall was providing itself as an IPv6 dns server

So whilst the laptop had picked up the IPv4 DNS addresses of the domain controllers it was also getting the Firewall as a DNS server on IPv6 and the firewall as configured to forward to google DNS & the ISP’s server

I changed the DNS forwarder to point at the UCS DNS servers and it’s working now.


#3

Sorry to hijack the thread, but I got the same Error with Windows 10, upgraded to Pro and joined the Domain, now it says Wrong User/password too.
Firewall is configged fine, I dont know what to look for anymore :frowning:
Please help :slight_smile:


#4

After fixing the DNS mine will login fine locally, but this machine will not login over RDP with the format username or domain\username

however if I do DC-IP\username or DC-Hostname\username I can login via RDP fine, it also doesn’t seem to matter which DC IP/Hostname I put before the username as long as it’s one of them.


#5

Is there a valid fix so you dont need to use the DC-IP anymore? Since we have the same problem over here :slight_smile:


#6

I solved it, the problem was only occuring on laptops with hardcoded Product Keys in the Bios. You need to install Windows 10 with an exisiting ei.cfg and a pid.txt with the generic windows 10 pro key, then everything works out fine.


#7

It does appear to be a problem if you upgrade from Home > Pro, and it’s not limited to samba4 based domains as it looks like people with a proper windows based domain are also running into it.

If you don’t want to nuke the system and start again the advice I found elsewhere to download the media creation tool and then do an “upgrade” seems to work as I’ve just done it on the laptop that was originally having this issue and I can finally login to it properly.

Takes a while esp on a slower machine but much easier than having to reinstall everything.