Which server role needed for app (Asterisk4UCS)?

asterisk4ucs

#1

Hello,

I set up a UCS in a VM in the last few days. After some hassle it works now. But I first set up a member server to use it as a dedicated Asterisk4UCS host but which isn’t offered as an installation target in the App Center. Then, I repeated the installation, this time as a DC slave but with no luck; still not offered as installation target.

So, these are my questions:

  • Which server role is required for Asterisk4UCS?
  • How can I find out which server role any given app in the App Center requires?
  • Is there any way to show which role a server fulfills? As I made the installation on friday, I’m not sure anymore if this really is a DC slave :slight_smile:

Best regards,
Masin Al-Dujaili


#2

Hey,

my guess is that you’re not seeing the App not so much due to the wrong server role, but rather because it’s only available for 4.2 according to the App Catalog. The App Catalog does state for which UCS release an App is available, but not which server role it requires.

However, you can obtain said information if you know how the App Center stores it. First you have to download the current App meta index. Here’s the URL: https://appcenter.software-univention.de/meta-inf/4.2/index.json.gz

Yes, that’s the URL for UCS 4.2, not for 4.3; as I said before Asterisk is only available for 4.2, and the index for 4.3 doesn’t contain Asterisk. So for demonstration purposes let’s continue with the index for 4.2.

After downloading and uncompressing it, search in index.json for Asterisk which you’ll find as "asterisk4ucs_20170124094112". You’ll end up with a hash containing multiple sub-entries. The important one is for the "ini" file. The corresponding URL is this one: https://appcenter.software-univention.de/meta-inf/4.2//asterisk4ucs/asterisk4ucs_20170124094112.ini

When you open it, you’ll find the following:

ServerRole = domaincontroller_master,domaincontroller_backup

And that’s your answer. Even if the App were available for 4.3, it would still need either a DC Master or a DC Backup; neither a memberserver nor a DC Slave would do.

The role is stored in the UCR variable server/role.

Kind regards
mosu


#3

Hi @Moritz_Bunkus,

thanks for your really helpful (and exhaustive :wink: ) answer.

What a lucky coincidence I didn’t update yet to 4.3. But of course, we plan to update. Soon … honestly.

As I remember having read somewhere I can’t change server roles of a running instance, it seems I have to reinstall my server. Again. *sigh*

Bests,
Masin AD


#4

Hello @MasinAD,

the app Asterisk4UCS has been discontinued in September. It is superseded by Kitoma.

Best regards,
Nico