WeKan API Connection Error


I am trying to talk to the UCS WeKan API with Standard HTTP Requests (e.g. Wekan REST API) to automate some of our internal tasks (listing, creating, moving cards etc).
UCS WeKan is responding with “error unauthorized” or “internal server error” when I try to send “POST /users/login” or something like that. I tried content-type json and x-www-form-urlencoded as application header, same errors.
I tried another aproach with n8n (https://n8n.io/) with the internal WeKan Node provided there. But this tools hassles with self signed certifcates and a pre-reverse proxy in front of the UCS does not work probably.

Does anyone know how to fix this or where I can explore an extended errorlog?

If i log in to WeKan via Browser, everythings works like a charm.

Thanks a lot!

Hey Tezzla,

I have not checked this but my guess would be that the API can only be used by “normal” Wekan users not stemming from the LDAP.


You are the man.
Local User works.

Thanks so much… :slight_smile:

1 Like