VlAN DHCP DNS

german

#1

Hallo,
ich habe den UCS im eigenen VLAN stehen, die Clients laufen über ein weiteres. Nun habe ich über Navigation/DHCP ein subnetz dafür extra angelegt. Die Clients bekommen auch ein Lease und den richtigen Gateway(L3 Switch), der DNS Server zeigt auf den UCS. Soweit klappt alles nur das Internet geht nicht, weil der DNS nicht weitergeleitet wird. Hatte das mit ping über externe IP getestet, nur ebend die Namesauflösung geht nicht. Der UCS selber bekommt die Namen problemlos aufgelöst, als DNS Forwarder steht dort auch die Firewall drin und der gateway ist der Switch.

Was mache ich verkehrt oder was fehlt noch?

Danke


#2

Hallo,

verteilen Sie einen Router über DHCP so das auf den Clients die Route nach “Draussen” korrekt gesetzt wird? Sie sollten mit folgendem Aufruf:

ldapsearch -x -b cn=routing,cn=dhcp,cn=policies,dc=firma,dc=com

Ein Objekt mit diesem Attribut erhalten:

univentionDhcpRouters: IP Adr. des Routers

Mit freundlichen Grüssen
Tobias Scherer


#3

Hallo danke,
aber es war wie ich geschrieben habe kein Router Problem sondern ein Dns Problem. Der Server hat die DNS Anfragen nicht weitergeleitet die von den Subnetz kommen.

Mittlerweile habe ich es gelöst bekommen, aber eigentlich dachte ich das wenn ich im Setup den DNS Forwarder eintrage das dann automatisch alle DNS Anfragen die der Server nicht beantworten kann an die Adresse weiterleitet. jetzt mußte ich den DNS Forwarder zuzüglich mit angeben und dann geht es auch.

beste Grüße


#4

Hallo,

Ich habe das Problem gefunden dank eines Hinweises. Standardmäßig werden die Dns Anfragen nur auf den eigenen Netz weitergeleitet.
Mit den setzen folgender Registryvariablen ging es dann. Leider steht das nirgendwo in der Doku.

 ucr set dns/allow/query/cache='any'
 ucr set dns/allow/query='any'

damit kann der Thread geschlossen werden und Herr Scherer sein Wochenende geniesen…:slight_smile: