Usermanagement owncloud: Internal Servererror

owncloud
ucs-4-3

#1

Today I want to change the permission of a user that are defined in the local usermanagement database of ownlcoud. If i click on “Administrator - Users” then came up a error:

`
Interner Serverfehler

Der Server hat einen internen Fehler und konnte Ihre Anfrage nicht vervollständigen.

Bitte wende dich an den Serveradministrator, sollte dieser Fehler mehrfach auftreten und füge deiner Anfrage die unten stehenden technischen Details bei.

More details can be found in the server log.

Technische Details

Entfernte Adresse: 172.17.42.1
Anforderungskennung: MAD8c6C7NNXg9VErhSQx

`

And where can I configure to use the internal database for user authentication? In the Option “Userauthentication” i only found a entry for LDAP - i user owncloud 10.0.9


#2

Hi!
is your UCS joined to a windows AD?
Has it worked before and then stopped working?

I am trying to setup a new nextcloud and got a quiet similar error message and LDAP errors in the log file
(Nextcloud internal server error first login)

regards
Michael


#3

UCS is not joined to a windows AD.

I know that I configure the users for some month ago. Meanwhile i upgrade to the actual version of owncloud-app.


#4

Hm, maybe you could upload the logfile. I’d like to see if it’s the same as on my server
The Nextcloud log is located here:

/var/lib/univention-appcenter/apps/nextcloud/data/nextcloud-data/nextcloud.log

I guess the OwnCloud App would have a similar log file. nextcloud is a fork from owncloud…

If any owncloud-ucs expert is willing to help you, he would probably ask for the logfile anyways…


#5

I think here is the solution:

But in my case no solution :frowning:


#6

Hm, unfortunately I cannot even login to my Nextcloud to change any LDAP config, because my system is domain joined and the administrator is also a windows AD user.

In the logfile of nextcloud I found this:
“Lost connection to LDAP server.”

As I can list all the users in my AD inside UCS user config, I was already guessing that nextcloud is not able to reach the LDAP Server (not the DomainController but the LDAP server on the UCS system itself)

As this should be “localhost” I am not sure why it wouldn’t be able to reach it :neutral_face:
But maybe it is using DNS… I will check that later!

Anyway: Thanks for sharing the Link! :smiley:


#7

Well, good news! (at least for me)

I found out that the dns record for my UCS system didn’t update when I changed from DHCP to a (different) static IP address.
After I changed that manually in my DNS server I was able to log in!

Unfortunatelay only as a user not with my admin accound (wrong password)

This was solved after adding a first and last name to my administrator accound in my Windows AD.
I saw this issue some years ago with a crappy citrix product that did an LDAP request and failed when accounts didn’t have First, Last and Display names. The built in admin accound in windows AD does not have those by default…


#8

OK - I find out, that my DNS can be the problem.

Here the image from the LDAP Entry:
Screenshot_8

And here of my LDAP
Screenshot_7

I think one memberserver-entry is missing. Can some give me a hint, which settings of the entry must be set to use the docker-container of ownlcoud?


#9

I create a new entry and set only following settings:

  • Name
  • Description
  • Password

This entry are the same like then in owncloud-ldap

Now it is working again