User not granted admin privileges in SuiteCRM

suitecrm

#1

Just installed SuiteCRM from Univention App catalog (ESX OVA Image)
UCS version is 4.3-2 errata234
SuiteCRM Version 7.10.7
Sugar Version 6.5.25 (Build 344)

Enabled checkbox for UCS Administrator user for SuiteCRM (checked Administrator checkbox also), but when I logon to SuiteCRM - reviewing user Administrator profile the user type is regular user, hence no access to admin portal. Attached details.SuiteCRM%20Administrator%20User

Tried creating a new UCS user with same results.

Any ideas what to do?


#2

Hi mchavezs,
Have you installed SugarCRM and SuiteCRM on the same machine?
How did you install SugarCRM 6.5.25 ?

Please enter the following commands on a linux command line as root

univention-app shell digitec-suitecrm
tail -f /var/log/univention/listener.log

Uncheck the Admin checkbox in Univention management, wait 30 seconds and check it again
Please send us the console output.
You can quit the tail command with Ctrl-C and then enter

exit

to exit the univention-app command

Workaround

Please enter the following commands on a linux command line as root

univention-app shell digitec-suitecrm
cat /etc/suitecrm/suitecrm/ucsadmin.secret

You will then see a long password. Use this password to login in in SuiteCRM as user ucsadmin. Use this user to give user users the admin role.


#3

Thank you Sven!
I’ll follow your instructions.

The ShugarCRM info is just what is displayed on the “about” link from SuiteCRM:

image

I’ll post results here.

Regards!


#4

Hi Sven

just to report, work around worked OK. User with Admin role now. Bellow info from listener log
Although I did not see anything get logged while making changes on users
Do I need to enable some kind of debug option??

root@crm2018:~# univention-app shell digitec-suitecrm
root@digit-53905963:/# tail -f /var/log/univention/listener.log
11.09.18 18:32:41.105  LISTENER    ( PROCESS ) : updating 'cn=Is_Active_SuiteCRM,cn=DIGITEC SuiteCRM Attributes,cn=custom attributes,cn=univention,dc=aysco,dc=ms' command a
11.09.18 18:32:41.108  LISTENER    ( PROCESS ) : updating 'cn=Is_Admin_SuiteCRM,cn=DIGITEC SuiteCRM Attributes,cn=custom attributes,cn=univention,dc=aysco,dc=ms' command a
11.09.18 18:32:41.120  LISTENER    ( PROCESS ) : updating 'cn=EmployeeStatus_SuiteCRM,cn=DIGITEC SuiteCRM Attributes,cn=custom attributes,cn=univention,dc=aysco,dc=ms' command a
11.09.18 18:32:41.126  LISTENER    ( PROCESS ) : updating 'cn=Roles_SuiteCRM,cn=DIGITEC SuiteCRM Attributes,cn=custom attributes,cn=univention,dc=aysco,dc=ms' command a
11.09.18 18:33:05.940  LISTENER    ( PROCESS ) : updating 'cn=crm2018,cn=dc,cn=computers,dc=aysco,dc=ms' command m
11.09.18 18:34:23.555  LISTENER    ( WARN    ) : received signal 15
11.09.18 18:34:29.587  DEBUG_INIT
11.09.18 18:34:31.332  MODULE      ( WARN    ) : Ignoring import error: No module named dns.resolver
11.09.18 18:34:31.724  LISTENER    ( WARN    ) : initializing module suitecrm-suitecrm
11.09.18 18:34:32.740  LISTENER    ( WARN    ) : finished initializing module suitecrm-suitecrm with rv=0
^C
root@digit-53905963:/#

#5

Hi mchavezs,
sorry, for the delay.

We would expect a line like:

14.09.18 12:42:42.442 LISTENER  ( PROCESS ) ;  updating `uid=testuser,cn=users,dc=asyco,dc=ms` command m

Can you please check:

https://help.univention.com/t/troubleshooting-listener-notifier/6430


#6

Hello - we are experiencing the same issue, and we installed from the OVA as well, same version and build. we ran the commands but no change. The admin option is not shown.

Any help is appreciated