Use full email address instead of user name as user login

Hello everyone!

The actual question itself: how can I use full address, i.e. jdoe@example.com instead of just jdoe while login to Kopano WebApp from UCS Univention App Center?
Full email is more logical and convinience as for my user experience.

Hi @Twissell,

this can be influenced through ldap_loginname_attribute in ldap.cfg. You can set it on ucs via

ucr set kopano/cfg/ldap/ldap_loginname_attribute=mail (from memory, untested)

1 Like

Hello!

Just tested on VM, nope that setting doesn’t work at all :face_with_raised_eyebrow:

Did you restart kopano-server afterwards?

Yes, I did. Login procedure gets broken if I execute

ucr set kopano/cfg/ldap/ldap_loginname_attribute=mail

It works with “short” username only after defaults settings has been setup.

ucr set kopano/cfg/ldap/ldap_loginname_attribute=uid

The right command is

ucr set kopano/cfg/ldap/ldap_loginname_attribute=mailPrimaryAddress
as far as I can test :slight_smile:

1 Like

login now with emai-address, but many ldap errors in mail.log

Oct 20 16:31:53 ucs-app kopano-server[13287]: Authentication by plugin failed for user “cz@xx.xx”: Trying to authenticate failed: cz@sw-fb.de not found in LDAP; username = cz

old device still using the old username format?

i dont get z-push-autodiscover to use login name, even i configure it
so i tried

ucr set kopano/cfg/ldap/ldap_loginname_attribute=mailPrimaryAddress

but then mail log bringing those errors

so i login with email and uid errors in mail log

define('USE_FULLEMAIL_FOR_LOGIN', false);
define('AUTODISCOVER_LOGIN_TYPE', AUTODISCOVER_LOGIN_EMAIL);

does not report username to mailclient

so if i login with primary address i use

define('USE_FULLEMAIL_FOR_LOGIN', true);
define('AUTODISCOVER_LOGIN_TYPE', AUTODISCOVER_LOGIN_EMAIL);

but then postfix causes the complains about login in with username only

so i have to get z-push running or login with email for kopano and ucs postfix

Postfix? How is that relevant for z-push?

I need autodiscover, but it ignores the uid only
So I try this solution above
But then postfix is failing
Can’t send any Mail

I don’t see how changing a z-push setting will generally make sending mail failing for the whole server.

I would recommend to book a remote session with the Kopano support so someone can have a direct look at your system.

i moved the discussion here

define(‘USE_FULLEMAIL_FOR_LOGIN’, false);

does not work in z-push as expected, so this was my workaround

please help