USB Zugriff

german

#1

Hallo,

ich verwende RDP & Windows 7 64bit.

Stecke ich einen USB Stick an, öffne diesen über den Systemordner am ThinClient, so sehe ich auch die Dateien am Stick. Will ich nun einen Ordner / Datei erstellen, so erhalte ich die Fehlermeldung:

[quote]Auf \thinclient\USB kann nicht zugegriffen werden… Sie haben eventuell keine Berechtigung, diese Netzwerkressource zu verwenden. Wenden Sie sich an den Administrator des Servers, um herauszufinden, ob Sie über Berechtigungen verfügen.

Es wurde versucht, auf einen unzuverlässige Adresse zuzugreifen.[/quote]

Und absofort kann ich auch nicht mehr auf die Freigabe \tsclient\USB zugreifen, muss mich via RDP ab & anmelden, danach funktionierts wieder, bis ich wieder eine Datei erstelle…

lG


#2

Ist dieses Thema hier eh nicht untergegangen??


#3

Hallo,

können Sie sicherstellen, dass die folgenden Punkte durchgeführt bzw. konfiguriert wurden?

• In der Rechnerverwaltung des Univention Directory Manager muss für den Thin Client im Reiter/Richtlinie Client-Peripherie der Haken Aktiviere den Zugriff auf Client-Peripheriegeräte aktiviert werden.

• Über eine Univention Configuration Registry-Richtlinie muss die Univention Configuration Registry-Variable thinclient/usbdevice/local auf yes gesetzt werden. (Das Setzen von Univention Configuration Registry-Variablen ist im Handbuch für UCS Thin Client Services in Kapitel 3.2 dokumentiert).

• Für den zugreifenden Benutzer muss in der DVS-Richtlinie (siehe Kapitel 5.2 UCS DVS Handbuch) die Option Zugriff auf USB-Massenspeicher aktiviert werden.

UCS Handbuch
UCS DVS Handbuch

Außerdem könnten Sie noch die Berechtigungen der Ordner und Verzeichnisse auf dem Stick sowie des Freigabeverzeichnisses auf dem Server prüfen, wenn die oben genannten Schritte durchgeführt wurden. Auf dem Stick sollte lediglich eine Partition bestehen, welche mit dem FAT Dateisystem formatiert ist.

Mit freundlichen Grüßen
Tobias Scherer


#4

Option ist am Client aktiviert.

Ist gesetzt.

root@sbsrv:~# univention-thin-client-ucr dump thinclient/usbdevice/local: yes

Ist in der Richtlinie “default-dvs-settings” aktiviert, welche auf “dc=tom,dc=local” verweist.

Habe den Thin- Client nun hochgefahren, nach der Benutzeranmeldung habe ich den USB- Stick angesteckt.

Start -> Computer -> USB auf “Thinclient” wurde nun ein Ordner “usbsisk-sdb” angelegt. soweit auch gut und schön…

Öffne ich diesen, wird mir auch der Inhalt angezeigt. Dateien öffnen auch möglich.

Will ich nun eine neue Datei erstellen, erhalte ich den Fehler:

[quote]Aufgrund eines unerwarteten Fehlers, können Sie die Datei nicht erstellen. Wenn der Fehler weiterhin ausgegeben wird, können Sie mithilfe des Fehlercodes in der Hilfe nach diesem Problem suchen.

Fehler 0x8007048F: Das Gerät ist nicht angeschlossen.[/quote]

Konsole des Thin- Clients:

root@thinthomas:~# mount | grep -e "^/dev/sdb" /dev/sdb on /ramdisk/var/run/drives/usbdisk-sdb type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=utf8,shortname=mixed,errors=remount-ro)

Erstellen einer Datei funktioniert auch über die Konsole:

root@thinthomas:/ramdisk/var/run/drives/usbdisk-sdb# echo "das ist ein test" > test123 root@thinthomas:/ramdisk/var/run/drives/usbdisk-sdb# cat test123 das ist ein test

lG


#5

Zu Testzwecken hab ich mir nun einen neuen USB- Stick geschnappt, dort vfat formatiert, gleiches Problem…


#6

Hallo,

evtl. verbessert der Einsatz von FreeRDP dieses Verhalten. Die Einrichtung ist in diesem Wiki Artikel beschrieben:
FreeRDP as a replacement for rdesktop in UCS TCS

Dieses Vorgehen sollte zunächst in einem Testsystem überprüft werden.

Mit freundlichen Grüßen
Tobias Scherer