Upgrade to UCS 4.1-2 Failed


#1

I have tried to upgrade to UCS 4.1-2 on two of three servers I have and the upgrade fails on both. Here is the error listed in the upgrade.log:

Reading package lists... Building dependency tree... Reading state information... The following packages have unmet dependencies: udev : Breaks: plymouth (< 0.9.0-7) but 0.8.5.1-5.17.201512031309 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. Error: Failed to execute "apt-get -o DPkg::Options::=--force-confold -o DPkg::Options::=--force-overwrite -o DPkg::Options::=--force-overwrite-dir --trivial-only=no --assume-yes --quiet=1 -u dist-upgrade

Anyone have any ideas?


#2

Here is some additional information on where the upgrade from 4.1-1 to 4.1-2 breaks:

Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (4) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Investigating (4) univention-pam [ amd64 ] < 9.0.0-5.267.201601111715 -> 9.0.0-6.268.201604140831 > ( univention ) Broken univention-pam:amd64 Depends on wngerman [ amd64 ] < 20120607-1.21.201511241411 -> 20131206-5 > ( text ) Considering wngerman:amd64 5421 as a solution to univention-pam:amd64 8 Removing univention-pam:amd64 rather than change wngerman:amd64 Investigating (5) udev [ amd64 ] < 175-7.2.46.201403112156 -> 215-17+deb8u4 > ( admin ) Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (5) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Investigating (5) univention-quota [ amd64 ] < 10.0.1-2.158.201601141304 > ( univention ) Broken univention-quota:amd64 Depends on univention-pam [ amd64 ] < 9.0.0-5.267.201601111715 -> 9.0.0-6.268.201604140831 > ( univention ) (> 0.8) Considering univention-pam:amd64 5421 as a solution to univention-quota:amd64 8 Removing univention-quota:amd64 rather than change univention-pam:amd64 Investigating (5) univention-role-server-common [ amd64 ] < 11.0.1-8.230.201510141128 > ( univention ) Broken univention-role-server-common:amd64 Depends on univention-quota [ amd64 ] < 10.0.1-2.158.201601141304 > ( univention ) Considering univention-quota:amd64 5421 as a solution to univention-role-server-common:amd64 5 Removing univention-role-server-common:amd64 rather than change univention-quota:amd64 Investigating (5) univention-management-console-module-quota [ amd64 ] < 10.0.1-2.158.201601141304 > ( univention ) Broken univention-management-console-module-quota:amd64 Depends on univention-quota [ amd64 ] < 10.0.1-2.158.201601141304 > ( univention ) Considering univention-quota:amd64 5421 as a solution to univention-management-console-module-quota:amd64 3 Removing univention-management-console-module-quota:amd64 rather than change univention-quota:amd64 Investigating (6) udev [ amd64 ] < 175-7.2.46.201403112156 -> 215-17+deb8u4 > ( admin ) Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (6) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Investigating (7) udev [ amd64 ] < 175-7.2.46.201403112156 -> 215-17+deb8u4 > ( admin ) Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (7) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Investigating (8) udev [ amd64 ] < 175-7.2.46.201403112156 -> 215-17+deb8u4 > ( admin ) Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (8) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Investigating (9) udev [ amd64 ] < 175-7.2.46.201403112156 -> 215-17+deb8u4 > ( admin ) Broken udev:amd64 Breaks on plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) (< 0.9.0-7) Conflicts//Breaks against version 0.8.5.1-5.18.201602181308 for plymouth but that is not InstVer, ignoring Considering plymouth:amd64 12 as a solution to udev:amd64 23 Upgrading plymouth:amd64 due to Breaks field in udev:amd64 Conflicts//Breaks against version 0.8.5.1-5.15.201410201741 for plymouth but that is not InstVer, ignoring Investigating (9) plymouth [ amd64 ] < 0.8.5.1-5.17.201512031309 -> 0.9.0-9 > ( misc ) Broken plymouth:amd64 Conflicts on console-common [ amd64 ] < 0.7.87.17.201409242245 -> 0.7.88 > ( utils ) Considering console-common:amd64 31 as a solution to plymouth:amd64 12 Holding Back plymouth:amd64 rather than change console-common:amd64 Done The following packages have unmet dependencies: udev : Breaks: plymouth (< 0.9.0-7) but 0.8.5.1-5.17.201512031309 is to be installed E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.


#3

Hi,

beside some obvious things to prove (package status with “dpkg -C”) and checking that the quoted error is the first I would check that the sources.list.d files are up-to-date at the time of the error.

# apt-cache policy plymouth plymouth: Installiert: 0.8.5.1-5.18.201602181308 Installationskandidat: 0.8.5.1-5.18.201602181308 Versionstabelle: *** 0.8.5.1-5.18.201602181308 0 500 https://updates.software-univention.de/4.1/maintained/ 4.1-2/amd64/ Packages 100 /var/lib/dpkg/status 0.8.5.1-5.17.201512031309 0 500 https://updates.software-univention.de/4.1/maintained/ 4.1-1/amd64/ Packages 0.8.5.1-5.15.201410201741 0 500 https://updates.software-univention.de/4.0/maintained/ 4.0-0/amd64/ Packages

Best Regards,
Dirk Ahrnke


#4

Ahrnke - Thank you for the reply.

dpkg -C - did not report any broken packages.

# apt-cache policy plymouth plymouth: Installed: 0.8.5.1-5.17.201512031309 Candidate: 0.9.0-9 Version table: 0.9.0-9 0 500 http://ftp.debian.org/debian/ jessie/main amd64 Packages 0.8.5.1-5.18.201602181308 0 500 https://updates.software-univention.de/4.1/maintained/component/ 4.1-1-errata/amd64/ Packages *** 0.8.5.1-5.17.201512031309 0 500 https://updates.software-univention.de/4.1/maintained/ 4.1-1/amd64/ Packages 100 /var/lib/dpkg/status 0.8.5.1-5.15.201410201741 0 500 https://updates.software-univention.de/4.0/maintained/ 4.0-0/amd64/ Packages

sources.list.d files don’t appear to be up to date as they don’t reference https://updates.software-univention.de/4.1/maintained/ 4.1-2/amd64/ Packages as your system.

Going to the package section of UCS shows several packages have upgrades, but if I try to update any package it fails with errors stating all the dependent packages need to be updated, removed, or reinstalled?

Is there an easy way to correct the system without effecting the UCS functions? Computer systems are not my occupation, so I don’t work with this on a daily bases. I switched from Fedora to UCS to explore or hope to find a solution where I didn’t have to tweak configurations each time upgrades was necessary.

Your help is welcomed and appreciated.


#5

I’d remove the Jessie-repository and try again.
UCS 4.1 is based on Wheezy. Beside that in most cases there is no reason to use the Upstream-Repositories.

Best Regards,
Dirk Ahrnke


#6

Ahrnke,

I noticed the same thing right after I posted the last reply! I removed the Repository and re-started the update. It seams to be working. The Jessie-repository was added to install a package for Zarafa Webapp Plugin that I no longer use. I forgot to clean this up.

Thank you for the help!!!


#7

The system upgraded without issue once the Jessie-Repository was removed! I didn’t notice UCS was based on Wheezy vs. Jessie, I am glad I did not start trying to fix things via the command line myself. That would have been a real mess!