Upgrade to errata1009 Domain Master broken

Good Morning,
after the Upgrade to Errata1009 the file /etc/apache2/sites-available/univention-proxy.conf is missing.

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2021-07-19 08:41:10 CEST; 9s ago
  Process: 17650 ExecStop=/usr/sbin/apachectl stop (code=exited, status=1/FAILURE)
  Process: 489 ExecReload=/usr/sbin/apachectl graceful (code=exited, status=0/SUCCESS)
  Process: 17657 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
 Main PID: 25337 (code=exited, status=0/SUCCESS)
      CPU: 57ms

Jul 19 08:41:10 dc1 systemd[1]: apache2.service: Unit entered failed state.
Jul 19 08:41:10 dc1 systemd[1]: apache2.service: Failed with result 'exit-code'.
Jul 19 08:41:10 dc1 systemd[1]: Starting The Apache HTTP Server...
Jul 19 08:41:10 dc1 apachectl[17657]: apache2: Syntax error on line 225 of /etc/apache2/apache2.conf: Syntax error on line 61 of /etc/apache2/sites-enabled/univention-saml.conf: Could not open configuration file /etc/apache2/sites-available/univention-proxy.conf: No such file or directory
Jul 19 08:41:10 dc1 apachectl[17657]: Action 'start' failed.
Jul 19 08:41:10 dc1 apachectl[17657]: The Apache error log may have more information.
Jul 19 08:41:10 dc1 systemd[1]: apache2.service: Control process exited, code=exited status=1
Jul 19 08:41:10 dc1 systemd[1]: Failed to start The Apache HTTP Server.
Jul 19 08:41:10 dc1 systemd[1]: apache2.service: Unit entered failed state.
Jul 19 08:41:10 dc1 systemd[1]: apache2.service: Failed with result 'exit-code'.

This leads to a not accessible Univention-Portal.

root@dc1:~# univention-app info
UCS: 4.4-8 errata1009
Installed: admindiary-backend=1.0 admindiary-frontend=1.0 dhcp-server=12.0 mobydick=1.0.0 pkgdb=11.0 samba4=4.10 self-service=                                                                                                                                                                                                                                                            4.0 self-service-backend=4.0
Upgradable:

I tryed to copy that file from my not updated second server and modified the fqdn in it. This brings back a Login, but after Login i get an 404: image

Maybe somone knows a solution

Looks like there is much more broken than it looks on first sight.
I moved from pve to VmWare and installed vmware-tools into it. While installing the tools i noticed that there are a couple of Programs maked as “no longer needed”

Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  bc cgroupfs-mount containerd docker.io git git-man
  golang-docker-credential-helpers heimdal-kdc heimdal-servers ifplugd
  libapache2-mod-authnz-pam libapache2-mod-wsgi libdaemon0 liberror-perl
  libfile-copy-recursive-perl libio-socket-inet6-perl libirs141
  libkdc2-heimdal libmcrypt4 libsecret-1-0 libsecret-common
  libsnmp-session-perl libsocket6-perl libxkbfile1 libyaml-0-2
  linux-image-4.9.0-14-amd64 linux-image-4.9.0-14-amd64-signed mrtg
  nfs-kernel-server openbsd-inetd pass php-curl php-krb5 php-ldap php-mcrypt
  php-memcache php7.0-curl php7.0-ldap php7.0-mcrypt pigz python-alabaster
  python-babel python-babel-localedata python-bs4 python-cherrypy3
  python-click python-colorama python-decorator python-defusedxml
  python-formencode python-genshi python-html5lib python-imagesize
  python-jinja2 python-lxml python-mako python-markupsafe python-memcache
  python-mimeparse python-paramiko python-paste python-pexpect python-psutil
  python-ptyprocess python-reportlab python-reportlab-accel python-repoze.lru
  python-repoze.who python-routes python-ruamel.ordereddict python-ruamel.yaml
  python-sphinx python-tempita python-trml2pdf python-typing
  python-univention-directory-manager-rest python-univention-directory-reports
  python-uritemplate python-urllib3 python-webencodings python-webob
  python-yaml python-zope.interface python3-cached-property python3-chardet
  python3-defusedxml python3-dockerpty python3-dockerpycreds python3-docopt
  python3-jsonschema python3-texttable python3-urllib3 python3-websocket
  python3-yaml runc simplesamlphp sphinx-common stunnel4 tree
  univention-apache univention-apache-vhost univention-bind
  univention-directory-manager-rest univention-directory-notifier
  univention-directory-reports univention-docker univention-firewall
  univention-heimdal-kdc univention-ifplugd univention-ldap-acl-master
  univention-ldap-config-master univention-license-import
  univention-maintenance univention-maintenance-mode
  univention-management-console-frontend univention-management-console-login
  univention-management-console-module-ipchange
  univention-management-console-module-join
  univention-management-console-module-mrtg
  univention-management-console-module-passwordchange
  univention-management-console-module-quota
  univention-management-console-module-reboot
  univention-management-console-module-services
  univention-management-console-module-setup
  univention-management-console-module-sysinfo
  univention-management-console-module-top
  univention-management-console-module-ucr
  univention-management-console-module-udm univention-nfs-server
  univention-policy-tools univention-quota univention-role-common
  univention-role-server-common univention-saml univention-saml-schema
  univention-server-overview univention-system-info univention-system-setup
  univention-web-js univention-web-style update-inetd x11-xkb-utils xclip
  xmlsec1
Verwenden Sie »apt autoremove«, um sie zu entfernen.

As this is my Domain Master these Packages sound to me like they should not be uninstalled.

My Question now is: What needs to be reinstalled to bring back my UMC?
The Domain is now unconfigureable as the Domain-Backup-Server throws an Error when i try to configure anything from there. : image

Any help would be very appreciated.

Greetings
Matthias

Have you tried to run:

ucr commit /etc/apache2/sites-available/univention-proxy.conf

if missing the file will be created.

Thank you for that hint.
I already tryed ucr commit to recreate all configs with no success.

After your post i run again the command to recreate univention-proxy.conf without any filechange

root@dc1:~# ls /etc/apache2/sites-enabled/
000-default.conf      univention-self-service.conf     univention-vhosts.conf
default-ssl.conf      univention-server-overview.conf
univention-saml.conf  univention-udm.conf
root@dc1:~# ucr commit /etc/apache2/sites-available/univention-proxy.conf
root@dc1:~# ls /etc/apache2/sites-enabled/
000-default.conf      univention-self-service.conf     univention-vhosts.conf
default-ssl.conf      univention-server-overview.conf
univention-saml.conf  univention-udm.conf

As i noticed that all those packages are marked obsolete i guess the source for recreating these files is not installed anymore.

I wonder if promoting the backup server to master and demote this broken Wreck would be a working solution instead of try to repair this messed up server?